Alignement left et right selon menus...Important !

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Alignement left et right selon menus...Important !

    Bonjour à tous,

    J'ai besoin d'un coup de main réel et pour une fois urgent car je travail sur un site personnel (Portail Plongée) depuis 4 mois et celui-ci doit être mit en ligne le 05/06 au plus tard (Un artiste intégré dans le site fais une newsletter et parle du site donc ce dernier doit être visible au moment de l'envoi).
    J'ai fais pas mal de modifs au niveau du template (template trouvé sur le web intitulé drc_bluewave), notamment design photoshop, et personnalisation CSS des modules et composants.

    Mon problème est le suivant :
    (Pour info j'utilise infinity_menus au niveau du menu gauche)
    Test sous firefox:

    1/ Quand j'arrive sur la page d'accueil du site, la colonne left est très bien (voir image jointe "AccueilLeftBien"). Concernant la colonne de droite, j'ai les titres qui sont tous décalé à droite en débordement du template (voir image jointe "AccueilRightProbleme"). J'ai pourtant TOUT tester (modifs dans infinitymenu, Css, index.phph...) sans trouver la solution.

    2/ Curieusement, quand je clic sur le menu pour accéder au contenu d'une catégorie ou un module ou composant, le problème est inverse: la colonne left se décale à droite au niveau des titres des menus (voir image jointe "ArticlesLeftProbleme"). Concernant la colonne de droite, celle-ci est parfaitement alignée (voir image jointe "ArticlesRightBien").

    Je ne comprend pas et j'ai vraiment des sueurs froides...

    J'ai joint l'index.php et le CSS.

    Je remercie vraiment la personne qui pourra jeter un oeuil et m'expliquer l'origine du souci.

    Jérôme
    Fichiers joints
    Dernière édition par jhautier à 01/06/2006, 17h17

  • #2
    bonjour
    en fait j'ai telecharger le template pour le tester
    bon tu a lair d'avoir fait des modifs mais je n'ai pas encore regarder
    mais si j'instal le templat original j'obtien un resultat tres different
    que si je prends tes fichiers
    voir miniature
    (et cela avec le menu original de joomla)
    je vais jeter un oiel mais sans promesse(je débute)
    mais un pro de la feuille de style va peut etre se manifester
    courage
    Alzeihmer .........de bonne heure
    je sais faire le café et le thé.................

    Commentaire


    • #3
      grrrrrrrrr j'ai loupé les miniatures
      Fichiers joints
      Alzeihmer .........de bonne heure
      je sais faire le café et le thé.................

      Commentaire


      • #4
        Bonsoir et merci de prendre le temps de regarder.

        C'est normal si le template ne s'affiche pas correctement car il y a certaines zones avec des images fixes (Ex: la bulle de plongée avec le texte "Menus").

        A mon avis le problème vient de l'index et/ou du CCS.

        C'est en effet (il faut peut être le préciser un "Template Modulable"), qui s'étend sur la droite selon la résolution du poste de l'internaute (800x600, 1024...).

        J'attends avec impatience les conseils des spécialistes des feuilles de style.

        Merci

        Jerome

        Commentaire


        • #5
          Je viens de tester ton template avec infinity_menus, et effectivement il y a un problème mais il ne vient pas de ton template mais des différentes feuilles de styles utilisé par infinity_menus.

          J'ai donc testé avec D4M TransMenu v1.3 que tu trouveras ici et là tout marche impeccable, alors à toi de voir
          www.joomlartefact.org
          - Atelier Templates
          - Tutos, Démo Templates et Extensions pour Joomla!
          - Hébergement gratuit de Projets Joomla

          Commentaire


          • #6
            Merci beaucoup Gaia.

            Je vais tester et vous tient au courant.

            Une question: tu as fais les tests sour IE ou firefox ?

            J'ai fais un test sous IE (même template et infinity menu) et sur certaines pages, le texte du body est "tronqué" et réduit à moitié, alors que sous firefox, pas de problème.

            As-tu le même soucis ?

            A plus tard.

            Jerome

            Commentaire


            • #7
              Oui j'ai testé le menu sur les 2 et c'est ok.

              Pour le texte du body effectivement, il y a une différence entre FF et IE, et en passant ce template est vraiment une grosse me*de codé avec les pieds (et encore, il avait du garder sa paire de boots ).

              Si tu veux un coup de main fait passer par mail le template complet (images comprises) ainsi que la liste des modules que tu utilises avec leur position.
              www.joomlartefact.org
              - Atelier Templates
              - Tutos, Démo Templates et Extensions pour Joomla!
              - Hébergement gratuit de Projets Joomla

              Commentaire


              • #8
                Bonjour Gaia,

                C'est sympa de me proposer de "regarder" le template de plus près.

                Au niveau des modules (et composants ?) ainsi que leurs positions, je peux te l'adresser par mail sans souci. Mais si tu fais des modifs sur le code du template et que je modifie à terme les positions et/ou l'ajout de modules, que va-t-il se passer ? Ce sera possible quand même ?

                Merci par avance de tes éclaircissements.

                Jerome

                Commentaire


                • #9
                  Oui pas de soucis, c'est juste pour pouvoir reproduire les conditions de fonctionnement de ton site au plus juste.
                  www.joomlartefact.org
                  - Atelier Templates
                  - Tutos, Démo Templates et Extensions pour Joomla!
                  - Hébergement gratuit de Projets Joomla

                  Commentaire


                  • #10
                    Merci Gaia.

                    Je prépare tout cela et te l'envoi ce matin.

                    Jerome

                    Commentaire


                    • #11
                      bonjour
                      bien sur je n'ai pas tout les elements en main mais lorque j'ai ton template modifié installé j'ai effectivement un decalage dans la mise en fome des "cadres" et cela en depit de tes propres image
                      en fait lorsque je met ton index et ton template je me retrouve avec la 1ere miniature alors qu'avec l'index et le template original le left et le top ne se chevauche pas ce qui a mon avis est une situation normale
                      pour remettre le top (voir la 2eme miniature j'ai modifié j'ai modifié dans ton index la ligne suivante qui était
                      Code:
                      <td width="26" rowspan="3" valign="top">
                            <IMG SRC="/templates/drc_bluewave/images/spacer.gif" WIDTH=15 ALT=""></td>
                            <td width="383" height="18" valign="top"><?php mosLoadModules ( 'top' ); ?>
                      en remetant le td width a 10 (valeur d'origine du template)
                      Code:
                      <td width="10" rowspan="3" valign="top" >
                            <IMG SRC="/templates/drc_bluewave/images/spacer.gif" WIDTH=15 ALT=""></td>
                            <td width="383" height="18" valign="top"><?php mosLoadModules ( 'top' ); ?>
                      cela de mon coté remet au moin les cadre du left top et right dans un bon alignement(voir miniature 2)
                      bien sur il s'agit d'un test en local ,avec seulement un bout de fichier et les images d'origine du fichier
                      mais il est vrai que déja dans ces condition j'ai un decalage dans le placement de ces cadres et que personelement je ne trouve pas ceci "tres sain
                      par contre je ne peut te dire quel impact cela aurait sur l'ensemble de ton site

                      mais bon je débute dans joomla alors si cela ne fait pas avncer le schmilblick je fait mes excuses
                      Fichiers joints
                      Alzeihmer .........de bonne heure
                      je sais faire le café et le thé.................

                      Commentaire


                      • #12
                        Salut Jérome,
                        tu pourrais pas remettre l'accès au site par hasard, juste pour voir ?
                        On pourrait poser un diagnostic peut etre plus précis, puisque dans les vrais conditions.

                        Didier

                        Commentaire


                        • #13
                          Bonjour à tous,

                          Pour Gaia: je viens de t'adresser les fichiers par mail

                          Pour Claudee: Merci beaucoup de tes tests et du temps passé. Je vais peut être attendre un premier retour de Gaia et Didier Rocher avant de faire des tests (et des bêtises !....). Merci en tout cas pour la piste.

                          Pour Didier: j'ai mis le site en ligne ICI (pendant 1h ou 2h pour éviter que trop de personnes se rendent sur le site sachant qu'il n'est pas terminé !...)

                          Une fois en ligne, je ferais un article dans la rubrique "Nouveau Sites" pour en parler en détails (Modules, composants...).

                          Merci vraiment à tous les 3. Je traverse une période "familiale" extrêmement difficile et "noire" et ce site représente beaucoup pour m'aérer l'esprit et "reprendre goût à la vie".

                          Je ne vais pas étaler mes problèmes persos, ce n'est pas l'objectif du site, mais sachez, que votre contribution peut pafois, sans le savoir, apporter plus qu'un "soutien technique".

                          Jérôme
                          Dernière édition par jhautier à 31/05/2006, 09h28

                          Commentaire


                          • #14
                            Je modifie mon jugement sur ce template :
                            Il avait des boots + des raquettes aux pieds !!!!

                            Un autre constat, le CSS est vraiment limité au strict minimum, et encore c'est limite !!
                            Après avoir passé 45mn dans l'index.php a essayer de rectifier toutes les erreurs du style
                            <TABLE WIDTH=100% BORDER=0 CELLPADDING=0 CELLSPACING=0>
                            <TR>
                            <TD>
                            <IMG SRC="/templates/drc_bluewave/images/topleft.jpg" WIDTH=199 HEIGHT=50 ALT=""></TD>
                            <TD width="100%">
                            <IMG SRC="/templates/drc_bluewave/images/topright.jpg" WIDTH=100% HEIGHT=50 ALT=""></TD>
                            </TR>
                            et d'essayer de bloquer le fond du menu ainsi que les th associés, je pense qu'il est plus rapide vu la simplicité relative de ce template de le recoder proprement html et css.

                            A moins que Didier est trouvé quelque chose car, pour être honnête, ce genre de conception de template me gonfle

                            Si pas de solutions, je veux bien essayer de te faire un truc vite fait mais bien fait
                            www.joomlartefact.org
                            - Atelier Templates
                            - Tutos, Démo Templates et Extensions pour Joomla!
                            - Hébergement gratuit de Projets Joomla

                            Commentaire


                            • #15
                              Bonjour Gaia,

                              Heu... je suis plus mer que montagne (cf mon site), donc pour les boots et les raquettes, je ne peux pas me prononcer !.........

                              Concernant ta remarque on peut peut être voir ce qu'en pense Didier, avant de se lancer dans de "grands travaux".

                              S'il faut refaire une partie du travail (!) et que cela nécessite du temps et une contrepartie financière, je trouverai cela normal (dans la limite de mes petits moyens...), je te tél alors pour voir comment on procède.

                              On attend les remarques de Didier et on reprend contact après.

                              Merci Gaia.

                              Jerome

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X