Probleme d'installation de mon template perso

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Probleme d'installation de mon template perso

    Bonjour,
    Je suis confronté à un problème avec l'installation du template que j'ai créé de A à Z pour mon site en joomla.

    Mon template s'appel 'BOB', il contient les dossier [images] et [css] et à la racine, il y a les fichiers 'index.php' et 'templateDetails.xml' (qui contient le détail des fichiers à installer)

    Je crée un archive .zip, et ensuite je tente de l'uploader via l'admin de mon site en utilisant le menu [site template]

    j'ai alors l'erreur "ERROR: Could not find a Joomla! XML setup file in the package."

    Le système est bien paraméttré puisque j'arrive à installer n'importe quel Template downloadé depuis joomla.fr ...



    Voici le détail de mon fichier 'templateDetails.xml' :

    <?xml version="1.0" encoding="iso-8859-1"?>
    <mosinstall type="template">
    <name>bob</name>
    <creationDate>30/08/06</creationDate>
    <author>Wiliam</author>
    <copyright>(c) S.A.R.L BOB 2006</copyright>
    <authorEmail>bob@bob.com</authorEmail>
    <authorUrl>http://www.bob.com/</authorUrl>
    <version>1.02</version>
    <description>Template Générique.</description>
    <files>
    <filename>index.php</filename>
    <filename>template_thumbnail.png</filename>
    </files>
    <images>
    <filename>images/b.gif</filename>
    <filename>images/background_content.jpg</filename>
    <filename>images/background_menu.jpg</filename>
    <filename>images/bl.gif</filename>
    <filename>images/br.gif</filename>
    <filename>images/footer_center.jpg</filename>
    <filename>images/footer_left.jpg</filename>
    <filename>images/footer_right.jpg</filename>
    <filename>images/l.gif</filename>
    <filename>images/l2.gif</filename>
    <filename>images/r.gif</filename>
    <filename>images/r1.gif</filename>
    <filename>images/r2.gif</filename>
    <filename>images/spacer.gif</filename>
    <filename>images/t.gif</filename>
    <filename>images/tl.gif</filename>
    <filename>images/top_banner.jpg</filename>
    <filename>images/top_logo.jpg/filename>
    <filename>images/tr.gif</filename>
    </images>
    <css>
    <filename>css/template_css.css</filename>
    </css>
    </mosinstall>
    tous les nom de fichiers sont Ok, copier/collés depuis l'explorer vers le fichier, comptés et recomptés ... comparé aux fichiers xml de templates téléchargés ...

    Merci pour vos lumières.
    Dernière édition par Billox à 24/08/2006, 14h01

  • #2
    essaye en mettant :
    Code:
    <mosinstall type="template" version="1.0.x">
    cours de SVT - infos scientifiques : www.nicolas-ogier.fr
    pas de demandes d'aide par mp, elles seront systématiquement refusées !

    Commentaire


    • #3
      #### de fichiers .GIF !!

      Bon, en fait g solutionner .... c'est bête mais sa m'as bouffé 4heures de ma vie : en fait la présence de fichier .gif empêche l'installation et produit cette erreur ... je me souviens bien avoir lu qqchose à l'époque sur sa ... donc si vous faites vous même votre Template attention préférez le png (png 8bit) pour vos images avec transparence.

      Commentaire


      • #4
        Salut,

        C'est très curieux ton probléme.
        Le message d'erreur indique que joomla ne trouvais pas le fichier setup.
        Tu es certain que tu avais pas encapsulé des fichiers dans une arborescence de dossier ?
        Je vois pas comment un fichier gif peut interdire l'upload. Il ne lit pas les fichiers.

        Papounet
        I'am happy for you !
        Dernière réalisation : http://www.pierrickservais.com/

        Commentaire


        • #5
          Oui c'est trés curieux en effet mais j'ai fais toutes les vérifs possibles et imaginables. Oui mon arborescence était ok, ainsi que les noms de fichiers à installer et leurs chemins ... c'est en épluchant les .zip de templates prés fabriqués (tmpl_business_plate.zip,clean_blue.zip etc....) que j'ai constaté l'abscence de fichiers .gif ... j'ai donc remplacé mes .gif par des .png (8bit) et là l'installation via l'admin a fonctionné.

          voici le détail de mon système :
          -Joomla 1.0.9 (avec installation sans pré-remplissage de la base) upgradé vers 1.0.10
          -JCE 1.0.4
          -letterman 1.2.2
          -facil form 1.4.4

          serveur:
          PHP built On: Linux sylvester.devel.redhat.com 2.4.20-2.41smp #1 SMP Sun Feb 9 09:29:47 EST 2003 i686 athlon i386 GNU/Linux
          Database Version: 3.23.54
          PHP Version: 4.2.2
          Web Server: Apache/2.0.40 (Red Hat Linux)
          WebServer to PHP interface: apache2filter
          Joomla! Version: Joomla! 1.0.10 Stable [ Sundown ] 26 June 2006 00:00 UTC
          User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
          Relevant PHP Settings:
          Safe Mode: OFF
          Open basedir: /home/httpd/vhosts/xxxxxxxx.com/httpdocs:/tmp
          Display Errors: ON
          Short Open Tags: ON
          File Uploads: ON
          Magic Quotes: ON
          Register Globals: OFF
          Output Buffering: OFF
          Session save path: /tmp
          Session auto start: 0
          XML enabled: Yes
          Zlib enabled: Yes
          Disabled Functions: none
          WYSIWYG Editor: No WYSIWYG Editor
          voilà ... a suivre

          Commentaire


          • #6
            Ah!

            Tes gifs etaient obtenus comment ?
            Soft et sauvegardes ?

            Il faut que l'on comprenne...
            I'am happy for you !
            Dernière réalisation : http://www.pierrickservais.com/

            Commentaire

            Annonce

            Réduire
            1 sur 2 < >

            C'est [Réglé] et on n'en parle plus ?

            A quoi ça sert ?
            La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

            Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

            Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
            Comment ajouter la mention [Réglé] à votre discussion ?
            1 - Aller sur votre discussion et éditer votre premier message :


            2 - Cliquer sur la liste déroulante Préfixe.

            3 - Choisir le préfixe [Réglé].


            4 - Et voilà… votre discussion est désormais identifiée comme réglée.

            2 sur 2 < >

            Assistance au forum - Outil de publication d'infos de votre site

            Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

            Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

            Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

            UTILISER À VOS PROPRES RISQUES :
            L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

            Problèmes connus :
            FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

            Installation :

            1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

            Archive zip : https://github.com/AFUJ/FPA/zipball/master

            2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

            3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

            4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

            5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

            6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
            et remplacer www. votresite .com par votre nom de domaine


            Exemples:
            Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
            Télécharger le script fpa-fr.php dans: /public_html/
            Pour executer le script: http://www..com/fpa-fr.php

            Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
            Télécharger le script fpa-fr.php dans: /public_html/cms/
            Pour executer le script: http://www..com/cms/fpa-fr.php

            En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

            Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
            Voir plus
            Voir moins
            Travaille ...
            X