Joomladay francophone 2018 à Paris 18 et 19 mai

Compatibilité IE7 ?

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Compatibilité IE7 ?

    Bonjour !
    Je suis assez novice.. voir très novice ! J'essaie de faire un site perso, pas forcement très beau (on verra pour ça quand je seraizs plus douée !)

    J'utilise Mozilla comme navigateur, et lorsque j'ai tout mis en place, pas de souci

    Mais voilà, j'ai constaté sur un autre ordi qui utilise IE7 que mon haut de page est tout décallé, c'est moche

    Je n'ai pas trouvé en parcourant le forum de réponse qui me semble correpondre à mon problème...
    Merci de me mettre un lien si c'était le cas

    le site en question : www.plongeuse.eu
    Dernière édition par Florence à 15/06/2007, 18h09
    www.plongeuse.eu

  • #2
    Bonjour,
    dans l'index.php de ce template, il y a cette portion de code :
    <td height="100" colspan="2" style="padding-top:14px;">
    <table width="100%" border="0" cellpadding="0" cellspacing="0">
    <tr>
    <td width="100%" style="padding-left:10px;">
    <a class="title" href="<?php echo $mosConfig_live_site;?>" title="<?php echo $mosConfig_sitename; ?>">
    <?php echo $mosConfig_sitename; ?></a>
    <br/>Some interesting Slogan here!
    </td>
    <td><?php mosLoadComponent( "banners" ); ?></td>
    </tr>
    </table>
    </td>
    Il faut la modifier de cette manière:
    <td height="100" colspan="2" >
    <table width="100%" border="0" cellpadding="0" cellspacing="0">
    <tr>
    <td width="100%" style="padding-left:10px;">
    <a class="title" href="<?php echo $mosConfig_live_site;?>" title="<?php echo $mosConfig_sitename; ?>">
    <?php echo $mosConfig_sitename; ?></a>
    <br/>Some interesting Slogan here!
    </td>
    <td style="padding-top:14px;"><?php mosLoadComponent( "banners" ); ?></td>
    </tr>
    </table>
    </td>
    Pour info, on en avait parlé là :
    http://forum.joomla.fr/showthread.ph...ghlight=portal
    et là
    http://forum.joomla.fr/showthread.ph...ight=247portal

    Ce que j'ai mi plus jaut est une autre alternative. Je pense.
    Si ça fonctionne pas, dis nous.
    Didier

    Commentaire


    • #3
      Bonjour
      Merci ! Je teste ça ce soir !
      www.plongeuse.eu

      Commentaire


      • #4
        En partie résolu

        Bonjour !

        Après avoir effectué les changements ci dessus, merci, le cadre s'affiche correctement désormais, merci !

        Mais cela m'a décallé sur tous les navigateurs pour lesquels j'ai possibilité de visionner , mon bandeau en flash....

        Auriez vous une idée qui me serait lumineuse pour le replacer correctement ??

        Merci encore !!!
        www.plongeuse.eu

        Commentaire


        • #5
          Bonjour,
          tu as fais la moitié du boulot.
          si tu regardes un peu plus haut, j'avais indiqué de modifier :
          <td><?php mosLoadComponent( "banners" ); ?></td>
          en
          <td style="padding-top:14px;"><?php mosLoadComponent( "banners" ); ?></td>
          Et c'est pas fait sur ce que je vois en ligne ( oui, j'ai des dons de voyance ).
          Dailleurs, il faut améliorer un peu sinon, tu vas nous dire que le titre est un peu trop décalé cers le haut.
          Modifions donc :
          <td width="100%" style="padding-left:10px;">
          en
          <td width="100%" style="padding-left:10px;padding-top:14px;">
          Récap de ce à quoi doit ressembler ton code :
          <td height="100" colspan="2" >
          <table width="100%" border="0" cellpadding="0" cellspacing="0">
          <tr>
          <td width="100%" style="padding-left:10px;padding-top:14px;">
          <a class="title" href="<?php echo $mosConfig_live_site;?>" title="<?php echo $mosConfig_sitename; ?>">
          <?php echo $mosConfig_sitename; ?></a>
          <br/>Some interesting Slogan here!
          </td>
          <td style="padding-top:14px;"><?php mosLoadComponent( "banners" ); ?></td>
          </tr>
          </table>
          </td>
          Et cette fois on lit tout jusqu'au bout.
          Didier

          Commentaire


          • #6
            Merci,
            j 'essaie, j'essaie, mais je crois que j'ai encore un bug....

            Bon, je regarde ça dans une heure, je vais m'aérer
            www.plongeuse.eu

            Commentaire


            • #7
              rien à faire, cela est tout décallé partout... Le boulet suis-je.....

              (logiquement, j'ai tout mis jusqu'en bas ce coup ci....)
              www.plongeuse.eu

              Commentaire


              • #8
                Salut,
                en ligne on a toujours pas les modifications.
                Donc ça peut pas etre aligné correctement.
                Es tu sure de faire sur le bon fichier ? ( ca arrive souvent ce genre de boulette ).
                Si tu fais en local, es tu certaine que ton fichier est correctement uploadé sur le serveur?

                Didier

                Commentaire


                • #9
                  Bonjour,
                  Bien , j'édite le fichier HTML (direct sur le serveur) de mon template...
                  En fait lorsque je rajoute
                  <td style="padding-top:14px;">
                  rien ne se passe....comme si la commande n'était pas prise en compte...?
                  www.plongeuse.eu

                  Commentaire


                  • #10
                    As tu les droits en écriture pour ce fichier?

                    Didier

                    Commentaire


                    • #11
                      je crois oui, (super admin)
                      toutes les autres modifs fonctionnent, sauf ce code là....
                      Dernière édition par Florence à 15/06/2007, 13h49
                      www.plongeuse.eu

                      Commentaire


                      • #12
                        Bon,
                        je ne sais pas pourquoi cela fait ça. Il faudrait accéder au serveur.
                        On a une autre solution à laquelle je viens de penser.
                        Essaies de mettre ceci dans ta feuille de style template_css.css :
                        td.title center{padding-top:14px;}
                        A la fin par exemple.
                        Firefox va le prendre. Opera itou. Reste à voir nos ami IE 6 et 7.
                        Dès que tu as fait je regarde.
                        J'attends.

                        Didier

                        Commentaire


                        • #13
                          Merci !!

                          J'ai fait le changement, ça foncionne sous mozilla, et je viens de vérifier sous IE7 aussi ! (je n'ai pas de versions antérieurs pour IE sous la main )

                          Merci beaucoup pour tes précieux conseils !!!
                          www.plongeuse.eu

                          Commentaire


                          • #14
                            C'est bon sous IE6.

                            Didier

                            Commentaire

                            Annonce

                            Réduire
                            1 sur 2 < >

                            C'est [Réglé] et on n'en parle plus ?

                            A quoi ça sert ?
                            La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                            Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                            Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                            Comment ajouter la mention [Réglé] à votre discussion ?
                            1 - Aller sur votre discussion et éditer votre premier message :


                            2 - Cliquer sur la liste déroulante Préfixe.

                            3 - Choisir le préfixe [Réglé].


                            4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                            2 sur 2 < >

                            Assistance au forum - Outil de publication d'infos de votre site

                            Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                            Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                            Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                            UTILISER À VOS PROPRES RISQUES :
                            L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                            Problèmes connus :
                            FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                            Installation :

                            1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                            Archive zip : https://github.com/AFUJ/FPA/zipball/master

                            2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                            3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                            4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                            5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                            6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                            et remplacer www. votresite .com par votre nom de domaine


                            Exemples:
                            Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/
                            Pour executer le script: http://www..com/fpa-fr.php

                            Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/cms/
                            Pour executer le script: http://www..com/cms/fpa-fr.php

                            En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                            Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                            Voir plus
                            Voir moins
                            Travaille ...
                            X