Joomladay francophone 2018 à Paris 18 et 19 mai

Probleme de gestion de template

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Probleme de gestion de template

    Bonjour,

    je dois créer un sitepour une petite entreprise, et j'ai donc choisis Joomla!
    J'ai donc un petit problème avec mon template :
    http://www.joomla-club.com/index.php...fileinfo&id=48

    Sur ce template se trouve un 2ème menu, au dessus du "body" de la page.
    J'ai réussi à l'enlever grâce a l'interface Administrateur de Joomla !

    Mais du coup je souhaite que mon corps de page monte pour éviter les ascenseurs !

    J'espère que j'ai été assez clair ! je suppose que il faut modifier le CSS, mais je ne veux pas non plus tout cafouiller !

    Merci d'avance !

  • #2
    tu veux virer les deux espaces que j'ai noté sur l'image? ou simplement celui de droite ?

    si c'est la partie a droite, va voir dans : templates / nom_de_ton_templates / index.php

    et dans ce fichier tu vire la case qui t'embete

    Je suis sur ton problème ou totalement ailleur? :P
    Fichiers joints

    Commentaire


    • #3
      Erf j'ai mal m'exprimer ; le lien que j'ai donné c'est mon template et non pas mon site dsl

      Commentaire


      • #4
        Mais c'est peut être la même solution ! je vais aller jeter un oeil

        Commentaire


        • #5
          Oula l'index est assez compliqué, je vois pas ce que je dois enlever >_<

          Merci au faite =)
          Fichiers joints

          Commentaire


          • #6
            tu es sur de vouloir garder ce templates? sans vouloir critiquer, mais tout est à refaire.

            c'est très mal codé, je sais pas trop comment celà peut marcher sans problème.

            Désolé, mais là je n'aurais pas le temps pour résoudre ton problème.

            [edit] aussi evite de faire des doubles post, utilise la fonction editer

            Commentaire


            • #7
              Désolé pour les 2,3 post en effet j'avais pas trop remarqué le bouton editer
              Pour ce qui est du template, y'a pas de solutions alors ? Sa m'embete un peu car je l'ai choisi avec mon boss avant d'entamer la parti créa ! Si il y vraiment pas de solution je changerai, mais se sera toujours la même chose avec d'autres template si je m'abuse!

              En tout cas, merci !

              Commentaire


              • #8
                ben non il y en a qui sont bien codé tout du moins de manière plus correcte.

                Un simple exemple d'un problème que je vois avec ce template :
                il y a plein de table qui se ferme, mais ils ont jamais été ouvert, ensuite il fait des suites : <tr><td><td><tr></td></tr></td> ...

                ca ne veux plus rien dire... en passant peu de temps à étudier un peu le html, tu arriverais au même résultat avec un autre template... c'est mon avis.

                je suis désolé, je dois etre fatigué, je voyais pas les tables ouvrant... ha ca va mieux, bon le codage est pas très beau mais ca peut passer

                alors fais une sauvegarde de ton fichier, et ensuite essaye de supprimer toutes cette parties la
                Code:
                <tr> 
                                        <td align="left" valign="top"><table width="100%" border="0" cellspacing="0" cellpadding="0">
                                            <tr> 
                                              <td align="left" valign="top"><table width="100%" border="0" cellspacing="0" cellpadding="0">
                                                  <tr> 
                                                    <td align="left" valign="top"><table width="100%" border="0" cellpadding="0" cellspacing="0" id="top">
                                                        <tr> 
                                                          <td align="left" valign="top"><table width="100%" border="0" cellspacing="0" cellpadding="0">
                                                              <tr> 
                                                                <td width="50%" align="left" valign="top"><table width="100%" border="0" cellpadding="0" cellspacing="0" id="user1">
                                                                    <tr> 
                                                                      <td align="left" valign="top"> 
                                                                        <?php mosLoadModules( 'user1', -1 ); ?>
                                                                      </td>
                                                                    </tr>
                                                                  </table></td>
                                                                <td width="50%" align="left" valign="top"><table width="100%" border="0" cellpadding="0" cellspacing="0" id="user2">
                                                                    <tr> 
                                                                      <td align="left" valign="top"> 
                                                                        <?php mosLoadModules( 'user2', -1 ); ?>
                                                                      </td>
                                                                    </tr>
                                                                  </table></td>
                                                              </tr>
                                                            </table></td>
                                                        </tr>
                                                      </table></td>
                                                  </tr>

                Commentaire


                • #9
                  Tu pourrais me dire les lignes car sa se ressemble partout et ce que j'ai suppr sa a supprime tout, il reste plus que le "body"
                  merci =)

                  Commentaire


                  • #10
                    j'ai retiré les lignes, désolé je suis sous wordpad alors je peux pas avoir les lignes :P
                    Fichiers joints

                    Commentaire


                    • #11
                      Envoyé par Schum Voir le message
                      j'ai retiré les lignes, désolé je suis sous wordpad alors je peux pas avoir les lignes :P
                      "Fichier template non trouvé! Le fichier recherché :wintercall_jc"

                      T'aurais pas supprimer un peu trop ?

                      Merci de ton aide quand même

                      Commentaire


                      • #12
                        euh ton erreur ne vient pas d'un problème avec l'index..

                        Commentaire


                        • #13
                          Ah vi autant pour moi !
                          Mais sa ne marche pas quand même ! :/
                          Donc on ne peux pas changer le format ou le remonter du body de la page ?

                          Commentaire

                          Annonce

                          Réduire
                          1 sur 2 < >

                          C'est [Réglé] et on n'en parle plus ?

                          A quoi ça sert ?
                          La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                          Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                          Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                          Comment ajouter la mention [Réglé] à votre discussion ?
                          1 - Aller sur votre discussion et éditer votre premier message :


                          2 - Cliquer sur la liste déroulante Préfixe.

                          3 - Choisir le préfixe [Réglé].


                          4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                          2 sur 2 < >

                          Assistance au forum - Outil de publication d'infos de votre site

                          Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                          Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                          Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                          UTILISER À VOS PROPRES RISQUES :
                          L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                          Problèmes connus :
                          FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                          Installation :

                          1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                          Archive zip : https://github.com/AFUJ/FPA/zipball/master

                          2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                          3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                          4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                          5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                          6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                          et remplacer www. votresite .com par votre nom de domaine


                          Exemples:
                          Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                          Télécharger le script fpa-fr.php dans: /public_html/
                          Pour executer le script: http://www..com/fpa-fr.php

                          Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                          Télécharger le script fpa-fr.php dans: /public_html/cms/
                          Pour executer le script: http://www..com/cms/fpa-fr.php

                          En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                          Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                          Voir plus
                          Voir moins
                          Travaille ...
                          X