Joomladay francophone 2018 à Paris 18 et 19 mai

Animation Flash dans Joomla

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Animation Flash dans Joomla

    Bonjour,
    J’ai une animation flash qui fait appelle à des photos qui sont dans un dossier, quand je modifie le code du Template et que j’intègre l’animation, alors l’animation se joue mais sans photos. « C’est comme si l’animation est isolé, et qu’elle ne puisse pas faire appelle aux photos ».
    Svp si qq’un à une idée qu’il m’aide.
    Merci d’avance.
    Dernière édition par Must à 19/07/2007, 10h16

  • #2
    Svp j’ai vraiment besoin d’aide, je suis bloqué sur cela.

    Commentaire


    • #3
      Personne ne peux m’aidé ?

      Commentaire


      • #4
        Tu sais, les explications que tu nous donnes (relis bien) me font penser qu'il faut jouer les devins !
        Alors je joue le premier : probable confusion dans le chemin d'accès aux photos par rapport à la page affichée ou au répertoire de stockage de l'animation.
        "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

        Commentaire


        • #5
          Désolé si je n’étais pas très clair,
          Je fais un site à l’aide de Joomla en locale (à l’aide de Easy-Php), je voulais intégrer un diaporama fais en flash. Le diaporama flash charge sait images d’un dossier (image qui se trouve à la même place que le .SWF).
          Mais quand j’ai intégrer mon diaporama dans le site, (en modifiant le code de l’index) le site charge le Swf mais le Swf n’arrive pas à charger les images, donc je ne vois que du blanc sur mon site. Après une petite recherche sur le net on ma dit que « quand Joomla génère la page, le flash n'est pas forcément appelé dans le dossier où il se trouve ». Donc on ma proposer d’utiliser « WireShark » pour avoir le chemin exacte, puis de modifier le lien vers les images .
          Mais je ne sais pas s’il est possible d’utiliser se logiciel pour un site en locale (sur Easy-php), et en plus je ne connais pas grands chose sur le logiciel.
          J’esper que c’est un peut plus clair, et que quelqu’un puisse m’aidé.
          Merci,
          Désolé pour la langueur du message.

          Commentaire


          • #6
            salut
            tu mets tes images dans quel dossier par rapport à la racine de ton site?

            exemple :
            /images/stories/imagesflash
            Création de sites web Tunisie : http://www.idealconception.com
            http://www.italianistica-tunisia.com

            Commentaire


            • #7
              Ils sont dans un dossier « image » dans le dossier du Template utilisé(et le Flash « Swf » il est dans le dossier du Template).
              \templates\business_blue\image

              Commentaire


              • #8
                dans flash as tu essayé d'appeler le dossier par son chemain de cette façon?

                /templates/business_blue/image

                et dans ton index.php appelle ton flash de cette façon ........src="/templates/business_blue/tonfichierflash.swf" etc.......

                essaye de voir de ce coté là
                (à mon avis tu devrais utiliser des antislash pas des slash)
                Création de sites web Tunisie : http://www.idealconception.com
                http://www.italianistica-tunisia.com

                Commentaire


                • #9
                  J’ai essayé mais malheureusement ca ne donne rien

                  Commentaire


                  • #10
                    salut fil le code d'intégration de ton flash qu'on regarde.
                    Témoignages, Formations, sur la pratique du logiciel libre sur : http://www.aveclelibre.info

                    Commentaire


                    • #11
                      Voila,

                      <td width="549" align="left" valign="top">
                      <object classid="clsid:\D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,19,0" width="851" height="159" title="head">

                      <param name="movie" value="<?php echo "$GLOBALS[mosConfig_live_site]/templates/$GLOBALS[cur_template]/"; ?>Header.swf" />
                      </object></td>

                      Header.swf c'est mon diaporama.

                      Commentaire


                      • #12
                        justement il ne sais ou aller prendre tes images! regarde ça inspire toi de ça
                        <object classid="clsid27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,29,0" width="851" height="159"align="middle">
                        <param name="movie" value="<?php echo $mosConfig_live_site; ?>/templates/tontemplate/images/tonanim.swf" />
                        <param name="quality" value="high" />
                        <embed src="<?php echo $mosConfig_live_site; ?>/templates/tontemplate/images/tonanim.swf" width="851" height="159" align="middle" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash"></embed>
                        </object>
                        Témoignages, Formations, sur la pratique du logiciel libre sur : http://www.aveclelibre.info

                        Commentaire


                        • #13
                          Je crois que joomla a juste besoin du lien vers le Swf, mais pour les images c’est le swf qui les charges. Donc c’est comme si le flash reste isoler et n’arrive pas à charger les images.
                          Ou peut etre comme j’ai trouve sur des forums, quand Joomla génère la page, le flash n'est pas forcément appelé dans le dossier où il se trouve.

                          Commentaire


                          • #14
                            justement je t'ai filé ce code pour te faire voir un que c'est ton anim qui ne va pas chercher les images dans le bonne endroit essaie de voir si leur position convienne a celle ci biensûr quant elle se trouve dans joomla.
                            Témoignages, Formations, sur la pratique du logiciel libre sur : http://www.aveclelibre.info

                            Commentaire


                            • #15
                              Oui l’anime charge bien les images, quand je la copie l’anime ainsi que le dossier image sur mon site « dans le dossier de mon Template » je l’est essaye et le diapo est parfais. Mais sur le site je ne vois que l’animation sans image.
                              Donc je suis sur que le problème n’est pas du coté de l’animation.

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X