Joomladay francophone 2018 à Paris 18 et 19 mai

La partie « left » bloque au milieu

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • La partie « left » bloque au milieu

    Bonjours, alors voilà je vous explique le tout j’ai pas dormi de la nuit, même pas une minute, et ceci pour réorganiser complètement mon template, j’ai mis le header la haut, et j’ai rétréci les menus

    Mais voilà le problème c’est que toute la partie « left » bloque au milieu, pourquoi ???
    La partie centrale, elle joue la timide et ne veut pas venir jusqu'à mon menu, pourquoi ???

    Je vous joint pour que vous puissiez m’aider le fichier index.php et le fichier template.css
    Ce sont les seuls fichiers que j’ai touché.
    Le site est encore a son debut : www.teleislam.com

    Je vais dormir en espérant que quelqu’un jette un oeil, merci d’avance.
    Fichiers joints
    Dernière édition par Hichem à 06/01/2008, 17h09
    www.spidexweb.com

  • #2
    Ajoute ce que j'ai mis en fuchia dans template_css.css (ligne 20) :
    Code:
    td, tr, p, div {
    color:#CCCCCC;
    font-family:Arial,Helvetica,sans-serif;
    font-size:12px;
    line-height:130%;
    vertical-align:top;
    }
    et vérifie que ça ne provoque pas d'autre problème d'alignement verticaux dans le reste de ton site.

    Ancien pseudo : Fleuve Blanc

    Commentaire


    • #3
      Merci ça a marché directement, pourtant je suis sur de ne pas avoir touché à tout ce bloque avant !!! le plus important c’est que cela marche
      MAIS il reste comme vous pouvez le constater, que la colonne s’arrête directement après, alors que normalement elle descend jusqu’en bas de la page.
      www.spidexweb.com

      Commentaire


      • #4
        Dans ce cas, le <div id="left"> ne sert à rien. Il devrait être supprimé et ça devrait être le <td> qui le contient qui devrait être changé en <td id="left">.

        Ancien pseudo : Fleuve Blanc

        Commentaire


        • #5
          Franchement « Fleuve blanc » tu n’es pas asséché, au contraire tu regorges d’information lol
          J’aurais sûrement passé des heures sur ces petites manipulations lol
          à ce qui paraît c’est comme cela que l’on apprend.
          www.spidexweb.com

          Commentaire


          • #6
            Oui, c'est clair. Après ça va beaucoup plus vite.

            En bonus : en bas de ta page, tu as un problème sous firefox et peut-être d'autres. Tes cellules sont décalés.
            En fait, ça vient de la ligne du dessus ou tu as ça comme code :
            Code:
            <td valign="top" class="left">
            </td>
            Une cellule vide située tout à droite contrairement à ce que sa class laisse entendre. Cette cellule est la 5° dans sa ligne alors que les autre ligne ont 4 cellules.
            Je pense qu'en la supprimant, tu rêgleras probablement le problème en bas de page.

            Ancien pseudo : Fleuve Blanc

            Commentaire


            • #7
              Merci
              Je voulais vous le demander, mais je ne voulais pas abuser lol
              Je l’ai supprimé, ça ma modifié autre chose, moi je pensé que vous parliez du bas de la page que je vous joints une image le montrant…
              Fichiers joints
              www.spidexweb.com

              Commentaire


              • #8
                Je parlais bien de ça et c'est déjà un bon début. Le truc qui manque encore c'est de supprimer ce que je mets en fuchia dans index.php du template :
                Code:
                <td class="leftshadow" width="28" rowspan="3" valign="top"></td>
                <td class="rightshadow" width="28" rowspan="3" valign="top"></td>


                Sinon, qu'est-ce que ça a modifié ?
                Ancien pseudo : Fleuve Blanc

                Commentaire


                • #9
                  en fait il y a c'est deux ligne car normalement, il ya une image à droite et à gauche du footer, c'est pour donner l'effet du dégradé, si on pouvais régler le problème en les laissant sa serai bien lol
                  www.spidexweb.com

                  Commentaire


                  • #10
                    je retire ce que j'ai dit lol
                    sa marche impec,
                    mais il reste toujours le problème cité dans le tout premier message :
                    La partie centrale, elle joue la timide et ne veut pas venir jusqu'à mon menu, pourquoi ???
                    le problème ne se voit que sur Explorer qui affiche une large bande noire
                    si vous terminez par cela vous aurez fini en beauté et moi j’aurai fini mon template lol
                    www.spidexweb.com

                    Commentaire


                    • #11
                      Je ne suis pas sur, mais j'ai l'impression que ça vient du module "Qui est en ligne". En le dépubliant dans l'admin, est-ce que tu as toujours ce problème ?
                      Ancien pseudo : Fleuve Blanc

                      Commentaire


                      • #12
                        Non désolé, je vient de le dé publier, c’est toujours pareil
                        www.spidexweb.com

                        Commentaire


                        • #13
                          Je sens que ça va être prise de tête. IE ne propose pas des outils aussi bien que firebug pour firefox qui permette de trouver rapidement le problème. Il faudra peut-être pas mal de modifs.

                          En voici déjà une de plus :

                          Supprime ce que j'ai mis en fuchia dans template_css.css (un peu après la ligne 191)
                          Code:
                          table.moduletable th {
                          background:#000000 url(../images/module_title.gif) no-repeat scroll left bottom;
                          color:#FFFFFF;
                          font-size:11px;
                          font-weight:bold;
                          height:24px;
                          line-height:24px;
                          margin-top:0pt;
                          text-align:center;
                          text-transform:uppercase;
                          width:159px;
                          }
                          Et sinon, tu peux republier "Qui est en ligne", si tu le souhaites.

                          Ancien pseudo : Fleuve Blanc

                          Commentaire


                          • #14
                            Non plus, je viens d’essayer lol ,
                            mais si vous préférez Mozilla, regardez quand la page se charge, elle vire vers la droite de la même longueur que la bande noire sous Explorer peut être que c’est le même problème
                            www.spidexweb.com

                            Commentaire

                            Annonce

                            Réduire
                            1 sur 2 < >

                            C'est [Réglé] et on n'en parle plus ?

                            A quoi ça sert ?
                            La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                            Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                            Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                            Comment ajouter la mention [Réglé] à votre discussion ?
                            1 - Aller sur votre discussion et éditer votre premier message :


                            2 - Cliquer sur la liste déroulante Préfixe.

                            3 - Choisir le préfixe [Réglé].


                            4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                            2 sur 2 < >

                            Assistance au forum - Outil de publication d'infos de votre site

                            Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                            Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                            Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                            UTILISER À VOS PROPRES RISQUES :
                            L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                            Problèmes connus :
                            FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                            Installation :

                            1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                            Archive zip : https://github.com/AFUJ/FPA/zipball/master

                            2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                            3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                            4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                            5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                            6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                            et remplacer www. votresite .com par votre nom de domaine


                            Exemples:
                            Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/
                            Pour executer le script: http://www..com/fpa-fr.php

                            Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/cms/
                            Pour executer le script: http://www..com/cms/fpa-fr.php

                            En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                            Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                            Voir plus
                            Voir moins
                            Travaille ...
                            X