Joomladay francophone 2018 à Paris 18 et 19 mai

menu "right" marche pas sous IE5 et 6

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • menu "right" marche pas sous IE5 et 6

    Bonjour,

    J'ai longtemps hésité de poster sur ce sujet mais là ca traine trop. J'ai hésité car il s'agit encore d'un problème de compatibilité de navigateur.

    Mais là ca va faire plusieurs mois que mon site tourne très bien SAUF pour les versions obsolète de Internet Explorer.

    En effet, apparemment sur IE5 et IE6, mon menu "right" fait n'importe quoi et il est inactif. C'est assez catastrophique. Dès fois j'oublie, et puis quand je repense à la dose de gens toujours sur IE6 ou IE5 et ben ca m'effraie.

    Je vous laisse le lien : COMPAGNIE LE PUITS.


    senzu
    http://www.compagniexyz.com
    http://www.senzu.net
    http://www.compagniexyz.com
    http://www.lebravesoldatchveik.org

  • #2
    1- Ta page n'est pas valide. Je ne comprends pas trop ce que c'est. Un problème d'encodage d'après le validateur w3c. Regarde ça. Ca provoque des problème sur IE. Si ta page devient valide, ça pourras peut-être règler tes problème pour IE6 qui me donne l'impression de basculer en mode quirks.

    2- Si ça ne suffit pas, sur ta colonne de droite, il faut que tu applique un overflow:hidden; afin que ton image en bas ne l'élargisse pas. Sur ton div id="main", il faut que tu appliques un margin-left:12px; à l'aide d'un commentaire conditionnel ou d'un hack juste pour IE6 et inférieur.

    3- Cette image en png transparent ne passe pas sur IE6 et inférieur sans utiliser un code pour fixer le png. Il existe un module pour joomla qui fait ça.

    4- Tu as aussi des problèmes dans ton en-tête avec un div id=header2 qui a aussi besoin d'un overflow:hidden;

    Ancien pseudo : Fleuve Blanc

    Commentaire


    • #3
      Envoyé par fleuveblanc Voir le message
      à l'aide d'un commentaire conditionnel ou d'un hack juste pour IE6 et inférieur.
      Merci. Je vais étudier tout ce que tu me dis, ca m'a l'air très éclairé. J'ai cité une de tes phrases les plus obscures pour moi.
      Je te tiens au courant. N'hésite de préciser par rapport à la quote si tu as le temps.ENCORE MERCI.
      http://www.senzu.net
      http://www.compagniexyz.com
      http://www.lebravesoldatchveik.org

      Commentaire


      • #4
        Les commentaires conditionnels sont conseillé par microsoft : http://www.css4design.com/blog/index...r-vs-hacks-css

        Mais il est aussi possible d'utiliser des hacks : http://zonecss.free.fr/courscss/cour...le_css_31.html

        A toi de choisir. Perso, je n'ai pas encore assez de recul pour avoir fait un vrai choix entre les 2.

        Ancien pseudo : Fleuve Blanc

        Commentaire


        • #5
          Hello !

          Effectivement, tu es en vrac sous IE6

          Tu as ca dans ton css :
          #sidebar{
          display: block;
          float:right;
          width:210px;
          height: px;
          margin-right:25px;
          padding:5px;
          background-image:url(../images/ane9DOWN.jpg);
          background-repeat:no-repeat;
          }

          et IE aime pas les padding et margin sur les blocs.....
          Tu devrais tester en virant ces padding et margin...
          Tu dois en avoir ailleurs, j't'avoue, j'ai pas fouiné, mais dèjà ce bloc la ce décalle car il ne rentre plus dans ta largeur...

          A priori, c'est pas trop galère !

          Commentaire


          • #6
            Ha enfin ! Enfin une avancée ! Mais pas eu le temps aujourd'hui d'essayer vos conseils (par contre j'ai zyeuté le site web sur les commentaires conditionnels et je me suis dis aussi : Ha voilà enfin !

            Franchement, c'est un sujet tellement opppressant que je me dis qu'il devrait y avoir presqu'un sous-forum entier sur le forum de joomla.

            "La compatilibité entre navigateur", ne peut-on pas dignement l'élire problème numéro 1 des webmasters ?
            J'espère que je vais arriver au bout de mes ennuis, mais en tout cas vous m'avez motivé.

            En plus de tout ca apparemment des navigateurs y'en a au moins quinze (si on intègre toutes les versions en vogue).

            Bon mais restons sur l'intégration de IE5 et6.

            Amitiés,

            senzu
            http://www.senzu.net
            http://www.compagniexyz.com
            http://www.lebravesoldatchveik.org

            Commentaire


            • #7
              Salut à tous,

              Bon j'ai fait des essais avec ce que vous m'avez dit (les commentaires conditionnel and co), et j'ai réussi par ce biais à remettre le #main et la colonne droite l'un à coté de l'autre mais cependant tous les liens en dessous du header ne sont pas cliquable sur ie6 (c'est à dire quasiment le site en entier). Pourquoi ? Je ne sais pas comment faire.
              Amitiés,

              senzu.
              Dernière édition par senzu à 01/01/2008, 19h45
              http://www.senzu.net
              http://www.compagniexyz.com
              http://www.lebravesoldatchveik.org

              Commentaire


              • #8
                up ! Bonjour à tous,

                J'ai mis cette page dans mes favoris et j'y viens presque toute les heures voir si qqn m'a répondu. Pourquoi ? Parce ce que ca correspond pour moi à une sorte de dernier rampart.
                Que mes sites soient fonctionnent sur IE6 c'est vachement important vu le nombre de gens qui s'en servent.
                Et je me dis que pour un initié ca doit pas être trop galère pour trouver quels commentaires conditionnels à mettre puisque les défauts sont très clairs : en desous du header, aucun lien ne fonctionnent sur IE6.
                Merci.

                Bonne journée.
                http://www.senzu.net
                http://www.compagniexyz.com
                http://www.lebravesoldatchveik.org

                Commentaire


                • #9
                  Là, ton site est inaccessible.
                  Ancien pseudo : Fleuve Blanc

                  Commentaire


                  • #10
                    Ha bon ?? Bizarre, très bizarre... Je remet le lien: COMPAGNIE LE PUITS.
                    http://www.senzu.net
                    http://www.compagniexyz.com
                    http://www.lebravesoldatchveik.org

                    Commentaire


                    • #11
                      Aujourd'hui ça fonctionne.

                      - Ta page n'est toujours pas valide html : change dans ton header :
                      Code:
                      <meta http-equiv="Content-Type" content="text/html;>charset=iso-8859-1" />
                      par :
                      Code:
                      <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
                      - Tu as un div gris en bas de ta page d'accueil sous FF. Je ne comprends pas à quoi il sert.
                      - Sur IE7, ta page est vide avec des erreurs
                      - Pour ton problème de lien, je n'ai pas accès à IE6 avec une IEdevtoolbar. Je regarderai plus en détail quand ça sera le cas.

                      Ancien pseudo : Fleuve Blanc

                      Commentaire


                      • #12
                        Merci !

                        J'ai fait le changement que tu dis seulement j'ai hésité car la ligne de remplacement était la même que celle de départ dans ton post.

                        - Pour IE7, je comprends pas, moi, il s'affiche très bien le site sur ie7.
                        - La div blanche (ou grise ??) apparemment c'est un bug de google analytics que je ne sais pas comment enlever

                        Merci !
                        A+
                        bonne nuit.
                        http://www.senzu.net
                        http://www.compagniexyz.com
                        http://www.lebravesoldatchveik.org

                        Commentaire


                        • #13
                          Je suis toujours en carafe.... IE6 c'est 75% des gens n'est ce pas ?
                          http://www.senzu.net
                          http://www.compagniexyz.com
                          http://www.lebravesoldatchveik.org

                          Commentaire


                          • #14
                            IE6 c'est à peu près 35% des internautes :
                            http://w3schools.com/browsers/browsers_stats.asp
                            http://www.libstat.com/pages/navigateur.htm

                            Sinon, j'ai regardé ton problème de lien. Etant donné que ce soucis apparait seulement quand la page est finie de charger, j'ai l'impression que c'est un problème de javascript :
                            1- désactive ce que tu as mis en place pour fixer les problème de png transparent et regarde si ça marche mieux
                            2- dépublie ta bannière (celle avec un effet de fondu en javascript) et regarde si ça marche mieux

                            Si ça ne te permet pas de trouver ce qui cause ce problème, je chercherai un peu plus.

                            Ancien pseudo : Fleuve Blanc

                            Commentaire


                            • #15
                              J'ai dépuplié pngfix et effectivement les liens marchent !! Mais en naviguant sur le site au bout d'un moment IE6 plante, il dit qu'il ne parvient pas à ouvrir la page et propose 'ok' et en cliquant ca marque 'impossible d'afficher la page'.

                              En dépubliant le module de bannière animées, ca ne change pas plus ou bien ca plante peut-être un chouia moins (l'info de plantage arrive plus tard peut-être).

                              DONC : du mieux, puisque les liens sont désormais actif MERCI !! Mais ca plante au bout d'un moment.
                              Et j'ai toujours des soucis de menus qui se barrent en bas parce que le main prend soudainement top de place (sur IE6) par rapport à la largeur. J'essaie de corrigé ce point là avec des commentaires conditionnels mais ca marche pas pour tout.

                              Et puis ca me ferait tout triste si je devais me séparer de ma belle bannière animée...

                              Bref merci, nous sommes en bonne voie !!!
                              http://www.senzu.net
                              http://www.compagniexyz.com
                              http://www.lebravesoldatchveik.org

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X