Joomladay francophone 2018 à Paris 18 et 19 mai

Ajouter une possition

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Ajouter une possition

    Bonjour à tous
    Tout d'abors je précise que j'ai fais une recherche sur le forum et la base de connaisance avant de poster et que j'y ai trouvé des réponses mais je ne suis pas parvenu à met fin.

    Je voudrais donc ajouter une possition "user3", dans mon fichier index.php j'ai ajouté
    Code:
    <?php if ( mosCountModules( 'user3' ) ) { mosLoadModules ( 'user3' ); } ?>
    sous la ligne et à l'endroit ou je souhaite avoir ma possition "user3"
    Code:
    <?php mosMainBody(); ?>
    Comme dit dans ce poste http://forum.joomla.fr/showthread.ph...outer+position

    J'ai un module mi à cette possition et "user3" module "Qui est en ligne"


    et bien dans "position des module"


    Mais la possition ne fonctionne pas voilà ce que j'ai


    J'aimerais avoir "user3" sous "user2"

    Je vous joint mon fichier index.php

    Je remercie d'avance les personnes qui vont m'aider.
    Sébastien
    Fichiers joints
    Dernière édition par titis14 à 22/01/2008, 21h05

  • #2
    Personne pour m'aider ??

    Commentaire


    • #3
      Ouvre ton fichier ac Dreamweaver par exemple pour mieux visualiser les tableaux.Ensuite tu rajoutes le load user3 en dessous de user2.
      J'aurai bien voulu te le faire mais les tableaux , j'ai jamais travaillé avec

      Commentaire


      • #4
        je l'ai fait comme marqué au début du post.

        Commentaire


        • #5
          My god

          ça faisait longtemps que j'avais pas vu du code aussi bordelique, et je pèse mes mots!!!

          Ligne 92 à 96 :
          Code:
          <span style="background-repeat: repeat-y;">
          <?php if (mosCountModules('user2')) { ?>
          </span>
          <span style="background-repeat: repeat-y; ">
          <?php } ?>
          </span>
          Des tableaux dans des tableaux en veut tu en voilà...
          Au secours!!!
          JoomlaDay Paris - 18 & 19 mai 2018 - J'y serai et vous ?
          ---
          GreenDog studio - Webdesign & Joomla! - Grenoble - greendog.fr

          Commentaire


          • #6
            le template n'ai pas de moi donc faut le dir au codeur.

            J'ai déjà modifier l'endroit que tu cite mais ca ne marche pas.
            Dernière édition par titis14 à 18/01/2008, 20h59

            Commentaire


            • #7
              Salut
              si j'ai le temps, je te mets un peu d'ordre dans ton index.php, mais pas avant demain...
              JoomlaDay Paris - 18 & 19 mai 2018 - J'y serai et vous ?
              ---
              GreenDog studio - Webdesign & Joomla! - Grenoble - greendog.fr

              Commentaire


              • #8
                user3

                slt;

                bein je pense que c très simple, il te suffit d'ouvrir l'index dans dreamweaver, coté design, clique sur user2, fait un saut de ligne depuis user2, et insert ton user3, s'il n'y a pas plus de 2user comme dans ma version renome le du coté code en user3,

                je pense que ça ira ;

                allez bon courage

                Commentaire


                • #9
                  Voilà, j'ai enlevé ce qui me paraissait en trop.

                  Tu avais des TR et des table en trop, deux déclaration de background color...

                  J'ai donc ajouté la position user3 sous user2.

                  Voilà, tiens moi au courant
                  Fichiers joints
                  JoomlaDay Paris - 18 & 19 mai 2018 - J'y serai et vous ?
                  ---
                  GreenDog studio - Webdesign & Joomla! - Grenoble - greendog.fr

                  Commentaire


                  • #10
                    merci beaucoup wabaw je vais tester.
                    j'aitais justement encore en train d'essayer.

                    encore merci.

                    Commentaire


                    • #11
                      aprés test je n'ai pas user3 même dans le code je ne le vois nul par et n'y dans la partie admin tu ne t'ai pas trompé ?

                      encore merci de prendre un peu de ton temps pour moi.

                      Commentaire


                      • #12
                        voila qui est fort étrange...
                        As-tu un lien vers ton site en préprod???

                        Dans le code généré, il est normal de ne pas voir les appels "mosLoadModules"...

                        Tu as bien remplacé le fichier index.php sur l'hébergement
                        et publié des modules en "public" à la position "user3" ???

                        Je dois bien avouer que je ne vois pas le souci...
                        JoomlaDay Paris - 18 & 19 mai 2018 - J'y serai et vous ?
                        ---
                        GreenDog studio - Webdesign & Joomla! - Grenoble - greendog.fr

                        Commentaire


                        • #13
                          Oui j'ai bien remi sur mon FTP et j'ai mi le module "qui est en ligne" en user3 mais il n'apparait pas sur le site.

                          Quand je regarde sous dreamwaever ton fichier index.php je ne vois rien qui parle de user3 es que c'est normal ?

                          Voilà l'adresse de mon site www.mrcn.fr . J'ai laisser ton fichier index pour que tu voye.

                          Merci de ton aide.
                          Dernière édition par titis14 à 22/01/2008, 16h40

                          Commentaire


                          • #14
                            Alors quand tu ouvres le fichier index php tu n'as pas la ligne :
                            Code PHP:
                            <?php if( mosCountModules('user3') ) : ?>
                                          <table width="100%" border="0" cellspacing="0" cellpadding="0">
                                            <tr>
                                              <td background="<?php echo $mosConfig_live_site;?>/templates/<?php echo $mainframe->getTemplate(); ?>/images/modules_21.gif" style="background-repeat:repeat-y">
                                                    <?php mosLoadModules('user3'0); ?>
                                              </td>
                                            </tr>
                                            <tr>
                                              <td><img src="<?php echo $mosConfig_live_site;?>/templates/<?php echo $mainframe->getTemplate(); ?>/images/modules_27.gif" width="186" height="20" /></td>
                                            </tr>
                                          </table>
                                          <?php endif; ?>
                            ??
                            ALors il y a un réel pb, parce que je pense bien t'avoir donné ce fichier la...

                            Ci-dessous le code en clair, fais un copier collé et transfert je regardes en live! :
                            Code:
                            <?php defined( "_VALID_MOS" ) or die( "Direct Access to this location is not allowed." );$iso = split( '=', _ISO );echo '<?xml version="1.0" encoding="'. $iso[1] .'"?' .'>';?>
                            <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
                            <html xmlns="http://www.w3.org/1999/xhtml">
                            <head>
                            	<?php mosShowHead(); ?>
                            	<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
                            	<?php if ( $my->id ) { initEditor(); } ?>
                            	<?php echo "<link rel=\"stylesheet\" href=\"$GLOBALS[mosConfig_live_site]/templates/$GLOBALS[cur_template]/css/template_css.css\" type=\"text/css\"/>" ; ?><?php echo "<link rel=\"shortcut icon\" href=\"$GLOBALS[mosConfig_live_site]/templates/blogger_blue/favicon.ico\" />" ; ?>
                            	<link rel="alternate" title="<?php echo $mosConfig_sitename; ?>" href="<?php echo $GLOBALS['mosConfig_live_site']; ?>/index2.php?option=com_rss&no_html=1" type="application/rss+xml" />
                            	<script language="JavaScript" type="text/javascript">
                            		<!--
                            		function MM_reloadPage(init) {  //reloads the window if Nav4 resized
                            		  if (init==true) with (navigator) {if ((appName=="Netscape")&&(parseInt(appVersion)==4)) {
                            			document.MM_pgW=innerWidth; document.MM_pgH=innerHeight; onresize=MM_reloadPage; }}
                            		  else if (innerWidth!=document.MM_pgW || innerHeight!=document.MM_pgH) location.reload();
                            		}
                            		MM_reloadPage(true);
                            		//-->
                            	  </script>
                            </head>
                            
                            <body >
                            <table width="890" border="0" align="center" cellpadding="0" cellspacing="0">
                              <tr>
                                <td><img src="<?php echo $mosConfig_live_site;?>/templates/<?php echo $mainframe->getTemplate(); ?>/images/08.png" width="18" height="23" /></td>
                                <td width="100%" background="<?php echo $mosConfig_live_site;?>/templates/<?php echo $mainframe->getTemplate(); ?>/images/09.png">&nbsp;</td>
                                <td><img src="<?php echo $mosConfig_live_site;?>/templates/<?php echo $mainframe->getTemplate(); ?>/images/11.png" width="19" height="23" /></td>
                              </tr>
                              <tr>
                                <td background="<?php echo $mosConfig_live_site;?>/templates/<?php echo $mainframe->getTemplate(); ?>/images/20.png">&nbsp;</td>
                                <td width="100%" bgcolor="#FFFFFF">
                            	<table width="100%" border="0" cellspacing="0" cellpadding="0">
                                  <tr>
                                    <td>
                            		<div id="corporateimage">
                            			<div id="newsflash">
                                     		<div align="right">
                                     		</div>
                                    	</div>
                            		</div>
                            		</td>
                                  </tr>
                                  <tr>
                                    <td>
                            		<table width="100%" border="0" cellspacing="0" cellpadding="0">
                                      <tr>
                                        <td valign="top">
                            			<table width="100%" border="0" cellspacing="0" cellpadding="0">
                                          <tr>
                                            <td background="<?php echo $mosConfig_live_site;?>/templates/<?php echo $mainframe->getTemplate(); ?>/images/modules_21.gif" style="background-repeat:repeat-y">
                            				<?php if( mosCountModules('left') ) : ?>
                            					<?php mosLoadModules('left', 0); ?>
                            				<?php endif; ?>
                            				</td>
                                          </tr>
                                          <tr>
                                            <td><img src="<?php echo $mosConfig_live_site;?>/templates/<?php echo $mainframe->getTemplate(); ?>/images/modules_27.gif" width="186" height="20" /></td>
                                          </tr>
                                        </table>
                                         <table width="100%" border="0" cellspacing="0" cellpadding="0">
                                            <tr>
                                              <td background="<?php echo $mosConfig_live_site;?>/templates/<?php echo $mainframe->getTemplate(); ?>/images/modules_21.gif" style="background-repeat:repeat-y">
                            				  	<?php if( mosCountModules('user1') ) : ?>
                            						<?php mosLoadModules ( 'user1' ); ?>
                            					<?php endif; ?>
                            				  </td>
                                            </tr>
                                            <tr>
                                              <td><img src="<?php echo $mosConfig_live_site;?>/templates/<?php echo $mainframe->getTemplate(); ?>/images/modules_27.gif" width="186" height="20" /></td>
                                            </tr>
                                          </table>
                            			 </td>
                                        <td width="100%" valign="top">
                            				<?php mosMainBody(); ?>
                            			</td>
                                        <td valign="top">
                            				<?php if( mosCountModules('right') ) : ?>
                            				  <table width="100%" border="0" cellspacing="0" cellpadding="0">
                            				  <tr>
                            					<td background="<?php echo $mosConfig_live_site;?>/templates/<?php echo $mainframe->getTemplate(); ?>/images/modules_21.gif" style="background-repeat:repeat-y">
                            						<?php mosLoadModules('right', 0); ?>
                            					</td>
                            				  </tr>
                            				  <tr>
                            					<td><img src="<?php echo $mosConfig_live_site;?>/templates/<?php echo $mainframe->getTemplate(); ?>/images/modules_27.gif" width="186" height="20" /></td>
                            				  </tr>
                            				  </table>
                                          <?php endif; ?>
                                          <?php if( mosCountModules('user2') ) : ?>
                                          <table width="100%" border="0" cellspacing="0" cellpadding="0">
                                            <tr>
                                              <td background="<?php echo $mosConfig_live_site;?>/templates/<?php echo $mainframe->getTemplate(); ?>/images/modules_21.gif" style="background-repeat:repeat-y">
                            						<?php mosLoadModules('user2', 0); ?>
                            				  </td>
                                            </tr>
                                            <tr>
                                              <td><img src="<?php echo $mosConfig_live_site;?>/templates/<?php echo $mainframe->getTemplate(); ?>/images/modules_27.gif" width="186" height="20" /></td>
                                            </tr>
                                          </table>
                                          <?php endif; ?>
                            			  <?php if( mosCountModules('user3') ) : ?>
                                          <table width="100%" border="0" cellspacing="0" cellpadding="0">
                                            <tr>
                                              <td background="<?php echo $mosConfig_live_site;?>/templates/<?php echo $mainframe->getTemplate(); ?>/images/modules_21.gif" style="background-repeat:repeat-y">
                            						<?php mosLoadModules('user3', 0); ?>
                            				  </td>
                                            </tr>
                                            <tr>
                                              <td><img src="<?php echo $mosConfig_live_site;?>/templates/<?php echo $mainframe->getTemplate(); ?>/images/modules_27.gif" width="186" height="20" /></td>
                                            </tr>
                                          </table>
                                          <?php endif; ?>
                            			</td>
                                      </tr>
                                    </table>
                            		</td>
                                  </tr>
                                  <tr>
                                    <td>
                            		<table width="100%" border="0" cellspacing="0" cellpadding="0">
                                      <tr>
                                        <td align="center">
                            			<?php if( mosCountModules('bottom') ) : ?>
                            				<?php mosLoadModules('bottom', 0); ?>
                            			<?php endif; ?>
                            			</td>
                                      </tr>
                                      <tr>
                                        <td>
                            			<?php include_once('includes/footer.php'); ?>
                            			</td>
                                      </tr>
                                    </table></td>
                                  </tr>
                                </table></td>
                                <td background="<?php echo $mosConfig_live_site;?>/templates/<?php echo $mainframe->getTemplate(); ?>/images/23.png">&nbsp;</td>
                              </tr>
                              <tr>
                                <td><img src="<?php echo $mosConfig_live_site;?>/templates/<?php echo $mainframe->getTemplate(); ?>/images/32.png" width="18" height="24" /></td>
                                <td width="100%" background="<?php echo $mosConfig_live_site;?>/templates/<?php echo $mainframe->getTemplate(); ?>/images/33.png">&nbsp;</td>
                                <td background="<?php echo $mosConfig_live_site;?>/templates/<?php echo $mainframe->getTemplate(); ?>/images/35.png">&nbsp;</td>
                              </tr>
                            </table>
                            </body>
                            </html>
                            JoomlaDay Paris - 18 & 19 mai 2018 - J'y serai et vous ?
                            ---
                            GreenDog studio - Webdesign & Joomla! - Grenoble - greendog.fr

                            Commentaire


                            • #15
                              aah la c'est bon bizar a mon avis y un souci de UP car je prenais ton fichier et c'est comme ci cela été le premier que j'ai donné.
                              Je te remerci de ton aide.
                              Je vais maintenant regarder comment tu as fait afin d'en ajouter d'autre.

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X