Joomladay francophone 2018 à Paris 18 et 19 mai

mon css ne prend pas en charge "active"

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • mon css ne prend pas en charge "active"

    bonjour, je travail sur joomla , j'ai créer 3 menu horizontal qui prennent la position "user3", c'est pa ça le probleme!!
    mon problem est dans les css des mes menu, il me prend pas en charge le css du menu active; je vais vous lister mon css :
    1. ul#mainlevel-nav {
    2. margin:0px;
    3. padding:0;
    4. height:33px;
    5. }
    6.
    7. ul#mainlevel-nav li {
    8. list-style: none;
    9. display:inline;
    10. height:33px;
    11. width:124px;
    12. }
    13.
    14.
    15. #menu_top
    16. a:link{
    17. font-size:10px;
    18. color:white;
    19. font-weight:normal;
    20. text-align:center;
    21. background:url(../images/menu_06.jpg) no-repeat;
    22. line-height:33px;
    23. height:33px;
    24. width:124px;
    25. display: block;
    26. float:left;
    27. }
    28. #menu_top
    29. a:visited{
    30. font-size:12px;
    31. color:#FFF000;
    32. font-weight:normal;
    33. text-align:center;
    34. background:url(../images/menu_06_on.jpg) no-repeat;
    35. line-height:33px;
    36. height:33px;
    37. width:124px;
    38. display: block;
    39. float:left;
    40. }
    41. #menu_top
    42. a:hover {
    43 color:#FFF000;
    44. font-size:12px;
    45. font-weight:bold;
    46. text-align:normal;
    47. background:url(../images/menu_06_on.jpg) no-repeat;
    48. line-height:33px;
    49. height:33px;
    50. width:124px;
    51. }
    52. #menu_top
    53. a:active {
    54. color:#FFF000;
    55. font-size:12px;
    56. font-weight:bold;
    57. text-align:normal;
    58. background:url(../images/menu_06_on.jpg) no-repeat;
    59. line-height:33px;
    60. height:33px;
    61. width:124px;
    62. }
    #menu_top a:hover , ul#mainlevel-nav#active-mainlevel-nav
    { color:#FFF000;
    font-size:12px;
    font-weight:bold;
    text-align:normal;
    background:url(../images/menu_06_on.jpg) no-repeat;
    line-height:33px;
    height:33px;
    width:124px;
    }


    priere de m'aider sur ça , je comprend pas pourquoi ça marche pas , je suis sure k'il s'agit d'un truc bete , mais commaime je sui coincé;
    merci.

  • #2
    Si tu parles de ça :
    Code:
    ul#mainlevel-nav#active-mainlevel-nav
    Ca ne risque pas de marcher ça ne veut rien dire.

    Après sans voir ton site et sans plus d'explication sur ce que tu veux faire, ça n'est pas facile de te trouver une solution.
    Ancien pseudo : Fleuve Blanc

    Commentaire


    • #3
      merci pour la reponse , c'est vrai j'ai pas bien detailler mon probleme, je vasi vous donner plus d'explication maintenant sachant que j'ai fait quelque modification , et que ça marche pour une partie du menu.
      bon la partie dans le code hrml ou se trouve la declaration de mes menus est la suivante:
      <td width="71" height="44" id="menu_top1" > <?php mosLoadModules ( 'user6', -1 ); ?> </td>
      <td width="190" height="44" id="menu_top" > <?php mosLoadModules ( 'user3', -1 ); ?></td>

      <td width="115" height="44" id="menu_top_right" ><?php mosLoadModules ( 'user2', -1 ); ?> </td>


      donc il ya 3 menu qui prennent des "user" differents(désolé je me suis trompé dans mon premier message) mais ils sont collé (j'ai fai ça parceque chaque parti du menu a une forme du backgroud differente).
      pour cela voila le css de mes menus

      ul#mainlevel-nav {
      margin:0px;
      padding:0;
      height:44px;
      }

      ul#mainlevel-nav li {
      list-style: none;
      display:inline;
      height:44px;
      }

      ul#mainlevel-nav li a {
      font-size:10px;
      color:white;
      font-weight:normal;
      text-align:center;
      background:url(../images/menu_06.jpg) no-repeat;
      line-height:33px;
      height:44px;
      width:85px;
      display: block;
      float:left;
      }
      ul#mainlevel-nav li
      a:link{
      font-size:10px;
      color:white;
      font-weight:bold;
      text-align:center;
      background:url(../images/menu_06.jpg) no-repeat;
      line-height:33px;
      height:44px;
      width:85px;
      display: block;
      float:left;
      }
      ul#mainlevel-nav li
      a:visited{
      font-size:10px;
      color:white;
      font-weight:bold;
      text-align:center;
      background:url(../images/menu_06.jpg) no-repeat;
      line-height:33px;
      height:44px;
      width:85px;
      display: block;
      float:left;
      }
      ul#mainlevel-nav li
      a:hover {
      color:#DD6E05;
      font-size:10px;
      font-weight:bold;
      text-align:normal;
      background:url(../images/menu_06_on.jpg) no-repeat;
      line-height:33px;
      height:44px;
      width:85px;
      }
      ul#mainlevel-nav li
      a:active {
      color:#DD6E05;
      font-size:10px;
      font-weight:bold;
      text-align:normal;
      background:url(../images/menu_06_on.jpg) no-repeat;
      height:44px;
      width:85px;
      }
      #menu_top a:hover, ul#mainlevel-nav a.mainlevel-nav#active_menu-nav{
      color:#DD6E05;
      font-size:10px;
      display:block;
      line-height:33px;
      background:url(../images/menu_06_on.jpg) no-repeat;
      font-weight:bold;
      }


      le css ci dessus marche trés bien , j'ai le menu hover et active qui fonctionnent trés bien.


      ul#mainlevel-nav1 {
      margin:0px;
      padding:0;
      height:44px;
      }

      ul#mainlevel-nav1 li {
      list-style: none;
      display:inline;
      height:44px;
      }

      ul#mainlevel-nav1 li a {
      font-size:10px;
      color:white;
      font-weight:normal;
      text-align:center;
      background:url(../images/menu_03.jpg) no-repeat;
      line-height:33px;
      height:44px;
      width:71px;
      display: block;
      float:left;
      }
      ul#mainlevel-nav1 li
      a:link{
      font-size:10px;
      color:white;
      font-weight:bold;
      text-align:center;
      background:url(../images/menu_03.jpg) no-repeat;
      line-height:33px;
      height:44px;
      width:71px;
      display: block;
      float:left;
      }
      ul#mainlevel-nav1 li
      a:visited{
      font-size:10px;
      color:white;
      font-weight:bold;
      text-align:center;
      background:url(../images/menu_03.jpg) no-repeat;
      line-height:33px;
      height:44px;
      width:71px;
      display: block;
      float:left;
      }
      ul#mainlevel-nav1 li
      a:hover {
      color:#DD6E05;
      font-size:10px;
      font-weight:bold;
      text-align:normal;
      background:url(../images/menu_03_on.jpg) no-repeat;
      line-height:33px;
      height:44px;
      width:71px;
      }
      ul#mainlevel-nav1 li
      a:active {
      color:#DD6E05;
      font-size:10px;
      font-weight:bold;
      text-align:normal;
      background:url(../images/menu_03_on.jpg) no-repeat;
      height:44px;
      width:71px;
      }
      #menu_top1 a:hover, ul#mainlevel-nav1 a.mainlevel-nav1#active_menu-nav1{
      color:#DD6E05;
      font-size:10px;
      display:block;
      line-height:33px;
      background:url(../images/menu_03_on.jpg) no-repeat;
      font-weight:bold;
      }
      Dans ce 2 eme menu il ya que le hover et link qui fonctionnent mais active na pas fonctionner .

      de meme pour le 3eme menu!!
      alors dans ce cas et comme vous le voyez n j'ai mi pratiquement le meme css pour les 3 menu , ils se differencie que dans l'image background!!
      dites moi esque c'est logique qu'ils ne fonctionne pas !!
      esque j'ai fait une erreur?
      je vous remercie d'avance pour vos reponse.

      Commentaire

      Annonce

      Réduire
      1 sur 2 < >

      C'est [Réglé] et on n'en parle plus ?

      A quoi ça sert ?
      La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

      Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

      Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
      Comment ajouter la mention [Réglé] à votre discussion ?
      1 - Aller sur votre discussion et éditer votre premier message :


      2 - Cliquer sur la liste déroulante Préfixe.

      3 - Choisir le préfixe [Réglé].


      4 - Et voilà… votre discussion est désormais identifiée comme réglée.

      2 sur 2 < >

      Assistance au forum - Outil de publication d'infos de votre site

      Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

      Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

      Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

      UTILISER À VOS PROPRES RISQUES :
      L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

      Problèmes connus :
      FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

      Installation :

      1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

      Archive zip : https://github.com/AFUJ/FPA/zipball/master

      2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

      3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

      4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

      5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

      6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
      et remplacer www. votresite .com par votre nom de domaine


      Exemples:
      Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
      Télécharger le script fpa-fr.php dans: /public_html/
      Pour executer le script: http://www..com/fpa-fr.php

      Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
      Télécharger le script fpa-fr.php dans: /public_html/cms/
      Pour executer le script: http://www..com/cms/fpa-fr.php

      En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

      Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
      Voir plus
      Voir moins
      Travaille ...
      X