Joomladay francophone 2018 à Paris 18 et 19 mai

template hyperion- soucis avec le module video

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • template hyperion- soucis avec le module video

    bonjour à tous ,

    je débute avec joomla , et je viens de mettre en ligne le template hyperion.
    j'arrive bien a faire ce que je veux a part cette partie vidéo que je n'arrive pas a réinitialiser. en effet j'ai juste voulu changer le nom de la rubrique pour la mettre en français et la plus rien ne marche . j'ai ensuite remis le nom anglais de la rubrique " recent videos" mais plus rien ne marche .avez vous une solution qui pourrais résoudre ce problème ?

    merci d'avance a ceux qui me répondront

    l'adresse du site :
    http://papillons-de-nuit.tmp37.haisoft.net/

    et ce qui devrait ce trouver a l'endroit vidéo
    http://demo.rockettheme.com/

  • #2
    En premier, es-tu allé là?
    http://tutorials.rockettheme.com/joo...m-modules.html

    Je pense que tu as édité ce module avec ton éditeur wysiwyg, et du coup comme le contenu de ce module est du code, l'éditeur te l'a fait sauté, ce qui explique le texte que tu as à l'écran :
    Code:
    window.addEvent('domready', function() { var flashVars = { titlesColor: '0x' + $$('a')[0].getStyle('color').substr(1)
    Pour remettre le module en ordre, regardes le tuto ci dessus, et ensuite dans ta configuration, mets "aucun éditeur wysiwyg" avant de modifier le module, et remets ton éditeur après la modif.
    C'est un peu lourd comme solution, mais bon...
    JoomlaDay FR 2018 - J'y étais et c'était génial !
    ---
    GreenDog studio - Webdesign & Joomla! - Grenoble - greendog.fr

    Commentaire


    • #3
      merci pour ton aide je vais me pencher sur le tuto et je verrais si ça marche .
      bonne journée

      Commentaire


      • #4
        INTEGRER une video dans le module video d'hyperion

        re ! merci pour le lien ça m'a aidé a remettre en place le module !!
        par contre j'ai un autre probleme .... (je suis embetante !) je n'arrive pas a integrer mes videos .
        j'ai ouvert le fichier video xml dans dreamweaver pour pouvoir l'editer et integrer le liens de mes videos flv , meme les images ne se change pas .... j'ai bien sur tout fait passer sur le serveur via filezilla mais rien ne bouge . pourriez vous encore une fois me donner votre avis svp ??

        merci d'avance

        Commentaire


        • #5
          Alors, comparons les fichiers xml d'origine et modifiés
          Code:
          <content>
          <!-- Item 1 -->
          <item>
          <!-- title of the video item -->
          <title>Realguys-RunFatboyRun</title>
          <!-- description of the video item -->
          <description>We began with the belief that people are good.</description>
          <!-- location of the custom video image relative to the base flash directory-->
          <path>thumbs/image1.jpg</path>
          <!-- location of the video fie -->
          <data>http://blip.tv/file/get/Realguys-RunFatboyRun385.flv</data>
          </item>
          </content>
          Code:
          <content>
          <item>
          <title>La fôret ensorcelée</title>
          <description>comédie musicale pour enfants.</description>
          <path>thumbs/image1.jpg</path>
          <data>http://blip.tv/file/get/Legoline-LaFretEnsorcele</data>
          </item>
          <item>
          <title>Le trésor du fond des mers</title>
          <description>Pour les adeptes de complots et de piraterie.</description>
          <path>thumbs/image2.jpg</path>
          <data>http://fr.youtube.com/watch?v=z6N0KRj-w5k</data>
          </item>
          </content>
          Dans ce fichier tu dois donner les chemins vers le fichiers flv que le module doit lire.
          Or la première vidéo dans ton xml n'a pas d'extension .flv, cela devrait être :
          http://blip.tv/file/get/Legoline-LaFretEnsorcele.flv
          De plus je n'ai pas l'impression que la vidéo flv ne se situe pas sur http://blip.tv.

          Alors ce que tu dois faire :
          Avoir des vidéos flv [ si tu n'as que des mpg ou autre il existe des sites sur le web qui transforme gratuitement tes vidéos en flv]
          Tu les poses dans un répertoire sur ton site et tu indiques le bon chemin de ta vidéo dans le xml.
          Exemple :
          <data>http://papillons-de-nuit.tmp37.haisoft.net/images/stories/videos/mon_fichier.flv</data>
          et tu génères une image de cette vidéo que tu pose dans le bon repertoire et tu renseignes ton xml :
          <path>thumbs/la_vignette_de_ma_video.jpg</path>

          Je pense que cela iras mieux...
          JoomlaDay FR 2018 - J'y étais et c'était génial !
          ---
          GreenDog studio - Webdesign & Joomla! - Grenoble - greendog.fr

          Commentaire


          • #6
            effectivement je n'avais pas pris le bon fichier .flv .
            j'ai bien convertie la video que j'ai transférée sur blip .
            par contre j'ai fait exactement ce que vous m'avez dit , j'ai changé le chemin dans le fichier xml ainsi que les upload dans filezilla avec un nouveau dossier consacré aux vidéos . j'ai donc bien toutes les images et tout mais la video ne se lance toujours pas ... je ne comprend pas .
            en tout cas merci beaucoup pour cette aide pas a pas , j'ai deja beaucoup avancée quant à la compréhension du fonctionnement du module

            Commentaire


            • #7
              Bonjour,
              j'ai exactement le même problème mais malgré ces explications, je n'arrive pas à remettre en place le module.
              Pourrais tu revenir sur ton explication plus en détail s'il te plait ? Je t'en serais trés reconnaissant !

              Commentaire


              • #8
                Autant pour moi, c'est réglé !

                Commentaire

                Annonce

                Réduire
                1 sur 2 < >

                C'est [Réglé] et on n'en parle plus ?

                A quoi ça sert ?
                La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                Comment ajouter la mention [Réglé] à votre discussion ?
                1 - Aller sur votre discussion et éditer votre premier message :


                2 - Cliquer sur la liste déroulante Préfixe.

                3 - Choisir le préfixe [Réglé].


                4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                2 sur 2 < >

                Assistance au forum - Outil de publication d'infos de votre site

                Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                UTILISER À VOS PROPRES RISQUES :
                L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                Problèmes connus :
                FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                Installation :

                1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                Archive zip : https://github.com/AFUJ/FPA/zipball/master

                2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                et remplacer www. votresite .com par votre nom de domaine


                Exemples:
                Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                Télécharger le script fpa-fr.php dans: /public_html/
                Pour executer le script: http://www..com/fpa-fr.php

                Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                Télécharger le script fpa-fr.php dans: /public_html/cms/
                Pour executer le script: http://www..com/cms/fpa-fr.php

                En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                Voir plus
                Voir moins
                Travaille ...
                X