Joomladay francophone 2018 à Paris 18 et 19 mai

Suffixes css de module ne s'appliquent plus...

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Suffixes css de module ne s'appliquent plus...

    Bonjour à tous,

    Tout est dans le titre..
    J'ai voulu changer le suffixe css d'un module sur mon site, histoire surtout d'en créer un nouveau, mais je me rends compte que les suffixes css autres que -black ne s'appliquent plus.
    Ils existent pourtant toujours dans le fichier css correspondant.

    Exemple ici le dernier à gauche, à qui j'ai mis via l'admin le suffixe css par défaut -grey, et rien ne s'affiche que ce fond blanc derrière "plus d'équipement" alors que ça aurait du être un rectangle arrondis gris.
    Idem pour les autres modules et autres suffixes (white, grey, blank, nouveau) à part le black, sur lequel j'étais restée depuis longtemps.

    Comprends pas...
    Ca parle à quelqu'un ??
    Dernière édition par Alice à 08/10/2008, 08h21
    http://aethrio.gr
    http://www.ikonexmedical.com
    http://www.oreavoyages.com

  • #2
    Je ne vois pas de classe .module-grey définie dans module.css, alors que les classes .module-black et .module-blank le sont.

    Si tu utilises un 'switch' de css pour définir le template par défaut (présent en général dans les templates YooTheme), attention à bien vérifier le dossier css utilisé (il porte le nom de la couleur sélectionnée).

    Commentaire


    • #3
      Merci Dunum pour ta réponse, (y'en a qui bossent tard !)
      Je suis retournée voir dans le fichier module.css et effectivement j'ai vu ça :
      Code:
      /* left modules */
      /* grey */
      #left div.module {
      	margin: 0px 0px 10px 0px;
      	background: url(../images/left_module_br.png) 100% 100% no-repeat;
      }
      
      #left div.module div {
      	background: url(../images/left_module_tr.png) 100% 0 no-repeat;
      }
      
      #left div.module div div {
      	background: url(../images/left_module_bl.png) 0 100% no-repeat;
      }
      
      #left div.module div div div {
      	width: 158px;
      	padding: 10px 15px 10px 15px;
      	background: url(../images/left_module_tl.png) 0 0 no-repeat; 
      	overflow: hidden;
      }
      
      #left div.module div div div div {
      	width: auto;
      	padding: 0px 0px 0px 0px;
      	background: none;
      }
      
      #left div.module h3 {
      	margin: -5px -5px 5px -5px;
      	padding: 0px 0px 0px 5px;
      	height: 20px;
      	background: url(../images/left_module_header.png) 0 100% repeat-x;
      	line-height: 15px;
      	text-align: left;
      	font-weight: bold;
      }
      Ce suffixe css de module /*grey*/, n'avait pas
      Code:
      -grey
      après
      Code:
      #left div.module
      ce qui est très bizarre, car dans le fichier module.css d'origine, c'est indiqué...et que je n'ai jamais fait cette modif

      Bref, du coup, j 'ai rajouté -grey pour chaque div et ça marche..
      Merci pour ta remarque, ça m'a bien servi.
      http://aethrio.gr
      http://www.ikonexmedical.com
      http://www.oreavoyages.com

      Commentaire


      • #4
        Bon, ben je profite de ce post pour reposer le problème mais là j'ai vérifié les suffixes css de modules, mais rien n'y fait.

        Cette fois-ci, mon suffixe css (-virtue) attribué au module content item qu'on peut voir en position droite icia tout bonnement disparu hier. Je n'ai pourtant pas touché au css :
        Code HTML:
        /* right modules */
        /* blank */
        #right div.moduletable-blank {
        	padding: 0px 0px 0px 0px;
        
        }
        /*virtue*/
        #right div.module-virtue {
        	margin-right: 5px; 
            padding: 0px 0px 0px 0px;
        	width: 175px;
        	overflow: hidden;
        	text-align:center;
            border: 3px outset #C8C8C8;
            background:#303030;   
        }	
        
        #right div.module-virtue h3 {
        	margin: 4px 0px 0px 0px;
        	padding: 0px 0px 0px 0px;
        	text-align: center;
        	font-weight: bold;
        	font-style:italic;
        	Font-size: 140%;
            Color: #ffffff; 
        }
        /*nouveau*/
        #right div.moduletable-nouveau {
        	margin-left: 0px; 
                  margin-bottom: 15px;
        	padding: 0px 0px 10px 0px;
        	width: 170px;
        	overflow: hidden;
        	text-align:center;
              border: 2px solid #e0e0e0;
              background: #000000;
               
        }	
        
        #right div.moduletable-nouveau h3 {
        	margin: 0px 0px 5px 0px;
        	padding: 0px 0px 0px 0px;
        	text-align: center;
        	font-weight: bold;
                  Color: #ffffff;
               
        }
        J'ai beau essayer avec les autres suffixes existants, le résultat est le même : rien qui correspondent aux suffixes désignés.

        Je ne comprends pas...
        Quelqu'un a déjà vu ça ?
        http://aethrio.gr
        http://www.ikonexmedical.com
        http://www.oreavoyages.com

        Commentaire

        Annonce

        Réduire
        1 sur 2 < >

        C'est [Réglé] et on n'en parle plus ?

        A quoi ça sert ?
        La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

        Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

        Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
        Comment ajouter la mention [Réglé] à votre discussion ?
        1 - Aller sur votre discussion et éditer votre premier message :


        2 - Cliquer sur la liste déroulante Préfixe.

        3 - Choisir le préfixe [Réglé].


        4 - Et voilà… votre discussion est désormais identifiée comme réglée.

        2 sur 2 < >

        Assistance au forum - Outil de publication d'infos de votre site

        Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

        Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

        Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

        UTILISER À VOS PROPRES RISQUES :
        L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

        Problèmes connus :
        FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

        Installation :

        1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

        Archive zip : https://github.com/AFUJ/FPA/zipball/master

        2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

        3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

        4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

        5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

        6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
        et remplacer www. votresite .com par votre nom de domaine


        Exemples:
        Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
        Télécharger le script fpa-fr.php dans: /public_html/
        Pour executer le script: http://www..com/fpa-fr.php

        Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
        Télécharger le script fpa-fr.php dans: /public_html/cms/
        Pour executer le script: http://www..com/cms/fpa-fr.php

        En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

        Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
        Voir plus
        Voir moins
        Travaille ...
        X