Joomladay francophone 2018 à Paris 18 et 19 mai

Perte de la base de données

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Perte de la base de données

    Bonjour,

    J'ai décidé de changer d'hébergeur.
    J'ai sauvegardé ma base de données mais la manipulation à échouée et je n'ai plus accès à mon ancien phpmyadmin. Je ne peux donc pas exporter ma base de données chez mon nouvel hébergeur.

    Je souhaite récupérer mon site en état. Comment puis-je faire ?

    Je vous remercie par avance pour vos réponses.

  • #2
    Bonjour,
    Je souhaite récupérer mon site en état. Comment puis-je faire ?
    je n'entrevois pas d'autre piste que repartir d'une sauvegarde ou retrouver l'accès à phpMysAdmin (point sur lequel ton ancien hébergeur devrait pouvoir t'aider).
    Ton site fonctionne toujours ?
    Schtroumpfe toi le Schtroumpf t'aidera.
    Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

    Commentaire


    • #3
      Non justement mon site ne fonctionne plus.
      Il n'a pas survécu au changement d'hébergeur.

      Commentaire


      • #4
        Re,
        Non justement mon site ne fonctionne plus. Il n'a pas survécu au changement d'hébergeur.
        je voulais dire chez l'ancien hébergeur. Sauf si l'abonnement est fini de chez fini ?
        Schtroumpfe toi le Schtroumpf t'aidera.
        Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

        Commentaire


        • #5
          Mon site ne fonctionne pas mais mon ancien hébergement est toujours en cours.
          J'ai déjà fait transférer mon site. Vous pensez que je peux encore demander à mon ancien hébergeur de m'envoyer ma base de données ?

          Commentaire


          • #6
            Re,
            J'ai déjà fait transférer mon site.
            je pense que tu as plutôt fait transférer ton nom de domaine.
            mon ancien hébergement est toujours en cours.
            donc tu dois toujours pouvoir accéder à ton site au moins par une adresse IP ou assimilé, et il n'y a pas de raisons pour que tu n'aies plus d'accès à phpMyAdmin.
            Vous pensez que je peux encore demander à mon ancien hébergeur de m'envoyer ma base de données ?
            Je ne sais pas quels sont les termes du service que tu as souscrit... mais il doit au moins te (re)donner les accès évoqués ci-dessus.
            Schtroumpfe toi le Schtroumpf t'aidera.
            Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

            Commentaire


            • #7
              Merci Grand Schtroumph pour tes réponses.
              Je vais voir avec mon ancien hébergeur.

              Je te donnerai des retours (espérons positifs) dès que possible.

              Longue vie à Grand Schtroumph.

              Commentaire


              • #8
                C'est bon pour ma base de données. C'était une erreur de mon ancien hébergeur.

                Mais un problème résolu en crée un autre (ce serait trop facile sinon).
                Maintenant impossible d'accéder à mon site. J'ai un message d'erreur :

                Joomla! Logo

                Le site est momentanément indisponible.
                Veuillez notifier le webmaster.
                Echec de la connexion au serveur de base de données

                ???
                Dernière édition par nicoevgo à 18/08/2009, 09h34

                Commentaire


                • #9
                  Re,
                  donc j'imagine que tu as remonté tes dossiers par FTP et ta base de données via phpMyAdmin ? Il te reste à modifier le fichier configuration.php pour lui dire où se trouve la base de données.
                  Un peu de lecture : http://aide.joomla.fr/Administration...un-site-2.html
                  Schtroumpfe toi le Schtroumpf t'aidera.
                  Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

                  Commentaire


                  • #10
                    J'ai bien remis mes dossiers en place.
                    Je vais lire attentivement ce document.

                    Je te remercie!!

                    Commentaire


                    • #11
                      Mon site refonctionne! Je te remercie.

                      Mais encore une fois il y a un nouveau problème : le template est totalement modifié. Je n'ai plus d'images et les couleurs sont celles de base.

                      Chez mon ancien hébergeur mon fichier configuration.php se situait à la racine du site, dans le dossier www.
                      Chez mon nouvel hébergeur j'ai du le déplacer à la base, soit avant le www.

                      Est-ce le problème ? Le nouveau chemin ? Comment résoudre ce nouveau problème ?

                      Commentaire


                      • #12
                        Re,
                        Chez mon nouvel hébergeur j'ai du le déplacer à la base, soit avant le www.
                        ton histoire est louche... le configuration.php doit être à coté de l'index.php principale, à la racine du site.
                        Tu n'aurais pas laissé actif l'URL rewriting ?
                        Si c'est le cas désactive-le et renomme ton .htaccess le temps vérifier... Après il faudra se poser la question de mettre ce qu'il faut dans le .hatccess pour ce nouvel hébergeur...
                        Schtroumpfe toi le Schtroumpf t'aidera.
                        Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

                        Commentaire

                        Annonce

                        Réduire
                        1 sur 2 < >

                        C'est [Réglé] et on n'en parle plus ?

                        A quoi ça sert ?
                        La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                        Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                        Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                        Comment ajouter la mention [Réglé] à votre discussion ?
                        1 - Aller sur votre discussion et éditer votre premier message :


                        2 - Cliquer sur la liste déroulante Préfixe.

                        3 - Choisir le préfixe [Réglé].


                        4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                        2 sur 2 < >

                        Assistance au forum - Outil de publication d'infos de votre site

                        Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                        Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                        Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                        UTILISER À VOS PROPRES RISQUES :
                        L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                        Problèmes connus :
                        FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                        Installation :

                        1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                        Archive zip : https://github.com/AFUJ/FPA/zipball/master

                        2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                        3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                        4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                        5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                        6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                        et remplacer www. votresite .com par votre nom de domaine


                        Exemples:
                        Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                        Télécharger le script fpa-fr.php dans: /public_html/
                        Pour executer le script: http://www..com/fpa-fr.php

                        Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                        Télécharger le script fpa-fr.php dans: /public_html/cms/
                        Pour executer le script: http://www..com/cms/fpa-fr.php

                        En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                        Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                        Voir plus
                        Voir moins
                        Travaille ...
                        X