Expiration après édition d'un article sous Joomla 1.0.9

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Expiration après édition d'un article sous Joomla 1.0.9

    Salut tout le monde,

    J'ai upgradé un site Joomla 1.0.8 full fr et un autre 1.0.8 anglais traduit en français : Même problème sur les deux (serveurs linux différents), l'article expire avec la même date de fin de publication : "1999-11-29 23:00:00". J'avais aussi fait une copie (une sauvegarde ) en local sous EasyPHP et après l'upgrade je n'ai pas ce problème.

    J'ai remplacé la chaine de caractères "Jamais" par "Never" pendant l'édition d'un article et il n'expire plus. Bref je suis passé dans le code (j'ai cherché "Jamais") et je suis tombé sur admin.content.html.php et admin.content.php), j'ai remplcé toutes les occurences de "Never" par "Jamais" et ça marche chez moi (à prendre avec précautions car c'est de la bidouille ). En fait les "Never" et "Jamais" étaient un peu mélangés mais du coup je ne comprends pas pourquoi ca marche en local et pas sous linux.

    Bref si quelqu'un pouvait confirmer ou corriger mes modifs (c'est un peu du pif quand même).

    EDIT: J'en ai parlé au chat de jeudi, très sympa d'ailleurs
    http://www.dvdalliance.com/ L'ancien site en phpnuke (very very old ). Très bientôt un nouveau dvdalliance en Joomla (enfin très bientôt c'est vite dit )

  • #2
    Tiens un bobby
    colle le code de tes deux fichiers on regardera

    ck
    Pas de demande de support en MP ou par mail, Merci.

    Commentaire


    • #3
      Normalement ce sont les mêmes que dans l'upgrade (j'ai vérifié normalement) :

      La modif :
      Il "suffit" de faire un remplacer de tous les Never par Jamais. J'ai aussi remplacé la ligne 173 de admin.content.html.php :

      if ($row->publish_down == $nullDate || $row->publish_down = 'Never') {

      par

      if ($row->publish_down == $nullDate || $row->publish_down == 'Never') {

      PS : Tu n'as certainement pas fini de me voir
      Fichiers joints
      http://www.dvdalliance.com/ L'ancien site en phpnuke (very very old ). Très bientôt un nouveau dvdalliance en Joomla (enfin très bientôt c'est vite dit )

      Commentaire


      • #4
        Question presque totalement indépendante (c'est le même fichier alors j'en profite )

        A la ligne 1173 du fichier admin.content.php je vois :
        -- $row->version = $item[0]->parentid;

        Quelqu'un connait ou sait où je peux trouver la signification de parentid ?
        Version (je pense) doit correspondre au nombre de fois que l'article a été modifié donc il devrait être remis à zéro (non ?). parentid est toujours à zéro (sur les données de chez moi) et comme je ne vois pas de lien de parenté entre les articles .


        PS : En fait j'étais persuadé en 1.0.8 que la copie d'un article était non publié mais en vérifiant ce n'est pas le cas. La copie garde l'état de l'article d'origine ce ui est un peu dommage (pour moi en tous cas). Du coup j'ai modifié la ligne 1160 (de admin.content.php) :

        AVANT :$row->state = $item[0]->state;

        APRES : $row->state = '0';

        Bien entendu les modifications ne sont qu'en test
        http://www.dvdalliance.com/ L'ancien site en phpnuke (very very old ). Très bientôt un nouveau dvdalliance en Joomla (enfin très bientôt c'est vite dit )

        Commentaire


        • #5
          Salut bobby,

          J'ai rencontré exactement le même pb (cf. ici). Je suis curieux d'ailleurs de savoir le pourquoi de cette valeur date/heure ("1999-11-29 23:00:00").

          J'ai téléchargé et installé tes fichiers "hackés" ... et cela fonctionne impec merci.

          Une petite précision pour les développeurs : dans la config d'origine, le pb survient au delà de 99 958 446 secondes. Tant que le différentiel entre la date de "création/début de publication est <= cette valeur tout est OK. Au delà Joomla nous ramène à la valeur "1999-11-29 23:00:00" et l'article est "dépublié".
          Dernière édition par vatokely à 17/06/2006, 20h11

          Commentaire


          • #6
            D'ailleurs ya la même chose pour le contenu statique (articles statiques). Même roblème = même solution
            http://www.dvdalliance.com/ L'ancien site en phpnuke (very very old ). Très bientôt un nouveau dvdalliance en Joomla (enfin très bientôt c'est vite dit )

            Commentaire


            • #7
              Merci pour cette info

              J'ai fait les correctifs et cela marche

              A+

              Denis

              Commentaire


              • #8
                Bonjour,

                Le problème doit venir de la version de MySQL, je suis sous Joomla 1.0.10, j'ai en local un serveur MySQL version MySQL 4.1.9, aucun souci!

                Par contre, j'ai fait un autre test sur un autre serveur, en local avec la version 3.23.54 de MySQL, et j'ai une date d'expiration de 1999 qui apparait chaque fois que j'enregistre un article (et pas quand je fais "Appliquer")

                J'ai mis les hacks (chapeau Bobby, ils marchent à merveille)

                Je venais me tenir au courant : la solution est elle appliquée pour les prochaines versions de Joomla?

                Merci

                Manu

                Commentaire


                • #9
                  ce hack est pas mal mais.... en mettant date de fin de publication sur "jamais" et faisant enregistrer l'article apparait toujours expiré dans la liste des articles et ceux jusqu'a l'actualisation du navigateur, bizzare...

                  Normalement lors sur la version native lors de l'enregistrement celui ci devrait directement passer on-line sans reload de la page, mais bon ca fonctionne quand même....
                  ALSASYS - Intégration & Développement spécifique Joomla - 39, avenue des Champs-Elysées - F-75008 Paris - Tél. 01 53 83 10 63 - www.alsasys.com

                  Commentaire


                  • #10
                    Il faut vérifier le changement dans le composant d'admin : /com_typedcontent

                    Même chose il y a des "Never" qui trainent, et cela influence le bignou
                    Faites du bruit, JOOMLA is the best ...
                    Quel pieds ce truc, j'en découvre tous les jours ...

                    Commentaire


                    • #11
                      Merci c'est ok

                      Bom week-end!
                      ALSASYS - Intégration & Développement spécifique Joomla - 39, avenue des Champs-Elysées - F-75008 Paris - Tél. 01 53 83 10 63 - www.alsasys.com

                      Commentaire


                      • #12
                        Envoyé par bobby
                        D'ailleurs ya la même chose pour le contenu statique (articles statiques). Même roblème = même solution
                        pour les articles statiques ou devons-nous intervenir?
                        ALSASYS - Intégration & Développement spécifique Joomla - 39, avenue des Champs-Elysées - F-75008 Paris - Tél. 01 53 83 10 63 - www.alsasys.com

                        Commentaire


                        • #13
                          Envoyé par gbygby
                          Il faut vérifier le changement dans le composant d'admin : /com_typedcontent

                          Même chose il y a des "Never" qui trainent, et cela influence le bignou
                          c'etait ca merci!
                          ALSASYS - Intégration & Développement spécifique Joomla - 39, avenue des Champs-Elysées - F-75008 Paris - Tél. 01 53 83 10 63 - www.alsasys.com

                          Commentaire


                          • #14
                            up car pb toujours d'actualité

                            Envoyé par Manu59 Voir le message
                            Bonjour,

                            Le problème doit venir de la version de MySQL, je suis sous Joomla 1.0.10, j'ai en local un serveur MySQL version MySQL 4.1.9, aucun souci!

                            Par contre, j'ai fait un autre test sur un autre serveur, en local avec la version 3.23.54 de MySQL, et j'ai une date d'expiration de 1999 qui apparait chaque fois que j'enregistre un article (et pas quand je fais "Appliquer")
                            J'ai le problème en local avec Joomla 1.0.11 et MySQL 3.23.58, merci pour le post je vais essayer ce hack. Au pire, le site online devrait avoir une version mysql plus récente donc pas de problème..

                            Commentaire

                            Annonce

                            Réduire
                            1 sur 2 < >

                            C'est [Réglé] et on n'en parle plus ?

                            A quoi ça sert ?
                            La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                            Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                            Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                            Comment ajouter la mention [Réglé] à votre discussion ?
                            1 - Aller sur votre discussion et éditer votre premier message :


                            2 - Cliquer sur la liste déroulante Préfixe.

                            3 - Choisir le préfixe [Réglé].


                            4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                            2 sur 2 < >

                            Assistance au forum - Outil de publication d'infos de votre site

                            Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                            Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                            Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                            UTILISER À VOS PROPRES RISQUES :
                            L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                            Problèmes connus :
                            FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                            Installation :

                            1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                            Archive zip : https://github.com/AFUJ/FPA/zipball/master

                            2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                            3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                            4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                            5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                            6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                            et remplacer www. votresite .com par votre nom de domaine


                            Exemples:
                            Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/
                            Pour executer le script: http://www..com/fpa-fr.php

                            Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/cms/
                            Pour executer le script: http://www..com/cms/fpa-fr.php

                            En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                            Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                            Voir plus
                            Voir moins
                            Travaille ...
                            X