Joomal 1.0.3 - Installation impossible de composants - Create directory error

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Joomal 1.0.3 - Installation impossible de composants - Create directory error

    Bonjour à tous,

    Il m'est impossible d'installer un composant depuis l'interface, je me retrouve avec un "failed to create directory".

    Safe Mode = ON
    Serveur Web = LInux

    Je n'ais pas le problème si j'installe un module ou un mambot "from directory", par contre les composants c'est nada.

    J'ai parcouru tous les forums possibles et usé google pour tenter de trouver une solution à mon problème.

    L'un d'entre-vous as t'il une solution ?

  • #2
    J'ai le même problème avec Joomla. Pas moyen d'installer ces composants.
    Et si je veux le faire manuellement, si le script d'installation doit déplacer des fichiers, ça ne marche pas non plus.

    Je n'ai aucune restriction (safe mode off, etc...) et tout mes répertoires ont l'autorisation 777.

    Je n'ai rien trouvé sur via google !

    Help help help

    Commentaire


    • #3
      Quelques pistes...
      • Si vous avez la possibilité de restaurer les droits par défaut de tout le dossier web d'un seul coup via l'interface de votre hébergeur, ça résoud souvent pas mal de choses
      • Sinon, à la main, c'est un "chown" qu'il faut faire pour rétablir les privilèges de propriété des répertoires... Mais là, ça dépend de votre serveur ! Les répertoires doivent appartenir à l'utilisateur et au groupe Apache, donc, chez certains c'est www:www, chez d'autres, autre chose !! Renseignez vous... Si vous avez accès à la console collez un chown récursif à votre racine web (chown -R www:www racineweb)
      • Vous avez appliqué les chmod automatiques de Joomla/$ambo dans l'interface admin, rayon config générale, onglet Serveur ? Restaurez les droits de départ comme ceux indiqués dans l'installation... Ne mettez pas du 777 partout
      Voilà ce que je vois pour le moment..

      @++
      Pas de demande de support en MP ou par mail, le forum est là pour ça!
      http://network.wantoo.com : Wantoo Network - Infogérance Serveurs Dédiés - Sécurité Joomla!

      Commentaire


      • #4
        - Je ne vois pas pour l'interface de mon hébergeur.
        - Pour le "chown" non plus
        - J'ai changé la configuration de Joomla et j'ai cela comme erreur

        Mon erreur:
        Failed to create directory "/back4/www/com/t/u/hannut.com/i/p/pi/htdocs/components/com_joomlaboard/"

        Si quelqu'un sait encore m'aider, ce sera mon sauveur

        Commentaire


        • #5
          Envoyé par chil
          Failed to create directory "/back4/www/com/t/u/hannut.com/i/p/pi/htdocs/components/com_joomlaboard/"
          Est-ce que le chemin absolu est correct ?

          Commentaire


          • #6
            Salut,
            Oui le chemin absolu est correct.

            Commentaire


            • #7
              Bon, après moulte recherches il parait que pour ne plus avoir l'erreur il faut éditer le script qui crée les répertoires et lui enlever le '/' final car c'est ça qui crée l'erreur !

              Est-ce que quelqu'un peut me dire où se trouve (dans quel fichier) ce script de création de répertoires.

              D'avance merci !

              Commentaire


              • #8
                Quelq'un peux t'il m'aider ?

                J'ai appris qu'il existait un patch pour corriger cela ! (qui fait ce que j'ai cité ci-dessus)

                Commentaire


                • #9
                  Personne n'a jamais eu ce "bug" ????

                  Commentaire


                  • #10
                    Voila il existe un patch (que j'ai obtenu difficillement) qui corrige le problème. il a été envoyé à Joomlafrance mais je ne l'ai pas encore vu publié.
                    @+

                    Commentaire


                    • #11
                      Salut tout le monde

                      personne n'a de solutions?? j'ai testé sur free.fr tout marche, mais lost oasis ne veux m'installer de composant
                      (Failed to create directory)
                      merci d'avance

                      Commentaire


                      • #12
                        Pas croyable
                        Le problème date de plus d'un an et encore pas de solution ?

                        Fallait t'il ecrire avec une autre langue pour qu'on nous aide à résoudre ce grave problème ?

                        It amazing me to be honest

                        Commentaire


                        • #13
                          Pas croyable qu'un an après tu sois encore chez un hébergeur ou les répertoires ne soient pas correctement CHOWNés. Tu n'as apparemment pas les droits en écriture sur l'espace qui t'est alloué par ton hébergeur, il faudrait voir avec lui.
                          Pas de demande de support en MP ou par mail, le forum est là pour ça!
                          http://www.joomla.fr : news, téléchargements, tutoriels, FAQ, traduction, documentation
                          http://www.lapatagonie.com : juste pour vous dépayser un peu...

                          Commentaire


                          • #14
                            Ton Patch

                            Envoyé par chil Voir le message
                            Voila il existe un patch (que j'ai obtenu difficillement) qui corrige le problème. il a été envoyé à Joomlafrance mais je ne l'ai pas encore vu publié.
                            @+
                            Salut,

                            peux-tu m'envoyer ton patch, j'ai le même problème. Impossible d'installer les composants, par contre pour les modules ça marche.

                            Mon email : jouanin.c.t@9online.fr

                            Merci

                            j'attend ta réponse
                            Thierry JOUANIN
                            http://photosjouanin.ovh.org/

                            Commentaire

                            Annonce

                            Réduire
                            1 sur 2 < >

                            C'est [Réglé] et on n'en parle plus ?

                            A quoi ça sert ?
                            La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                            Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                            Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                            Comment ajouter la mention [Réglé] à votre discussion ?
                            1 - Aller sur votre discussion et éditer votre premier message :


                            2 - Cliquer sur la liste déroulante Préfixe.

                            3 - Choisir le préfixe [Réglé].


                            4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                            2 sur 2 < >

                            Assistance au forum - Outil de publication d'infos de votre site

                            Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                            Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                            Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                            UTILISER À VOS PROPRES RISQUES :
                            L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                            Problèmes connus :
                            FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                            Installation :

                            1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                            Archive zip : https://github.com/AFUJ/FPA/zipball/master

                            2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                            3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                            4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                            5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                            6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                            et remplacer www. votresite .com par votre nom de domaine


                            Exemples:
                            Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/
                            Pour executer le script: http://www..com/fpa-fr.php

                            Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/cms/
                            Pour executer le script: http://www..com/cms/fpa-fr.php

                            En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                            Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                            Voir plus
                            Voir moins
                            Travaille ...
                            X