error 500 sur un serveur dédié

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • error 500 sur un serveur dédié

    Bonjour à tous.

    Ma société vient de se procurer un serveur dédié chez ovh, de là un admin réseau et co externe à ovh nous a configuré le serveur.
    Dès que j'active le seo, le serveur plante.
    J'ai demandé à l'admin de vérifier que les deux lignes pour apache soit décommentez, mon htaccess est d'origine, je l'ai placé en chmod 777 mais rien à faire j'ai tjs l'erreure. En local je n'ai pas de problème.

    Donc y aurait'il un paramètre à rajouter ou modifier sur le serveur, car mon admin réseau ne trouve pas de solution..

    J'ai déjà fouiller sur le forum, mais sans solution
    Bertrand

    Chrystalide - Spécialiste Joomla

  • #2
    Salut,

    Quelle distrib, ton dédié ?

    @++
    Hyperion

    PS : Peux-tu nous faire parvenir le contenu de ton htaccess, tel qu'il est actuellement ? Merci
    Pas de demande de support en MP ou par mail, le forum est là pour ça!
    http://network.wantoo.com : Wantoo Network - Infogérance Serveurs Dédiés - Sécurité Joomla!

    Commentaire


    • #3
      Salut hypérion, tu veux dire quoi par distrib ?
      voiçi le contenu du fichier htaccess

      Code:
      ##
      # @version $Id: htaccess.txt 1005 2005-11-13 17:33:59Z stingrey $
      # @package Joomla
      # @copyright Copyright (C) 2005 Open Source Matters. All rights reserved.
      # @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
      # Joomla! is Free Software
      ##
      
      Options +FollowSymLinks
      
      #
      #  mod_rewrite in use
      #
      
      RewriteEngine On
      
      #  Uncomment following line if your webserver's URL 
      #  is not directly related to physical file paths.
      #  Update YourJoomlaDirectory (just / for root)
      
      RewriteBase /
      
      #
      #  Rules
      #
      
      RewriteCond %{REQUEST_FILENAME} !\.(jpg|jpeg|gif|png|css|js|pl|txt)$
      RewriteCond %{REQUEST_FILENAME} !-f
      RewriteCond %{REQUEST_FILENAME} !-d
      RewriteRule ^(.*) index.php
      le site est sur http://www.webtcctesting.be/joomla/

      je crois que je dois activer le RewriteBase /, vu que je ne ne suis pas à la racine, mais là encore je ne suis pas trop sur.

      pour ce qui est de globals.php-off, je viens de voir qu'il est toujours à on.
      phpinfo.php

      et j'ai même commencé à lire ton tutorial sur créer son propre serveur linux, du très bon travail

      je cherche toujours

      Merci
      Bertrand

      Chrystalide - Spécialiste Joomla

      Commentaire


      • #4
        Salut Chrystalide,

        "Distrib", comme Distribution Linux, mais grâce à ton initiative de publier ton phpinfo , j'ai vu que c'était une Debian.

        Bon, plusieurs choses :
        • Effectivement, en premier lieu, ton RewriteBase doit être corrigé car tu n'es pas à la racine. "RewriteBase /joomla" sera correct
        • En revanche, le module mod_rewrite n'est pas activé dans Apache. Il te faut décommenter la ligne dans httpd.conf comme il est précisé tout en bas de ce mini-tuto
        Ceci fait, il faut redémarrer le serveur Apache pour que les modifications soient prises en compte. Si tu ne sais pas faire, vas sur ton interface serveur pour relancer le service. Ne sachant pas quelle interface tu as, je ne peux t'aider plus, à part te donner la commande en console shell SSH (si tu as déjà fais ce genre de manip) : /etc/init.d/apache2 restart

        Tu as normalement là tout ce qu'il te faut pour activer le SEF sur ton serveur

        @++
        Hyperion

        PS: merci pour les compliments D'ailleurs, n'hésites pas à faire vivre le thread du forum si, d'aventure, tu avais des questions...
        Pas de demande de support en MP ou par mail, le forum est là pour ça!
        http://network.wantoo.com : Wantoo Network - Infogérance Serveurs Dédiés - Sécurité Joomla!

        Commentaire


        • #5
          Merci hyperion pour ta réponse

          C'est à quelle ligne que tu vois si le mod_rewrite est actif ?
          Car selon mon admin réseau il était acti.
          j'ai regardé ds webmin je n'ai effectivement vu aucune trace.
          Et quand je veux éditer le fichier httpd.conf , il me donne une sorte de redirection..

          :-)
          Bertrand

          Chrystalide - Spécialiste Joomla

          Commentaire


          • #6
            Envoyé par chrystalide
            Merci hyperion pour ta réponse

            C'est à quelle ligne que tu vois si le mod_rewrite est actif ?
            Car selon mon admin réseau il était acti.
            j'ai regardé ds webmin je n'ai effectivement vu aucune trace.
            Et quand je veux éditer le fichier httpd.conf , il me donne une sorte de redirection..

            :-)
            Salut,

            Je ne sais pas à quelle ligne se trouve le mod_rewrite dans ton httpd.conf. Fais une recherche dans ton fichier, ou défiles jusqu'à ce que tu le trouves (chaque distrib a sa façon de placer les commentaires qui modifient le nombre de lignes !) !

            En revanche, pour l'éditer, le mieux étant d'utiliser une console SSH (via Putty -> voir mon tuto ) avec accès root. Sur ta Debian, normalement tu devrais chercher du côté de /etc/apache ou apache2

            Pour modifier le register_globals sur On ou sur Off, c'est le php.ini, que tu trouves vers /etc/php4/apache2/php.ini

            Quelques pistes de travail !

            @++
            Hyperion
            Pas de demande de support en MP ou par mail, le forum est là pour ça!
            http://network.wantoo.com : Wantoo Network - Infogérance Serveurs Dédiés - Sécurité Joomla!

            Commentaire


            • #7
              Ds le http.conf, ça je sais.
              C'était comment toi via le phpinfo je suppose tu avais vu que le rewrite n'était pas actif..
              Bertrand

              Chrystalide - Spécialiste Joomla

              Commentaire


              • #8
                [résolu] error 500 sur un débian apache2

                Ah beh voilà nous venons de trouver .
                Selon mon admin réseau vuq ue c'est du apache 2
                il fallait changer un truc ou deux
                "il allait pas chercher le bon include des bon module a loader"

                Merci pour ton aide, et encore félicitations pour ton tutorial.
                Dernière édition par chrystalide à 15/12/2005, 14h08
                Bertrand

                Chrystalide - Spécialiste Joomla

                Commentaire


                • #9
                  Il n'y a pas de quoi !

                  Content que le problème soit résolu !!

                  Bonne création de site à vous...

                  @++
                  Hyperion
                  Pas de demande de support en MP ou par mail, le forum est là pour ça!
                  http://network.wantoo.com : Wantoo Network - Infogérance Serveurs Dédiés - Sécurité Joomla!

                  Commentaire

                  Annonce

                  Réduire
                  1 sur 2 < >

                  C'est [Réglé] et on n'en parle plus ?

                  A quoi ça sert ?
                  La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                  Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                  Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                  Comment ajouter la mention [Réglé] à votre discussion ?
                  1 - Aller sur votre discussion et éditer votre premier message :


                  2 - Cliquer sur la liste déroulante Préfixe.

                  3 - Choisir le préfixe [Réglé].


                  4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                  2 sur 2 < >

                  Assistance au forum - Outil de publication d'infos de votre site

                  Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                  Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                  Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                  UTILISER À VOS PROPRES RISQUES :
                  L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                  Problèmes connus :
                  FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                  Installation :

                  1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                  Archive zip : https://github.com/AFUJ/FPA/zipball/master

                  2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                  3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                  4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                  5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                  6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                  et remplacer www. votresite .com par votre nom de domaine


                  Exemples:
                  Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                  Télécharger le script fpa-fr.php dans: /public_html/
                  Pour executer le script: http://www..com/fpa-fr.php

                  Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                  Télécharger le script fpa-fr.php dans: /public_html/cms/
                  Pour executer le script: http://www..com/cms/fpa-fr.php

                  En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                  Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                  Voir plus
                  Voir moins
                  Travaille ...
                  X