Joomladay francophone 2018 à Paris 18 et 19 mai

problème installation permissions repertoires

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • problème installation permissions repertoires

    bonjour

    j'ai un petit soucis.

    Je veux installer joomla 1.0.13 stable en français.

    Je télécharge le fichier, jusque là tout va bien, j'ai wampserver, je démarre wampserver, je copie les fichiers sous joomla_test, me connecte en localhost, la page d'installation apparait, OK. Et puis j'ai les repertoires media, modules, templates qui sont non-modifiables. Bon ok, je comprends pas trop sauf qu'à côté il parle de CHMODer, ce sont les droits d'écriture/lecture, chouette, sauf que je suis en local sur mon disque C:, que je tente de modifier les droits lecture seule (dont le carré est plein et non coché, donc répertoires accessibles et d'autres pas, je change donc il veut bien et pof me remet le petit carré plein).
    Donc pas trop con je me documente sur la question, et 2 heures après j'ai bien compris qu'il faut un logiciel FTP pour gérer les droits, sauf que là je suis en localhost. Bon tant pis je laisse tomber et continue l'installation. Bingo ! L'interface admin fonctionne mais pas le site .... une évidence me direz-vous, mais pas pour moi. Le répertoire Templates n'existerait apparemment pas, il ne trouve donc pas les fichiers et n'affiche rien. Logique implaccable, sauf que là je bloque complètement. Impossible d'installer Joomla ! ... je suis vert. Mais je reprend des couleur à l'idée que forcément l'un d'entre vous connait la réponse )

    Merci

    _Lolo

  • #2
    Donnes-nous le message d'erreur que tu as quand tu veux accéder au site.
    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

    Commentaire


    • #3
      Fichier template non trouvé! Le fichier recherché :rhuk_solarflare_ii

      Commentaire


      • #4
        Vérifies si ton répertoire est bien présent. En général, c'est soit une absence de répertoire, soit une erreur de chemin dans le paramétrage du site.
        "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

        Commentaire


        • #5
          par exemple pour le repertoire templates, j'ai bien www\Joomla_test\administrator\templates, et dedans uniquement joomla_admin ... les repertoires modules et medias existent aussi.
          tu ne penses pas qu'il puisse y avoir un problème avec la permission des repertoires ?

          Commentaire


          • #6
            Là, tu parles du répertoire des templates d'administration.
            Celui attendu et cité dans ton message d'erreur doit se trouver dans "www\Joomla_test\templates".

            A ta place, dans un premier temps, j'installerais moovla.php pour m'assurer que le fichier de configuration est correct au niveau des chemins et si ça ne fonctionne toujours pas :
            - je renommerais le répertoire actuel en "Joomlatest",
            - je décompresserais de nouveau "Joomla_1.0.13-Stable-fr.zip" directement dans le répertoire "www",
            - puis je renommerais le répertoire "Joomla_1.0.13-Stable-fr" en "Joomla_test", en y copiant le fichier de configuration actuel.

            Il est possible que les permissions sur les répertoires jouent, mais c'est un souci que je n'ai jamais rencontré.
            "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

            Commentaire


            • #7
              merci j'essaierai ce soir

              Commentaire


              • #8
                Bon on laisse tomber j'ai choisi la facilité ... j'ai tout viré, retélechargé et réinstallé wampserver et joomla .... et ça fonctionne. Merci quand même

                Commentaire


                • #9
                  Permissions des répertoires en local ?

                  Bonsoir,

                  j'essai d'installer une copie de mon site en local et a l'install j'ai:

                  Code:
                   Permissions des répertoires:
                  
                  Pour que Joomla fonctionne correctement, certains répertoires doivent être accessibles en lecture et écriture.
                  
                  Si certains des répertoires listés co-contre sont dans l'état "Non modifiable", alors vous devrez changer les CHMODer pour les rendre "Modifiables".
                    
                  administrator/backups/	Non-modifiable
                  administrator/components/	Non-modifiable
                  administrator/modules/	Non-modifiable
                  administrator/templates/	Non-modifiable
                  cache/	Non-modifiable
                  components/	Non-modifiable
                  images/	Non-modifiable
                  images/banners/	Non-modifiable
                  images/stories/	Non-modifiable
                  language/	Non-modifiable
                  mambots/	Non-modifiable
                  mambots/content/	Non-modifiable
                  mambots/editors/	Non-modifiable
                  mambots/editors-xtd/	Non-modifiable
                  mambots/search/	Non-modifiable
                  mambots/system/	Non-modifiable
                  media/	Non-modifiable
                  modules/	Non-modifiable
                  templates/	Non-modifiable
                  Que dois faire, je pense qu'un chmod pourrais régler le soucis mais je ne sais pas le quel !!

                  merci de m'eclairer?
                  Actualités Web
                  Création de site internet 78

                  Commentaire


                  • #10
                    Personne pour m'aider ??
                    Actualités Web
                    Création de site internet 78

                    Commentaire


                    • #11
                      Bonjour,
                      en, général pour les répertoires il faut utiliser 775

                      Commentaire

                      Annonce

                      Réduire
                      1 sur 2 < >

                      C'est [Réglé] et on n'en parle plus ?

                      A quoi ça sert ?
                      La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                      Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                      Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                      Comment ajouter la mention [Réglé] à votre discussion ?
                      1 - Aller sur votre discussion et éditer votre premier message :


                      2 - Cliquer sur la liste déroulante Préfixe.

                      3 - Choisir le préfixe [Réglé].


                      4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                      2 sur 2 < >

                      Assistance au forum - Outil de publication d'infos de votre site

                      Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                      Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                      Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                      UTILISER À VOS PROPRES RISQUES :
                      L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                      Problèmes connus :
                      FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                      Installation :

                      1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                      Archive zip : https://github.com/AFUJ/FPA/zipball/master

                      2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                      3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                      4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                      5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                      6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                      et remplacer www. votresite .com par votre nom de domaine


                      Exemples:
                      Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                      Télécharger le script fpa-fr.php dans: /public_html/
                      Pour executer le script: http://www..com/fpa-fr.php

                      Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                      Télécharger le script fpa-fr.php dans: /public_html/cms/
                      Pour executer le script: http://www..com/cms/fpa-fr.php

                      En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                      Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                      Voir plus
                      Voir moins
                      Travaille ...
                      X