Joomladay francophone 2018 à Paris 18 et 19 mai

local vers serveur distant

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • local vers serveur distant

    voila,
    j'ai effectué les differentes etapes de "joomla pour les nuls" (transfert via ftp des fichiers sources utilisés, supression de configuration.php et reinstallation), jusque la pas de probleme...
    j'ai recupérer la bases de données de mon site local, creer une base de données sur mon hebergeur et j'importe en suite celle-la pour ecraser celle que l'installation a créé afin de retrouver mon site web tel que je l'avais conçu en local, mais voila, a part les images que j'avais modifier et les boutons, tout le reste n'apparait pas, ni les nouveaux composants, ni les nouveaux modules, ni les menus, ni les articles, enfin rien de tout ce que j'avais fait et j'avoue, a part tout refaire directement sur la web, je ne vois pas ou ça coince!
    a oui, et maintenant chaque fois que j'essaie de recuperer la base de données local, au lieu de me creer un .sql il me donne un fichier quasi vide en .php.html (?) alors que je l'avais deja fait avant sans aucun probleme.
    quelqu'un a t'il une solution alternative (transfert via ftp des sources puis changements manuels du configuration.php manuellement par exemple?)
    merci d'avance
    Dernière édition par seya2cyclop à 30/10/2007, 14h09

  • #2
    Salut,

    Le problème vient apparemment de l'export de ta base de données locale...
    Ouvre PHPMyAdmin en local (http://localhost/phpmyadmin/), sélectionne ta base de données dans le menu déroulant de gauche et assure toi que tu as toutes tes tables (au moins 35) et que ces tables ne sont pas vides (colonnes enregistrements)
    Pas de demande de support en MP ou par mail, le forum est là pour ça!
    http://www.joomla.fr : news, téléchargements, tutoriels, FAQ, traduction, documentation
    http://www.lapatagonie.com : juste pour vous dépayser un peu...

    Commentaire


    • #3
      voila c fait, j'en ai bien 35, tous selectionné.
      mais lorsque je consulte la base de données que je viens d'exporter en local, je remarque que la configuration est la meme qu'un site de base en joomla, comme si je n'avais rien fait (faux texte, liens vers joomla, licence, menus de bases...) alors que mon site en local ne contient rien de cela...
      meme les articles sont redevenus les exemples de bases de joomla! (lorem ispum dolor), je ne comprends pas

      Commentaire


      • #4
        Tu as peut-être une deuxième base de données alors?
        Pas de demande de support en MP ou par mail, le forum est là pour ça!
        http://www.joomla.fr : news, téléchargements, tutoriels, FAQ, traduction, documentation
        http://www.lapatagonie.com : juste pour vous dépayser un peu...

        Commentaire


        • #5
          ca m'etonnerait parce que je n'y connais absolument rien en mysql et je ne vois pas comment j'aurais créer 2 bases de données en local, mais si j'en ai plusieurs comment le savoir, comment les retrouver?
          est-ce que quelqu'un a une idée parce que la je desespere, surtout pour l'histoire de la bases de données, c'est trop bete

          Commentaire


          • #6
            Toujours dans phpmyadmin, menu déroulant de gauche, vois ce que tu as comme autres bases de données (qui auraient plus de 35 tables) en plus des bases par défaut, ou sinon ouvre le fichier configuration.php du site qui est "ok" et localise la valeur de la variable $mosConfig_db pour avoir le nom de la base de données qui est ok
            Pas de demande de support en MP ou par mail, le forum est là pour ça!
            http://www.joomla.fr : news, téléchargements, tutoriels, FAQ, traduction, documentation
            http://www.lapatagonie.com : juste pour vous dépayser un peu...

            Commentaire


            • #7
              ok merci, j'en ai trouvé, j'ai exporté la bases de données et en lisant je retrouve dedans tous les liens, les menus, articles...merci a toi
              je comprends toujours pas comment la bases de données a changé de nom?
              enfin peu importe
              je vais testé en ligne et je remets un message pour confirmer que tout fonctionne.

              donc maintenant je dois refaire le ftp, installation et finir par l'import de la bases de données c'est ca?(ou bien effacer d'abord la bases données sur le servuer vue qu'elle etait erronée?)

              au fait sous amen il n'y a pas des pb pour changer ensuite le config.php, parce que sinon il est plus simple de le modifier en local?

              Commentaire


              • #8
                Non, tu n'as que la base de données à ré importer.
                Sinon j'ai pas compris la question concernant Amen
                Pas de demande de support en MP ou par mail, le forum est là pour ça!
                http://www.joomla.fr : news, téléchargements, tutoriels, FAQ, traduction, documentation
                http://www.lapatagonie.com : juste pour vous dépayser un peu...

                Commentaire


                • #9
                  j'ai aussi un probleme d'accent dans la bases de données cnormal ou bien ca apparaitra tel quel sur le site?
                  pour info je travaill sur un site en espagnol donc des accents toniques et des ñ

                  Commentaire


                  • #10
                    chez Amen, il n'est plus possible de changer la configuration quelques fois apres l'installation, donc a ce moemnt je pourrais la modifier en local au cas ou non?

                    Commentaire


                    • #11
                      j'ai encore un problem
                      je ne peux pas importer ma bases de données local vers serveur
                      voila ce qui apparait:

                      Estructura de tabla para la tabla `jos_banner`
                      --
                      CREATE TABLE `jos_banner` (

                      `bid` int( 11 ) NOT NULL AUTO_INCREMENT ,
                      `cid` int( 11 ) NOT NULL default '0',
                      `type` varchar( 10 ) NOT NULL default 'banner',
                      `name` varchar( 50 ) NOT NULL default '',
                      `imptotal` int( 11 ) NOT NULL default '0',
                      `impmade` int( 11 ) NOT NULL default '0',
                      `clicks` int( 11 ) NOT NULL default '0',
                      `imageurl` varchar( 100 ) NOT NULL default '',
                      `clickurl` varchar( 200 ) NOT NULL default '',
                      `date` datetime default NULL ,
                      `showBanner` tinyint( 1 ) NOT NULL default '0',
                      `checked_out` tinyint( 1 ) NOT NULL default '0',
                      `checked_out_time` datetime NOT NULL default '0000-00-00 00:00:00',
                      `editor` varchar( 50 ) default NULL ,
                      `custombannercode` text,
                      PRIMARY KEY ( `bid` ) ,
                      KEY `viewbanner` ( `showBanner` )
                      ) TYPE = MYISAM AUTO_INCREMENT =4;


                      MySQL ha dicho:

                      #1050 - Table 'jos_banner' already exists

                      Commentaire


                      • #12
                        Supprime toutes les tables de la base de données Amen.

                        Pour ton problème d'accents, quand tu importes ta base de données locale chez Amen, passe le jeu de caractère du fichier .sql à latin1 (au lieu de UTF8 par défaut)
                        Pas de demande de support en MP ou par mail, le forum est là pour ça!
                        http://www.joomla.fr : news, téléchargements, tutoriels, FAQ, traduction, documentation
                        http://www.lapatagonie.com : juste pour vous dépayser un peu...

                        Commentaire


                        • #13
                          encore un autre probleme:
                          les images des boutons menu principal et utilisateur n'apparaisent pas alors que pour les autres menus si, est ce que c'est un probleme de joomla spanish?

                          Commentaire


                          • #14
                            une URL pour voir?
                            Pas de demande de support en MP ou par mail, le forum est là pour ça!
                            http://www.joomla.fr : news, téléchargements, tutoriels, FAQ, traduction, documentation
                            http://www.lapatagonie.com : juste pour vous dépayser un peu...

                            Commentaire


                            • #15
                              c'est bon il suffisait de changer le template espagnol par un français vu que l'espagnol a des bugs

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X