Joomladay francophone 2018 à Paris 18 et 19 mai

Ma base de données

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Ma base de données

    Bonjour,

    J'ai découvert Joomla il y a plusieurs mois. Après avoir consciencieusement lu JPLN, j'ai mis au point, tant bien que mal, mon site (en local). N'ayant aucune expérience en la matière, chaque étape fut longue et quelque peu laborieuse. Heureusement, ce forum m'a aidé à avancer.

    J'ai ensuite suivi la procédure pour la mise en ligne de mon affaire. Après quelques problèmes, je suis arrivé à 2 doigts de mon objectif. Niveau FileZilla, tout s'est passé comme indiqué dans le manuel JPLN. Avec phpMyadmin (local et serveur), j'ai suivi les consignes à la lettre et tout semble normal.

    Mon problème est que c'est le site Joomla qui s'affiche et pas le mien.
    J'ai relu toute la doc, j'ai été voir partout et je fouille le forum depuis 2 jours sans succès. Je sens bien que ça doit être simple, mais je ne voie pas. Il s'agit vraissemblablement d'un truc lié à la base de données, mais quoi?

    Merci pour votre temps et votre aide.

  • #2
    J'ai l'impression que tu as importé ta base avant de lancer la réinstallation conseillée dans la notice. Est-ce que je me trompe ?
    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

    Commentaire


    • #3
      Db

      Euh non, c'est juste.
      C'est ça la cause de tous mes malheurs alors?
      Que puis-je faire pour réparer ce mauvais enchaînement?

      En fait, comme j'ai un peu pataugé à l'étape 2 de l'instal distante, je m'y suis repris à plusieurs fois (upload avec FileZilla, export DB,...). Quand je transferais les fichiers de mon site et que je procédais à la réinstallation, je reçevait un message d'erreur à l'étape 2. J'ai trouvé un message sur le forum qui parlait de ça et conseillait de cocher la case supprimer les bases existantes. J'ai aussi fait ça. Ensuite, je pouvais accéder à l'étape suivante.

      Du coup, il est vrais que je n'ai pas respecté la séquence dont tu parles. Damned!

      J'ai pourtant essayer de tout faire au poil.
      Dernière édition par zawa-ninja à 21/11/2007, 16h53

      Commentaire


      • #4
        Je patauge

        J'ai supprimer tous les répertoires et fichiers uploadé avec FileZilla pour tout recommencer.

        J'ai donc d'abord retransféré les fichiers d'instal de Joomla_1.0.13-Stable-fr.

        Ensuite j'ai procédé à l'instal => problème à l'étape 2 (voir fichier joint instal - étape 2).

        Après, j'ai procédé à l'export de la base de données Joomla locale avant de transférer mes fichiers de l'instal local (cf. sitejoomla) vers le serveur.

        Lors de la réinstal, denouveau un blocage à l'étape 2 (voir fichier joint reinstal - étape 2). Pour passer ce blocage, j'ai à chaque fois dû cocher la case "supprimer les bases existantes".

        Finalement, j'ai importé la base sur le serveur de mon hébergeur.

        Résultat, c'est le site Joomla qui apparaît et toujours pas le mien.
        Je ne sais plus quoi faire.
        Quelqu'un peut-il m'aider?
        Fichiers joints

        Commentaire


        • #5
          Même problème

          Bonjour,

          Je pense avoir le même problème que zawa-ninja.

          Voici mon site http://www.pra-consulting.co.uk/ . J'ai respecté toute la procédure de JPLN (avec des messages de réussite) sauf le point 7.5.3 car je ne sais pas trop comment faire...

          J'ai installé Joomla via l'interface administrateur de mon hébergeur (payant)

          D'avance, merci beaucoup pour votre aide...

          Maxime

          Commentaire


          • #6
            MWIP vous conseillerait à tous deux d'utiliser JoomlaPack qui simplifie cette procédure.

            Pour la nième fois , je donne "ma" technique de transfert d'un hébergement à un autre :
            - transfert par ftp des fichiers locaux ou du premier hébergeur vers le nouveau (sauf .htaccess ou après l'avoir renommé, sauf si c'est le même hébergeur, sinon, risque d'erreur de serveur)
            - export et import de la base de données
            - upload de moovla.php à la racine du nouveau site et lancement de ce fichier pour corriger automatiquement les chemins d'accès absolu et manuellement les informations d'accès à la base de données, puis suppression de ce fichier.
            - éventuellement adaptation du fichier .htaccess au nouvel hébergeur

            zawa-ninja, il devrait te suffire de réimporter les données de ta sauvegarde de base de données locale dans celle de ton hébergeur, quitte à supprimer préalablement les tables dans la base sauf si ta sauvegarde locale ne comporte pas les instructions de création mais seulement d'insertion des données. L'erreur dont tu nous montres une copie d'écran vient du fait que ta base n'était pas vide et que Joomla! ne pouvait recréer les tables, ce que tu as résolu, si j'ai bien compris, en cochant la case de suppression des tables.

            Maxime, tu as maintenant une version de base de Joomla! sur ton espace d'hébergement : as-tu développé aussi quelque chose en local ? Si oui, il faut que tu utilises ma procédure de migration mais en n'exportant pas vers le serveur ton fichier "configuration.php" local, ce qui t'évitera le recours à moovla.php puisque ce fichier de configuration distant est à jour.
            "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

            Commentaire


            • #7
              Bonjour Robert,

              Tout d'abord, merci pour votre réponse.

              J'ai effectivement créé quelque chose en local. Mon site est même fini. J'ai transféré les fichiers sur le serveur et j'ai supprimé le configuration.php à la fin... Mais je ne sais pas quoi faire pour régénérer mon fichier configuration.php...

              Dans JPLN, ils disent de "procéder comme pour une installation distante classique", mais comment dois-je faire? Au départ de quoi?

              D'avance, merci beaucoup

              Maxime

              Commentaire


              • #8
                Le programme Moovla te permettra de reconfigurer Joomla!
                MWIP pour les intimes

                M. W. I. Prod. (Documentations et téléchargements pour Joomla!)

                Commentaire


                • #9
                  Bonjour,

                  Merci beaucoup pour vos réponses.

                  J'ai téléchargé Moovla, j'ai décompressé le dossier et j'ai glissé moovla.php dans mon site distant via FileZilla... Je l'ai placé à la racine du site, au même niveau que configuration.php...

                  Quand je vais sur http://www.pra-consulting.co.uk/moovla.php, je n'ai aucune page qui s'affiche...

                  J'ai cherché pas mal et je ne vois pas ce qui peut poser problème...

                  Voici quelques trucs que j'ai remarqué dans FileZilla...

                  1. Je n'ai pas exactement la même structure dans le site local et le site distant. Dans le site distant, j'ai, en plus des fichiers et dossiers uploadés de mon site local, les dossiers suivants :
                  - cgi-bin
                  - logs
                  - mivadata
                  - public_html
                  - sessions (c'est moi qui l'ai créé en suivant JPLN mais je ne sais pas pourquoi...)

                  Tous sauf "sessions" ont un point d'interrogation noir sur l'icône du dossier

                  2. J'ai laissé le fichier configuration.php

                  3. Moovla a été téléchargé et décompressé sur mon disque dur dans un dossier qui n'a rien à voir avec sitejoomla

                  4. moovla.php se trouve près de configuration.php

                  5. Les fichiers .php sont des Documents Microsoft Picture It. Est-ce normal?

                  D'avance, merci beaucoup pour votre réponse et vos éclaircissements.

                  J'ai vraiment besoin de rendre public ce site pour aujourd'hui ou demain...

                  Thanks

                  Maxime

                  Commentaire


                  • #10
                    Je ne sais pas ce que tu as fait au juste, mais http://www.pra-consulting.co.uk/ ouvre bien un site Joomla vierge, ne contenant que les données exemples.
                    Pour moi, cela veut dire que si tu as envoyé par ftp tes fichiers locaux, tu ne l'as pas fait dans le répertoire de cette version non paramétrée et que tu n'as pas importé chez ton hébergeur la sauvegarde de la base de données locale.
                    Tu n'as aucun besoin de moovla : renvoie par ftp tout ce que tu as fait en local SAUF configuration.php et occupe-toi de la base.
                    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

                    Commentaire


                    • #11
                      Bonjour Robert,

                      Merci pour vos réponses régulières et votre aide.

                      J'ai donc retransféré, via FileZilla, mon site local sur le site distant et j'ai exporter et importer ma base de données et rien ne change...

                      Je ne sais vraiment pas quoi faire de plus.

                      J'ai transféré tout sauf le fichier configuration.php comme vous me l'avez conseillé. Que dois-je faire pour récupérer un fichier configuration.php "tout beau, tout propre" comme ils disent dans JPLN à la page 103 (Section 7.5.3)?

                      J'ai peut-être fait une bêtise en supprimant le contenu de public_html sur mon site distant... Non? Depuis, il n'y a plus rien dans ce dossier.

                      Merci beaucoup pour votre aide future et passée.

                      Maxime

                      Commentaire


                      • #12
                        Merci pour votre aide,

                        J'ai fait un petit pas en avant... grâce à joomlapack, j'ai pu accéder à une réinstallation de joomla à partir de ma base de donnée. Tout se passe correctement, néanmoins il existe une différence avec le tutorial (cfr piece jointe). Ca pourait expliquer le probleme, mais je n'ai aucune idée de comment y remédier.

                        Et si je continue l'installation, tout a l'air de bien se passer mais des que je me connecte sur l'administration de mon site, il me demande de m'indentifier. Impossible car "aucun administrateur n'a été déclaré" alors que j'ai rien changé par rapport à mon site en local. Et si j'ouvre ma page internet normalement, il ne met plus le site de base de joomla mais une erreur indiquant ''acces denied, you have no right to view the contents of this directory''.

                        Donc vraissemblablement, c'est bien la différence avec le tuto qui m'empeche de continuer.

                        Edit: La recherche "registre global" dans le forum me permet sans doute de continuer. En espérant que tout roule correctement
                        Fichiers joints
                        Dernière édition par zawa-ninja à 26/11/2007, 22h11

                        Commentaire


                        • #13
                          Robert,

                          J'ai changé de base de données sur les conseils de mon hébergeur, j'ai réimporté et voilà ce que j'ai maintenant à mon adresse :
                          www.pra-consulting.co.uk

                          A quoi est-ce que ça peut être dû?

                          Merci beaucoup pour votre aide

                          Maxime

                          Commentaire


                          • #14
                            Voilà, j'y suis arrivé !!!

                            C'était un problème de bases de données apparemment...

                            Maintenant, il me reste quelques trucs à corriger mais c'est déjà pas mal

                            Merci beaucoup pour votre aide

                            Maxime

                            Commentaire

                            Annonce

                            Réduire
                            1 sur 2 < >

                            C'est [Réglé] et on n'en parle plus ?

                            A quoi ça sert ?
                            La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                            Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                            Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                            Comment ajouter la mention [Réglé] à votre discussion ?
                            1 - Aller sur votre discussion et éditer votre premier message :


                            2 - Cliquer sur la liste déroulante Préfixe.

                            3 - Choisir le préfixe [Réglé].


                            4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                            2 sur 2 < >

                            Assistance au forum - Outil de publication d'infos de votre site

                            Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                            Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                            Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                            UTILISER À VOS PROPRES RISQUES :
                            L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                            Problèmes connus :
                            FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                            Installation :

                            1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                            Archive zip : https://github.com/AFUJ/FPA/zipball/master

                            2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                            3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                            4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                            5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                            6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                            et remplacer www. votresite .com par votre nom de domaine


                            Exemples:
                            Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/
                            Pour executer le script: http://www..com/fpa-fr.php

                            Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/cms/
                            Pour executer le script: http://www..com/cms/fpa-fr.php

                            En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                            Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                            Voir plus
                            Voir moins
                            Travaille ...
                            X