Joomladay francophone 2018 à Paris 18 et 19 mai

Installation pack virtualmart 1.0.13

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Installation pack virtualmart 1.0.13

    bonjour à tous.
    J'ai besoin de vos lumieres et de votre aide sur cette installation.
    J'ai installé en localhost le pack virtualmart 1.0.13 afin de faire mon site et tout à fonctionné nickel en local .
    J'essaye maintenant desespérement de le mettre en ligne (hébergeur 1&1)depuis quelques jours en suivant la procédure normale comme indiqué mais j'ai une erreur récurente que je n'arrive pas à résoudre:
    j'ai donc
    - Tranféré mon site via FileZilla sur le serveur.
    - Effacé le fichier configuration.php.
    - Rectifié le fichier htacces pour 1&1 comme indiqué sur le forum.
    - Remis sur le serveur le repertoire installation à la racine
    - je pointe sur mon nom de domaine : www.monsite.com
    - j'ai bien le menu d'installation de joomla qui s'affiche.
    - Je vérifie que tout "est au vert " ce qui est le cas.
    - Je rentre bien dans l'étape 1 les données de configuration de ma base de données MySQL
    et lorsque je fais "suivant" j'ai cette erreur qui apparait .

    A database error occurred when running query

    CREATE TABLE `jos_banner` ( `bid` int(11) NOT NULL auto_increment, `cid` int(11) NOT NULL default '0', `type` varchar(10) NOT NULL default 'banner', `name` varchar(50) NOT NULL default '', `imptotal` int(11) NOT NULL default '0', `impmade` int(11) NOT NULL default '0', `clicks` int(11) NOT NULL default '0', `imageurl` varchar(100) NOT NULL default '', `clickurl` varchar(200) NOT NULL default '', `date` datetime default NULL, `showBanner` tinyint(1) NOT NULL default '0', `checked_out` tinyint(1) NOT NULL default '0', `checked_out_time` datetime NOT NULL default '0000-00-00 00:00:00', `editor` varchar(50) default NULL, `custombannercode` text, PRIMARY KEY (`bid`), KEY `viewbanner` (`showBanner`) ) ENGINE=MyISAM DEFAULT CHARSET=latin1 ;
    The error was:
    You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near \'DEFAULT CHARSET=latin1\' at line 1 SQL=CREATE TABLE `jos_banner` ( `bid` int(11) NOT NULL auto_increment, `cid` int(11) NOT NULL default \'0\', `type` varchar(10) NOT NULL default \'banner\', `name` varchar(50) NOT NULL default \'\', `imptotal` int(11) NOT NULL default \'0\', `impmade` int(11) NOT NULL default \'0\', `clicks` int(11) NOT NULL default \'0\', `imageurl` varchar(100) NOT NULL default \'\', `clickurl` varchar(200) NOT NULL default \'\', `date` datetime default NULL, `showBanner` tinyint(1) NOT NULL default \'0\', `checked_out` tinyint(1) NOT NULL default \'0\', `checked_out_time` datetime NOT NULL default \'0000-00-00 00:00:00\', `editor` varchar(50) default NULL, `custombannercode` text, PRIMARY KEY (`bid`), KEY `viewbanner` (`showBanner`) ) ENGINE=MyISAM DEFAULT CHARSET=latin1 ;
    Message windows : Une erreur est apparue la base ne sera pas réstaurée.

    - J'ai installé joomla_hisa_en.php afin de vérifier de nouveau . Tout est " au vert " .

    Je ne comprends pas d'ou cela peux venir et quel est le moyen de réparer ce probléme. Je précise que je suis un autodidacte complet dans le domaine et que pour moi le message ci-dessus , c'est du chinois !

    Merci d'avance de l'aide que vous pourrez me proposer .
    Cordialement .
    Philippe .
    Dernière édition par xphil34 à 24/11/2007, 22h52

  • #2
    Si ton site est fonctionnel en local, tu n'as pas besoin de réinstaller chez 1&1 mais seulement d'envoyer tes fichiers locaux par ftp, de sauvegarder ta base locale pour l'importer chez 1&1 (après avoir vidé celle que tu as déjà essayé d'utiliser ou en avoir créé une nouvelle) puis de mettre à jour ton fichier de configuration avec les nouvelles infos de chemin d'accès absolu et de base de données. Pour cela, moovla.php peut être très pratique.

    Autre solution : installer Joomlapack en local pour sauvegarder, récupérer le zip, l'envoyer sur ton espace d'hébergement où tu le dézippes (merci 1&1 pour cette fonctionnalité) et ensuite, tu relances l'installation en donnant les infos de base et en remettant ensuite ton mot de passe d'administrateur.

    Il te faut ensuite régler le problème de register globals en mettant cette ligne dans un fichier .htaccess
    AddType x-mapp-php5 .php
    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

    Commentaire


    • #3
      Merci RobertG de ta réponse rapide;
      En effet , j'ai fait ce que tu m'indique ,( transfert de mes fichiers, export de ma base, et nouvelle configuration via moovla.php )
      mais dans ce cas, j'ai une nouvelle erreur lorsque je pointe mon site :
      Fatal error: Call to a member function loadBotGroup() on a non-object in /homepages/7/d219176658/htdocs/index.php on line 48
      ??kezako ?

      Commentaire


      • #4
        Cela pourrait vouloir dire que certains fichiers ont pu être mal copiés ou qu'il y a un souci avec la base : l'erreur se situe en effet ici
        // load system bot group
        $_MAMBOTS->loadBotGroup( 'system' );
        mais je ne suis pas assez calé pour te donner la solution (j'ai plusieurs sites Joomla! chez 1&1 sans jamais avoir eu ce type d'erreur).
        "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

        Commentaire


        • #5
          En effet , d'aprés ce que j'ai pu trouver comme information sur le forum sur ce message d'erreur ; ça peux provenir d'erreur de transfert FTP.
          je re-essaye donc.
          Je recharge le tout sur le serveur 1&1 mais cette fois en ayant zippé l'integralité du site local . J'ai décompressé une fois sur le serveur ; refait la manip avec moovla pour refaire mon configuration.php

          ..........et CA MARCHE ! ! ! ! . comme quoi un peu de pérsevérence ça fini par payer .

          Merci encore à toi RoberG pour tes réponses.
          Dernière édition par xphil34 à 24/11/2007, 22h52

          Commentaire

          Annonce

          Réduire
          1 sur 2 < >

          C'est [Réglé] et on n'en parle plus ?

          A quoi ça sert ?
          La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

          Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

          Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
          Comment ajouter la mention [Réglé] à votre discussion ?
          1 - Aller sur votre discussion et éditer votre premier message :


          2 - Cliquer sur la liste déroulante Préfixe.

          3 - Choisir le préfixe [Réglé].


          4 - Et voilà… votre discussion est désormais identifiée comme réglée.

          2 sur 2 < >

          Assistance au forum - Outil de publication d'infos de votre site

          Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

          Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

          Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

          UTILISER À VOS PROPRES RISQUES :
          L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

          Problèmes connus :
          FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

          Installation :

          1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

          Archive zip : https://github.com/AFUJ/FPA/zipball/master

          2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

          3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

          4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

          5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

          6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
          et remplacer www. votresite .com par votre nom de domaine


          Exemples:
          Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
          Télécharger le script fpa-fr.php dans: /public_html/
          Pour executer le script: http://www..com/fpa-fr.php

          Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
          Télécharger le script fpa-fr.php dans: /public_html/cms/
          Pour executer le script: http://www..com/cms/fpa-fr.php

          En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

          Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
          Voir plus
          Voir moins
          Travaille ...
          X