mambo 4.5.2.3 vers joomla 1.05, des soucis!

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • mambo 4.5.2.3 vers joomla 1.05, des soucis!

    bonjour,
    J'ai sauté le pas hier et j'ai enfin migré vers joomla 1.05 stable, avec la procédure suivante:
    installation et réglages en local, puis copie du dossier entier vers l'hebergeur.
    j'ai gardé les anciens fichiers .htaccess et configuration.php, puis j'ai appliqué le script sql mambo 4.5.2.3 vers joomla 1.0x.
    pas eu besoin de changer le code sur les fichier index.php dans les templates administrator.
    Mais voilà, j'ai eu quelques petits problèmes avec des erreurs php qui s'affichent (notamment avec les bots mosauthorxtd et dynamicImage), la réinstallation du bot dynamicImage a résolu le problème, quoique sur certains articles j'ai encore cette ligne :Notice: Undefined offset: 1 in /home/mawajiz/public_html/mambots/content/dynamicImage.php on line 92.
    Or quand je vais à la ligne 92 c'est vide (c'est juste un saut de ligne)
    Maintenant avec akocomment, j'ai encore une ligne de code qui apparaît en haut des articles :
    Notice: Use of undefined constant _AKOCOMMENT_FORMVALIDATE2 - assumed '_AKOCOMMENT_FORMVALIDATE2' in /home/mawajiz/public_html/mambots/content/akocommentbot.php on line 146

    La aussi, même topo la ligne 146 est vide;

    par contr en local je n'ai aucun de ces problèmes.
    Autre chose, j'ai pas crée de nouvelles tables jos_, j'ai gardé les mos_ aussi bien en local que chez l'hebergeur.
    Alors là je donne ma langue au chat si vous pouvez m'aider à retrouver un site normal sans ces nombreux problèmes.
    Merci par avance, en attendant j'ai dù désactiver pas mal de modules, de composants et de bots qui me posent probleme
    Dernière édition par rafie à 08/02/2006, 13h41
    http://pub.2m.tv/.mawajiz

  • #2
    Bon, j'ai avancé depuis un peu.
    Pour ce qui est de l'erreure akocomment, elle est générée à cause du composant security image que j'ai désactivé pour le moment en attendant une solution.
    pour dynamicImage, meêm en mettant dans les reglages error reporting dans l'onglet serveur sur none, l'erreur s'affiche toujours.
    j'ai parcouru le forum pour essayer de trouver un semblant de problème similaire ou début de solution, et j'ai remarque même si je n'ai pas trouvé de réponse qu'il y a pas mal de gens qui s'arrachent les cheveux comme moi, avec joomla, ce qui n'est pas sans me réconforter un peu.
    http://pub.2m.tv/.mawajiz

    Commentaire


    • #3
      Envoyé par rafie
      bonjour,
      J'ai sauté le pas hier et j'ai enfin migré vers joomla 1.05 stable, avec la procédure suivante:
      installation et réglages en local, puis copie du dossier entier vers l'hebergeur.
      j'ai gardé les anciens fichiers .htaccess et configuration.php, puis j'ai appliqué le script sql mambo 4.5.2.3 vers joomla 1.0x.
      pas eu besoin de changer le code sur les fichier index.php dans les templates administrator.
      Mais voilà, j'ai eu quelques petits problèmes avec des erreurs php qui s'affichent
      Avec akocomment, j'ai encore une ligne de code qui apparaît en haut des articles :
      Notice: Use of undefined constant _AKOCOMMENT_FORMVALIDATE2 - assumed '_AKOCOMMENT_FORMVALIDATE2' in /home/mawajiz/public_html/mambots/content/akocommentbot.php on line 146

      La aussi, même topo la ligne 146 est vide;

      par contr en local je n'ai aucun de ces problèmes.
      Autre chose, j'ai pas crée de nouvelles tables jos_, j'ai gardé les mos_ aussi bien en local que chez l'hebergeur.
      Alors là je donne ma langue au chat si vous pouvez m'aider à retrouver un site normal sans ces nombreux problèmes.
      Merci par avance, en attendant j'ai dù désactiver pas mal de modules, de composants et de bots qui me posent probleme
      ça y est, j'ai pu régler le problème tout seul comme un grand. En fait, il fallait juste ajouter cette ligne dans le fichier french.php du composant akocomment après l'avoir importée du fichier english.php et traduite en français:
      DEFINE("_AKOCOMMENT_FORMVALIDATE2","Veuillez essayer de deviner les caractères dans la case security image avant de poster.");

      Voilà voilou!
      Rafie
      http://pub.2m.tv/.mawajiz

      Commentaire


      • #4
        Envoyé par rafie
        bonjour,
        j'ai eu quelques petits problèmes avec des erreurs php qui s'affichent (notamment avec les bots mosauthorxtd et dynamicImage), la réinstallation du bot dynamicImage a résolu le problème, quoique sur certains articles j'ai encore cette ligne :Notice: Undefined offset: 1 in /home/mawajiz/public_html/mambots/content/dynamicImage.php on line 92.
        Or quand je vais à la ligne 92 c'est vide (c'est juste un saut de ligne)
        Là aussi j'ai pu réglé le problème en postant dans des forums dédiés au php.
        Si vous rencontrez vous aussi ce problème, il suffit d'aller à la ligne indiquée dans le notice, 92, dans mon cas et remplacer cette ligne de code:
        if (!is_int($row->hits)) {
        par celle-ci: if (!isset($row->hits)) {

        Et le tour est joué.
        Merci au passage au forum de easyphp.org, qui a répondu à ma question en moins de 10 minutes.
        Rafie... Heureux
        http://pub.2m.tv/.mawajiz

        Commentaire

        Annonce

        Réduire
        1 sur 2 < >

        C'est [Réglé] et on n'en parle plus ?

        A quoi ça sert ?
        La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

        Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

        Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
        Comment ajouter la mention [Réglé] à votre discussion ?
        1 - Aller sur votre discussion et éditer votre premier message :


        2 - Cliquer sur la liste déroulante Préfixe.

        3 - Choisir le préfixe [Réglé].


        4 - Et voilà… votre discussion est désormais identifiée comme réglée.

        2 sur 2 < >

        Assistance au forum - Outil de publication d'infos de votre site

        Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

        Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

        Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

        UTILISER À VOS PROPRES RISQUES :
        L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

        Problèmes connus :
        FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

        Installation :

        1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

        Archive zip : https://github.com/AFUJ/FPA/zipball/master

        2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

        3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

        4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

        5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

        6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
        et remplacer www. votresite .com par votre nom de domaine


        Exemples:
        Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
        Télécharger le script fpa-fr.php dans: /public_html/
        Pour executer le script: http://www..com/fpa-fr.php

        Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
        Télécharger le script fpa-fr.php dans: /public_html/cms/
        Pour executer le script: http://www..com/cms/fpa-fr.php

        En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

        Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
        Voir plus
        Voir moins
        Travaille ...
        X