Joomladay francophone 2018 à Paris 18 et 19 mai

installation composant via ftp

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • installation composant via ftp

    Bonjour,

    je cherche depuis ce matin une solution pour installer des composants.
    mon site est hébergé sur ovh
    je veux installer datsogallery par exemple,
    sauf que je ne vois pas comment faire, beaucoup de messages sont sur le forum concernant ce problème, plus ou moins aucune solution... enfin tellement fouilli que j'ai du mal à m'y retrouver

    j'ai décompressé datsogallery, je l'ai mis à la racine:
    www/installer/datsogallery

    il est donc décompressé, je vais dans installer composant:

    je lui donne l'adresse suivante: 'installer depuis le repertoire:
    /home/b/o/i/boiteacouture/www/installer/datsogallery

    et mon message:

    Failed to create directory "/home/b/o/i/boiteacouture/www/components/com_datsogallery/"

    j'ai essayé de créer un répertoire dans components, ça change rien

    quelqu'un peut il m'éclairer,
    merci d'avance, karine

  • #2
    Tout pareil

    Même problême chez ovh demo 1G, a priori c 'est un problême de droit d' accès aux répertoires dont à besoin Joomla, mais comment faire pour changer les droits ? Et que faut il entrer pour que celà fonctionne, that' s the question...

    Commentaire


    • #3
      Bonjour.

      Je suis chez OVH en 90plan et je n'ai eu aucun problème d'installation.
      Pour info le chmod du répertoire components et com_datsogallery sont en 755.
      Pour changer les droits tu peux le faire avec ton logiciel ftp (clic droit sur le fichier ou le dossier)

      A+

      Thierry
      Mon site : Thierry Neveu Photoblog

      Commentaire


      • #4
        Idem j'ai le meme problème depuis 2-3 semaines, j'ai essayé de changer les droits... mais cela ne fonctionne pas !!

        J'ai pas de solutions, mais si vous avez trouvé, cela m'interesse !!!

        Cdlt Godsilken.
        http://7vents.fr

        Commentaire


        • #5
          Idem

          Pareil
          J'essaye depuis 3 jours d'installer Fireboard et j'ai le message suivant
          Failed to create directory "/home/dolores/www/components/com_fireboard/"
          je suis chez OVH et c'est la première fois que cela m'arrive
          Beaucoup remercier signifie secrètement demander davantage.

          Commentaire


          • #6
            Bonsoir

            Quand vous avez le message d'erreur "Failed to create directory" avez-vous vérifié que le répertoire en question n'est pas déjà existant sur le serveur suite à la première installation qui aurait planté ?
            Mon site : Thierry Neveu Photoblog

            Commentaire


            • #7
              Non aucune trace ni dans les répertoires ni dans la base de données
              Beaucoup remercier signifie secrètement demander davantage.

              Commentaire


              • #8
                Je n'ai toujours pas réussi à résoudre le problème !!

                UP SVP....

                Aucun composant ne veut s'installer.
                J'ai demandé au service technique de OVH mais bon ils me disent bien que c'est un problème de droit, mais ne renvois sur le forum de Joomla pour trouver la solution.

                Donc voilà si vous avez réussi avec ce problème de droit, aidez-moi !!
                J'ai testé en 755 pour les répertoires et 644 pour les fichiers
                755 rép et 7xx fichiers... rien n'y fait !!


                Merci à vous.
                Dernière édition par godsilken11 à 28/02/2008, 11h15
                http://7vents.fr

                Commentaire


                • #9
                  Bonsoir.

                  Je viens de vérifier sur mon 90plan chez OVH. Le répertoire "components" et ses sous-répertoires sont bien en 755, les fichiers sont en 644. Le dossier "www" est lui en 705 mais je ne sais pas si on peut le modifier.

                  C'est vraiment bizarre ton problème. J'aimerais bien connaitre la solution au cas où ça m'arriverait.

                  Concernant le service technique OVH, ça dépend sur qui on tombe. La dernière fois, le technicien m'a dit que des con.....!

                  Tu peux peut-être voir ici. Tiens nous au courant si ça marche.

                  Thierry
                  Dernière édition par thierry76 à 28/02/2008, 18h34
                  Mon site : Thierry Neveu Photoblog

                  Commentaire


                  • #10
                    Problème installation de composant (sur OVH)

                    Super ton lien !!

                    J'ai cherché au moins 3 semaines à résoudre ce problème et c'est enfin fait !!!

                    J'ai effectué exactement ce qu'il préconise :
                    Changer le code du fichier : "component.class.php" situé dans administrator/components/com_installer/component

                    vous prenez ça :

                    Code:
                    if(!file_exists($this->elementDir()) && !mosMakePath($this->elementDir())) {
                    $this->setError( 1, 'Failed to create directory "' . $this->elementDir() . '"' );
                    return false;
                    }
                    if(!file_exists($this->componentAdminDir()) && !mosMakePath($this->componentAdminDir())) {
                    $this->setError( 1, 'Failed to create directory "' . $this->componentAdminDir() . '"' );
                    return false;
                    }
                    et vous le remplacez par ça :

                    Code:
                    if(!file_exists($this->elementDir()) && !mosMakePath($this->elementDir())) {
                    $dirbugc=substr($this->elementDir(),0,-1);
                    mkdir($dirbugc);
                    // $this->setError( 1, 'Failed to create directory "' . $this->elementDir() . '"' );
                    // return false;
                    }
                    if(!file_exists($this->componentAdminDir()) && !mosMakePath($this->componentAdminDir())) {
                    $dirbugc=substr($this->componentAdminDir(),0,-1);
                    mkdir($dirbugc);
                    // $this->setError( 1, 'Failed to create directory "' . $this->componentAdminDir() . '"' );
                    // return false;
                    }
                    Et maintenant vous pouvez installer des composants !!

                    Sur le lien ci dessus il y 'a aussi ce qu'il faut modifier si vous avez des problèmes pour installer un mambot ou un template !!

                    Je suis content !! Merci encore !!




                    PS : rien à voir avec le post juste pr te dire que les liens du header de ton site ne se voye pas (j'ai fait le curieux )
                    Dernière édition par godsilken11 à 29/02/2008, 08h37
                    http://7vents.fr

                    Commentaire


                    • #11
                      Content d'avoir pu t'aider. En fait ce n'était pas une question de droits comme ils ont dit chez OVH.

                      PS : pour les liens sur mon site, ce sont des liens d'évitement, ils n'ont pas forcément besoin d'être très visibles.

                      Thierry
                      Dernière édition par thierry76 à 29/02/2008, 15h18
                      Mon site : Thierry Neveu Photoblog

                      Commentaire

                      Annonce

                      Réduire
                      1 sur 2 < >

                      C'est [Réglé] et on n'en parle plus ?

                      A quoi ça sert ?
                      La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                      Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                      Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                      Comment ajouter la mention [Réglé] à votre discussion ?
                      1 - Aller sur votre discussion et éditer votre premier message :


                      2 - Cliquer sur la liste déroulante Préfixe.

                      3 - Choisir le préfixe [Réglé].


                      4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                      2 sur 2 < >

                      Assistance au forum - Outil de publication d'infos de votre site

                      Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                      Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                      Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                      UTILISER À VOS PROPRES RISQUES :
                      L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                      Problèmes connus :
                      FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                      Installation :

                      1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                      Archive zip : https://github.com/AFUJ/FPA/zipball/master

                      2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                      3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                      4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                      5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                      6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                      et remplacer www. votresite .com par votre nom de domaine


                      Exemples:
                      Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                      Télécharger le script fpa-fr.php dans: /public_html/
                      Pour executer le script: http://www..com/fpa-fr.php

                      Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                      Télécharger le script fpa-fr.php dans: /public_html/cms/
                      Pour executer le script: http://www..com/cms/fpa-fr.php

                      En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                      Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                      Voir plus
                      Voir moins
                      Travaille ...
                      X