Erreur 404 & En chantier sporadique

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Erreur 404 & En chantier sporadique

    Bonjour,

    Nous avons récemment remplacé notre ancien site par un tout nouveau tout beau sous Joomla 1.0.7 à cette adresse : http://www.machinima.fr/

    Nous pensions en avoir *fini* avec les messages Erreur 404 et En chantier (qui ne nous gênaient pas tant que le site était... en chantier).

    Mais malgré la mise en ligne, le problème est récurrent et imprévisible :



    Et voilà ce que me réponds mon hébergeur pour l'ancien site (Postnuke) :
    " c ni l'un ni l'autre mais a mon avis la fameuse propagation de 7 jours (à laquelle je ne croyais pas en fait pour ne l'avoir jamais vu) qui existe vraiment en fait lorsqu'on deplace de serveur un site "
    Et le nouveau (Joomla) :
    " comme je te disais si tu as une 404 ou un "en chantier" ca ne peut venir que de ton site à toi et pas du serveur (sinon ca n'afficherait pas la 404). fo ke tu vois ça avec ton webmaster là c pas de mon ressort du tout vu que je sais pas comment est foutu ton site "

    A signaler que nous avons profité de l'arrivée du nouveau site pour déplacer le contenu et la base de données d'un serveur à l'autre.

    Est-ce que vous pouvez m'aider à y voir clair ?

    // EDIT
    En visualisation la BDD, j'ai vu que JOS_SESSION était le seul à avoir une "perte" de 1444 octets. Ce n'est pas beaucoup mais je me demande si ce n'est pas l'origine du problème : une ou plusieurs sessions restées "ouvertes" qui plombent la BDD. Je fais une recherche sur le sujet sur le forum en attendant vos lumières, merci //

    // EDIT DE L'EDIT
    Bon et bien après avoir titillé le jos_session, le site est miraculeusement revenu... Du coup j'ai supprimé les sessions "sans nome" et vais réduire la durée de log pour voir comment ca se passe // - je note tout ca au cas ou ca pourrait aider...
    Dernière édition par aVe_Machinima à 16/03/2006, 12h56

  • #2
    Bon j'ai supprimé les EDIT de l'ancien post. Apparemment tripatouiller jos_session ne change rien.

    A votre avis, le problème vient-il : du site (joomla + bdd) ou de l'hébergeur ? Et à quel niveau ?

    Commentaire


    • #3
      Salut,

      Je pense que tu as un problème avec le fichier configuration.php qui est à la racine de ton site.
      Edite le et regarde les éléments suivants :

      $mosConfig_absolute_path -> Chemin absolu vers le dossier ou est installé Joomla (fourni par ton hébergeur)

      $mosConfig_live_site -> adresse de ton site (Nom de domaine qui pointe vers le dossier ou est installé Joomla)
      Joomla sur mac en local

      Commentaire


      • #4
        Alors dans Absolute Path j'ai :
        $mosConfig_absolute_path = 'D:\\www\\machinima.fr\\website';

        Dans Config Host j'ai :
        $mosConfig_host = '62.39.109.115';

        Et dans Live Site j'ai :
        $mosConfig_live_site = 'http://www.machinima.fr/';

        Le Live Site me permet d'utiliser la fonction de traduction de Yahoo (et ca marche).

        Sur le serveur le fichier index.php est dans /website/

        Le truc c'est pas que ca foire tout le temps, c'est que en même temps un internaute peut "voir" le site, alors qu'un autre peut avoir l'erreur ! (Moult confirmations par MSN...)

        Commentaire


        • #5
          Tu peux essayer le truc suivant :

          Va dans l'administration Menu Système et cliques sur vider tous les caches
          Joomla sur mac en local

          Commentaire


          • #6
            Ca m'a l'air diablement intéressant, mais je n'ai trouvé que cela dans l'onglet Cache de la Configuration Globale :

            Caching : Non
            Cache Folder : D:\www\machinima.fr\website/cache
            Cache Time : 900

            Est-ce là qu'il faut intervenir ?
            Merci encore pour le coup de main !

            // EDIT
            J'ai regardé d'autres posts, et apparemment le noeud du problème pourrait se tenir dans les caches. Cependant je n'arrive pas à trouver ce miraculeux "Vider tous les caches" dans le BackEnd. Je continue ma recherche.
            Dernière édition par aVe_Machinima à 20/03/2006, 15h41

            Commentaire


            • #7
              Envoyé par aVe_Machinima
              Ca m'a l'air diablement intéressant, mais je n'ai trouvé que cela dans l'onglet Cache de la Configuration Globale :
              Salut,

              Ce n'est pas dans la configuration gobale, mais dans le menu en haut :

              Accueil, Gestion du site, ....., Messages, Système, Aide

              Tu cliques sur Système et vider tous les caches
              Joomla sur mac en local

              Commentaire


              • #8
                YES ! Le cache n'était pas activé, donc je n'avais pas le message.
                Mais alors du coup, un truc intéressant, depuis que j'ai activé le cache, la frontpage du site arrive beaucoup plus vite. Je ne sais pas encore si les coupures existent toujours, mais le site déboule plus vite !

                Merci !

                Commentaire

                Annonce

                Réduire
                1 sur 2 < >

                C'est [Réglé] et on n'en parle plus ?

                A quoi ça sert ?
                La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                Comment ajouter la mention [Réglé] à votre discussion ?
                1 - Aller sur votre discussion et éditer votre premier message :


                2 - Cliquer sur la liste déroulante Préfixe.

                3 - Choisir le préfixe [Réglé].


                4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                2 sur 2 < >

                Assistance au forum - Outil de publication d'infos de votre site

                Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                UTILISER À VOS PROPRES RISQUES :
                L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                Problèmes connus :
                FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                Installation :

                1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                Archive zip : https://github.com/AFUJ/FPA/zipball/master

                2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                et remplacer www. votresite .com par votre nom de domaine


                Exemples:
                Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                Télécharger le script fpa-fr.php dans: /public_html/
                Pour executer le script: http://www..com/fpa-fr.php

                Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                Télécharger le script fpa-fr.php dans: /public_html/cms/
                Pour executer le script: http://www..com/cms/fpa-fr.php

                En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                Voir plus
                Voir moins
                Travaille ...
                X