Au secours

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Au secours

    J'ai tenté aujourd'hui une migration de mambo vers joomla.
    Ça n'a pas fonctionné.
    J'avais bien effectué une sauvegarde sur mon local, mais en réinstallant le tout (copie du local vers le serveur) tout au premier niveau (comme avant), avec tout joomla (new) dans un répertoire à lui (au 1er niveau aussi), je ne peux plus accéder à l'administration. J'ai bien l'écran du login, mambo tente de lancer l'index2 de l'administration mais revient toujours sur l'écran du login.
    Que puis-je faire ? SVP, mon site est hs. Il est sur free.
    Merci de votre réponse.
    Dernière édition par psknsd à 30/11/2005, 14h39 Raison: Réglé

  • #2
    Salut,

    Si tu postes dans un autre forum parce que tu n'as pas de réponse dans celui-ci on ne va pas y arriver
    Prends l'habitude de donner des titres plus explicites aux discussions que tu ouvres..
    ==> Je supprime l'autre discussion

    Ton site est-il très avancé? Beaucoup d'articles rédigés? Beaucoup de composants installés?
    Pas de demande de support en MP ou par mail, le forum est là pour ça!
    http://www.joomla.fr : news, téléchargements, tutoriels, FAQ, traduction, documentation
    http://www.lapatagonie.com : juste pour vous dépayser un peu...

    Commentaire


    • #3
      Bon je me permets de répondre, car je me sent un peu concerné (voir un peu responsable), je connais psknsd et le site, oui le site est avancé, des articles sont rédigés et des composants installés.

      Commentaire


      • #4
        Moyennant quelques pirouettes il y a moyen de migrer son site de mambo vers Joomla! "propremen", sans utiliser la technique de l'écrasement des fichiers/répertoires.
        Pour le contenu et les utilisateurs c'est très facile, pour le reste:

        Quelle est la version de mambo utilisée?
        Quels sont les noms et versions des composants utilisés?
        Pas de demande de support en MP ou par mail, le forum est là pour ça!
        http://www.joomla.fr : news, téléchargements, tutoriels, FAQ, traduction, documentation
        http://www.lapatagonie.com : juste pour vous dépayser un peu...

        Commentaire


        • #5
          (psknsdec escuse moi de mon intrusion mais j'essaye de faire avancer)

          la version est Mambo 4.5.2.3
          les composants : ponygallery, community buider, akocomment, skychat, ext cal, mamboexplorer, simple board, j'en oubli probablement quelques uns.

          le souci actuel est ;
          1 - de réussir à reprendre la commande administration (il reconnait que lorsqu'on inscrit le bon mot de passe, il lance l'index2 pouis revient sur l'index 1),
          2 - puis d'engager dans un second temps la migration.

          à priori certains fichiers clef pour la connexion en administrator on pu être endommager ou perdu lors des transferts de sauvegarde.

          merci par avance de ton aide

          Commentaire


          • #6
            Peut être cela vaudrait le coût de remettre dans le dossier administrator (après une sauvegarde préalable) tout sauf le dossier components, repris depuis les dossiers source de mambo 4.5.2.3.

            c'est une suggestion
            Dernière édition par cant à 27/11/2005, 11h46

            Commentaire


            • #7
              Bon ben on va essayer de partir sur des bases plus sûres

              - Fais une installation propre de Joomla! 1.0.4 dans un sous répertoire de ton site, par exemple http://www.tonsite.com/joomla (ne change pas le préfixe des tables, à savoir jos_ )
              - Ensuite tu installes les composants sur cette nouvelle installation (prends la dernière version des composants, notamment pour CB et Joomlaboard)
              - Enfin tu m'envoies un dump en PM de ton installation actuelle en sélectionant bien les options Inclure des énoncés "DROP TABLE" (pour la structure) et Insertions complètes (pour les données) --> si tu ne sais comment effectuer un dump vois la procédure sur Mambonewbies
              Pas de demande de support en MP ou par mail, le forum est là pour ça!
              http://www.joomla.fr : news, téléchargements, tutoriels, FAQ, traduction, documentation
              http://www.lapatagonie.com : juste pour vous dépayser un peu...

              Commentaire


              • #8
                Migration suite..

                Je m'incruste puisque je rencontre un problème similaire de backend avec ma migration Mambo --> Joomla.

                J'ai donc suivi tes conseils Hornos : nouvelle base Joomla et import de la base de données mambo.
                Alors, maintenant j'ai des champs mos_ et des champs jos_ dans ma base, logique. Puis-je simplement changer le "database prefix" qui est actuellement jos_ par mos_ dans la configuration globale du site ? (et eventuellement supprimer de la base tous les champs en jos_)

                Je pourrai le faire directement mais j'ose pas trop :-s
                Toute nouvelle in the Joomla community,
                Motivée pour apprendre et bientôt contribuer !!

                Commentaire


                • #9
                  Pour Hornos, suite discussion psknsd.
                  Suivant tes conseils, j'ai installé Joomla et tous (je crois, je vois plus mon ancien site) les composants et modules que j'utilisais.
                  J'ai aussi effectué le dump de ma base, mais je ne sais pas comment te la transmettre. Dis-moi comment tu veux procéder.
                  Merci d'avance.

                  Commentaire


                  • #10
                    Bon moi j'ai avancé et changé le nom des tables par mos_

                    Problème 1 : les accents de mes articles sont mal gérés, remplacés par des & et autres signes bizarres, va-t-il falloir que je les remplace un par un, ou refaire l'export ?

                    Problème 2 : j'ai voulu ajouter un lien de menu et même scénario que pour la précédente install, ça tourne dans le vide et je ne peux plus me re-logger.

                    Grrr, je ne m'en sors pas. quelqu'un peut-il m'aider ?
                    Toute nouvelle in the Joomla community,
                    Motivée pour apprendre et bientôt contribuer !!

                    Commentaire


                    • #11
                      Une précision !

                      Je viens de refaire une install' à neuf, pas d'import de base, rien que le pack fourni en basic pour l'install de Joomla et j'ai le même problème : des que je fais "new" menu item, ça tourne dans le vide et impossible de se relogger.

                      Je suis vraiment la seule à qui ça arrive ?!
                      Toute nouvelle in the Joomla community,
                      Motivée pour apprendre et bientôt contribuer !!

                      Commentaire


                      • #12
                        Je m'aperçois que c'est Mysql server 4.1 qui est installé sur mon serveur.

                        Je fais donc la manip préconisée : à savoir renommer database.php et database.mysqli.php. Visiblement ce n'est pas suffisant.

                        Vais-je devoir ré-installer Mysql en une version supérieure ?, sachant que j'ai plusieurs sites mambo qui tournent sans problèmes avec la version 4.1 sur ce même serveur. C'est pas chago ça.
                        Toute nouvelle in the Joomla community,
                        Motivée pour apprendre et bientôt contribuer !!

                        Commentaire


                        • #13
                          Quelqu'un peux-t-il m'éclairer ?

                          à savoir, est-il possible de faire tourner Joomla sur MySql server 4.1 ?
                          ou dois-je passer à Mysql, version supérieure - dans ce cas, quid de mes autres sites Mambo ?

                          Merci de m'aider, toute information est bonne à prendre !!
                          Toute nouvelle in the Joomla community,
                          Motivée pour apprendre et bientôt contribuer !!

                          Commentaire


                          • #14
                            Je continue mon monologue.
                            J'ai téléchargé le pack Joomla 1.0.4 et tout a l'air de fonctionner correctement (add new menu item en tout cas) sans rien changer à ma configuration php / mysql.

                            Je vais tester le site un peu plus en détail, et si tout ok j'adopte.

                            Mais bon, j'avoue avoir été pas loin de laisser tomber Joomla et revenir sur Mambo les gars.
                            Toute nouvelle in the Joomla community,
                            Motivée pour apprendre et bientôt contribuer !!

                            Commentaire


                            • #15
                              alors quel a été le résultat?

                              et euh ta procedure a l'air un peu compliqué non?

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X