Joomladay francophone 2018 à Paris 18 et 19 mai

Problème urgent: accès à l'administration impossible

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] Problème urgent: accès à l'administration impossible

    Bonjour,

    J'ai lu que c'était un problème récurent mais je n'ai pas trouvé de solution sur ce forum.
    J'ai malheureusement désactivé le module user du site joomla sur lequel je travaille et lorsque j'accède à wwww.monsite.fr/administrator et que je rentre mes bons login et mot de passe, il ne cesse de me les redemander, sans jamais me faire entrer dans le back end.

    C'est la même chose en front end, il ne me fait jamais passer en utilisateur enregistré, avec aucun des comptes.

    J'ai essayé en mettant de mauvais login et mot de passe, il les refuse.
    J'ai essayé de modifier les mots de passes en passant par la base de données. La modification marche bien mais je n'accède toujours à rien.
    J'ai également créer un nouveau Super Administrateur il est enregistré mais il n'accède pas non plus ni au front end, ni au back end.

    S'il vous plaît, j'aurais vraiment besoin d'un coup de main!
    Est-il possible de réactiver le module à partir de la base de données? Si oui, comment?
    Y a t il une autre solution?

    Merci d'avance!
    Lisa - Utilisatrice fraiche de Joomla 1.5

  • #2
    Salut Lisa,

    Tu vas dans phpmyadmin, tu ouvres ta base de données, la table jos_plugins,
    tu cherches l'enregistrement 'User - Joomla!', tu l'édites et en face de 'Published',
    tu écris 1 à la place de 0.

    Commentaire


    • #3
      Génial!!!!

      Pilou62, tu es mon sauveur! Ca a marché!

      Merci beaucoup!!! Je me doutais que c'était simple, mais quand on ne sais pas ... on ne sais pas!
      J'avais imprimé ma base de données ainsi qu'une sauvegarde d'il y a deux jours et je m'apprêtais à les comparer champs par champs (80 pages en tout petit)!
      --------------

      J'en profite pour te poser une autre question, (qui est sûrement stupide, je m'en excuse) il me semblait que sur la version précédente de joomla, je pouvais désinstaller des modules et plugins, hors quand je vais dans Extensions, Installer/Désinstaller, je ne peux qu'installer...

      La petite icône "désinstaller" qui était à l'origine à côté de l'icône "aide" n'y est pas...
      Je suis sous joomla 1.5.12
      Du coup, je fais des désinstallations sauvages (suppression du plugins et je vais dans la base de données virer ce qui se rapporte au nom, mais je ne suis pas bien sûre de tout virer... et j'ai d'ailleurs des composants que je ne peux plus installer à cause de ça...). Enfin, c'est pas très beau en tout cas!

      Encore un énorme merci pour cette histoire d'autorisation en tout cas ! Ca me sauve ma journée (voir ma semaine)!
      Lisa - Utilisatrice fraiche de Joomla 1.5

      Commentaire


      • #4
        Là, à mon avis, tu as dû désactivé un module administrateur genre sous-menu ...
        Je regarde et je te dis quoi.

        Commentaire


        • #5
          Voilà, toujours via phpmyadmin, dans ta base de données, ouvre la table jos_modules, trouve l'entrée 'Admin SubMenu' et sur 'Published', mettre 1 à la place de ...

          Commentaire


          • #6
            S'agit-il de ça?
            Parce que c'était déjà sur 1...

            Quelque chose qui cloche?
            Lisa - Utilisatrice fraiche de Joomla 1.5

            Commentaire


            • #7
              Salut Lisa,

              Bizarre, dès que je le mets à 0, les sous-menus disparaissent et dès que je le remets sur 1, ils réapparaissent.

              J'ai aussi la valeur 1 pour ordering (et toi 0) mais je ne sais pas si ça vient de là...
              La posiion, chez moi est submenu et toi header, peut-être la solution est là.

              Commentaire


              • #8
                Voilà, j'ai changé la position (je suis passé de header à submenu) et ça a marché!
                MERCI encore! C'est super!
                Au plaisir de te reposer des questions
                Lisa - Utilisatrice fraiche de Joomla 1.5

                Commentaire


                • #9
                  Bonjour à tous,

                  Désolé de remonter un topic mais j'en ai vraiment besoin car j'ai le même problème.

                  Il me manque également le sub-menu admin et quand je vais sur Installer/Désinstaller, je ne peux qu'installer car il me manque les sous-menus.

                  Je suis allé dans PHPmyadmin > jos_modules mais je ne trouve pas admin sub-menu / sous-menu administration backend.

                  Comment puis-je faire pour réinstaller le menu ?

                  Un grand merci d'avance
                  OBW

                  Commentaire


                  • #10
                    Edit :

                    J'ai donc uploader sur mon FTP le module mod_submenu que j'ai placé dans www/administrator/modules.

                    Dans le mod_submenu, il y a 3 fichiers :
                    - index.html
                    - mod_submenu.php
                    - mod_submenu.xml

                    Je ne sais pas comment installer ce module dans phpMyadmin. Je me doute bien que ça se passe dans la table jos_modules mais comment l'ajouter ?

                    Merci

                    Commentaire


                    • #11
                      Bonjour,
                      il faudra quand même essayer de comprendre un jour comment c'est arrivé...
                      Exécute ça dans phpMyAdmin, après avoir vérifié qu'il n'y a pas de ligne avec ID=13 dans jos_modules.
                      Code:
                      INSERT INTO `jos_modules` (`id`, `title`, `content`, `ordering`, `position`, `checked_out`, `checked_out_time`, `published`, `module`, `numnews`, `access`, `showtitle`, `params`, `iscore`, `client_id`, `control`) VALUES 
                      (13, 'Sous-menu administration backend', '', 1, 'submenu', 0, '0000-00-00 00:00:00', 1, 'mod_submenu', 0, 2, 1, '', 0, 1, '');
                      Schtroumpfe toi le Schtroumpf t'aidera.
                      Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

                      Commentaire


                      • #12
                        Bonjour Grand Schtroumpf,

                        Tout mes respects pour l'aide que tu m'as apportée. En effet ta ligne de code marche à merveille et j'ai retrouvé mon Sous Menu Administration.

                        Je ne comprends pas la ligne de code mais le résultat est là.

                        Je comprends mon erreur, elle vient du fait que j'ai supprimé par erreur le mod_submenu dans "Installer/Désinstaller > Modules > mod_submenu.

                        Un énorme merci

                        Schtroumpfement votre,
                        OBW

                        Commentaire


                        • #13
                          Re,
                          c'était juste une instruction SQL pour recréer la ligne manquante dans la table jos_modules. Comme tu avais remonté les fichiers àla main, ça termine l'installation...
                          J'ai juste fait un export de la ligne à partir d'une base Joomla.
                          Schtroumpfe toi le Schtroumpf t'aidera.
                          Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

                          Commentaire


                          • #14
                            Re,

                            Ok je comprends mieux d'où tu tiens le code maintenant. J'ai une autre question concernant le nom du site qui s'est changé tout seul en "Array". Dois-je poster sur un autre topic ?

                            Merci pour tout

                            Commentaire


                            • #15
                              Merci

                              Un grand merci pour les indications d'où on trouve les données des sous menus administrateur dans la base de données. J'avais fait la bêtise de créer un 2eme module sous menu et le publier... et la j'avais le backend hs!!! PAs évident de savoir ou était caché ce module administrateur dans la bdd !

                              MErci et bravo !

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X