Erreur 404 et bugs après clic sur les lens du site.

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Erreur 404 et bugs après clic sur les lens du site.

    Salut,
    C'est le couak total.
    Après avoir intégré un site en local qui fonctionne parfaitement en local, une fois héberger, les clics sur pas mal de liens du site renvoi les messages d'erreurs du genre:

    404 - Composant non trouvé

    Vous ne pouvez pas visiter cette page car :

    bookmark/favoris périmé
    Un moteur de recherche possède un listing périmé pour ce site
    une adresse erronée
    vous n'avez pas accès à cette page
    La ressource demandée n'a pas été trouvée
    Une erreur est survenue pendant l'exécution de la requête.

    Veuillez essayer l'une des pages suivantes :

    Page d'accueil

    Si les difficultés persistent, merci de contacter l'administrateur de ce site.

    Composant non trouvé


    Merci d'avance pour vos réponses qui m'aideront.
    Dernière édition par donwload_CL à 03/05/2011, 09h01 Raison: Passer le post en REGLE

  • #2
    Re : Erreur 404 et bugs après clic sur les lens du site.

    Bonjour,

    En général, il s'agit d eproblèmes de réécriture d'URLs, sans indications plus précises sur: le SEF Joomla! est-il en service, ainsi que le mod_rewrite apache ? le .htaccess est-il présent ? Utilises-tu un autre système d erewriting (sh404, joomsef...)?
    Pas de demande de support par MP.
    S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

    Commentaire


    • #3
      Re : Erreur 404 et bugs après clic sur les lens du site.

      Oui effectivement après réflexion, je pense aussi qu'il s'agit de problèmes de réécriture d'URLs.

      Et honnêtement je lis ta réponse:
      le SEF Joomla! est-il en service, ainsi que le mod_rewrite apache ? le .htaccess est-il présent ? Utilises-tu un autre système d erewriting (sh404, joomsef...)?
      mais je ne vois pas comment procéder.

      En back end, j'ai les paramètres ci-après:
      Menu Site > Configuration générale > Onglet Site > Panneau Paramètres SEO:

      - URLs explicites (SEF) est activé à Oui
      - Utiliser le module Apachemod_rewrite (réécriture au "vol" des URLs) est activé à Non
      - Ajouter un suffixe aux URLs est acctivé à Non

      Que dois faire? Merci d'avance.

      Commentaire


      • #4
        Re : Erreur 404 et bugs après clic sur les lens du site.

        Si le cache Joomla! est activé, vider le cache pour commencer
        Pas de demande de support par MP.
        S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

        Commentaire


        • #5
          Re : Erreur 404 et bugs après clic sur les lens du site.

          Ouf Joomla, que c'est magnifique!!!
          Voilà en fouillant un peu dans le forum, tout fonctionne maintenant, en fait le contenu du site en ligne est disponible, tout les liens marchent.
          J'ai dû:
          -Activer la cache de Joomla dans le Menu Site> Configuration générale pour la vider ensuite dans le Menu Outils> Nettoyer le Cache.
          -Désactiver à nouveau le cache dans Configuation générale.
          - Renommer le htaccess.txt en .htaccess dans mon dossier racine du site.
          - Dans les Paramètres SEO de la configuration générale j'ai:
          > URLs explicites (SEF) activé à Oui
          > Utiliser le module Apachemod_rewrite (réécriture au "vol" des URLs) activé à Oui
          > Ajouter un suffixe aux URLs est activé à Non
          Oui c'est ok, mais est-ce une manipulation saine et logique qui ne fera pas de bugs plutard svp???
          Merci.

          Commentaire


          • #6
            Re : Erreur 404 et bugs après clic sur les lens du site.

            C'est une configuration classique, qui une fois bien réglée peut fonctionner des années
            Pas de demande de support par MP.
            S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

            Commentaire


            • #7
              Re : Erreur 404 et bugs après clic sur les lens du site.

              Re,
              la manip du cache n'a pas du servir à grand chose vu qu'il n'était pas activé, et tu as fini l'activation propre de la réécriture d'URL (avec un peu de chance, puisque ça a marché du premier coup ! ) donc tout va bien. Tu peux passer le sujet en [réglé].
              Dernière édition par Grand Schtroumpf à 03/05/2011, 10h43
              Schtroumpfe toi le Schtroumpf t'aidera.
              Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

              Commentaire


              • #8
                Re : Erreur 404 et bugs après clic sur les lens du site.

                Merci infiniment.

                Commentaire

                Annonce

                Réduire
                1 sur 2 < >

                C'est [Réglé] et on n'en parle plus ?

                A quoi ça sert ?
                La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                Comment ajouter la mention [Réglé] à votre discussion ?
                1 - Aller sur votre discussion et éditer votre premier message :


                2 - Cliquer sur la liste déroulante Préfixe.

                3 - Choisir le préfixe [Réglé].


                4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                2 sur 2 < >

                Assistance au forum - Outil de publication d'infos de votre site

                Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                UTILISER À VOS PROPRES RISQUES :
                L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                Problèmes connus :
                FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                Installation :

                1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                Archive zip : https://github.com/AFUJ/FPA/zipball/master

                2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                et remplacer www. votresite .com par votre nom de domaine


                Exemples:
                Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                Télécharger le script fpa-fr.php dans: /public_html/
                Pour executer le script: http://www..com/fpa-fr.php

                Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                Télécharger le script fpa-fr.php dans: /public_html/cms/
                Pour executer le script: http://www..com/cms/fpa-fr.php

                En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                Voir plus
                Voir moins
                Travaille ...
                X