Joomladay francophone 2018 à Paris 18 et 19 mai

Insertion d'une image au sein d'un texte

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] Insertion d'une image au sein d'un texte

    Bonjour, je suis un nouvel utilisateur de Joomla, et en tant que débutant je suis pas-à-pas le pdf "Joomla pour les nuls".

    J'essaye de créer un site comme dans l'exemple donné (celui avec les continents et pays pour faire la distinction entre sections, catégories et articles).

    J'en suis au niveau de l'insertion d'une image au sein d'un article, et je rencontre qq problèmes.
    En effet quand j'insère mon image elle se met tjrs au début du texte de l'article et non au sein même de ce texte comme dans l'image exemple du pdf.

    Pour mieux illustrer mes propos voici l'image 1 représentant ce que je veux obtenir, et l'image 2 ce que j'ai moi.



    Image 1



    Image 2

  • #2
    Bonjour,
    tu dois laisser le positionnement à "défaut" alors qu'il faudrait mettre droite ou gauche.
    Schtroumpfe toi le Schtroumpf t'aidera.
    Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

    Commentaire


    • #3
      Bonjour,

      Quand tu insères l'image tu choisis un alignement à gauche (ou à droite) (onglet Apparence), et pour éviter que le texte soit collé à l'image, il te faudra aussi définir une marge à droite (ou à gauche).

      J'espère que cela répond à ta question

      Bonne journée

      Commentaire


      • #4
        Je suis bien allez dans la fenêtre "Apparence" et est bien réglé l'alignement sur la gauche, et celà me donne l'image 2 comme résultat...
        En aucun cas cela me donne l'image 1. C'est pour cela d'ailleurs que je poste sur le forum car si c'était juste un problème de choix d'alignement (à gauche ou à droite) j'y serai arrivé...

        Commentaire


        • #5
          Re,
          et si tu regardes le code de l'article (bouton [HTML] ) tu vois quoi ?
          Schtroumpfe toi le Schtroumpf t'aidera.
          Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

          Commentaire


          • #6
            Voilà le code HTML de mon article :

            <p><img src="images/stories/Asie/Tokyo.jpg" border="0" width="150" />Texte</p>

            D'ailleurs j'ai l'impression que joomla ne sauvegarde aucune modification que j'apporte à cet article, même si je clique sur le bouton "sauver". En tout cas pour ce qui est de toute modifications que j'apporte à l'image, pas pour le texte.

            Commentaire


            • #7
              Bonjour Heimdall31,

              J'ai le même problème que toi : non prise en compte des modifications de positionnement d'une image dans un article.

              Qui a la réponse ?

              Commentaire


              • #8
                Re,
                ça devrait mettre un truc comme :
                <img src="images/stories/articles.jpg" border="0" width="128" height="96" align="left" />
                Si tu ajoutes le align à la main dans la fenêtre HTML, c'est pris en compte ?
                Tu as fait un essai dans un article "vierge" ?
                Schtroumpfe toi le Schtroumpf t'aidera.
                Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

                Commentaire


                • #9
                  Bonjour Grand S.

                  Chez moi aussi aucune modif (hors texte) prise en compte après "sauver". La prévisualisation est correcte. Je suis le superadministrateur de mon site encore local avec ..1.5.14.

                  Parallèlement, il m'est impossible de modifier le CSS d'un template qui reste désespérément en "lecure seule". Voir le post dans le forum ad hoc.

                  Une solution commune à ces problèmes (probablement) d'autorisation ?

                  Cordialement.

                  Commentaire


                  • #10
                    Bon quand je rajoute manuellement align= "left" ça marche parfaitement, et ça me sauvegarde bien la modification apporté à l'article.
                    Par contre si je le fais en passant par le menu d'insertion d'images ça ne marche tjrs pas...Serait-ce un bug ?

                    En tout cas merci pour tes conseils Grand S.

                    Commentaire


                    • #11
                      Idem pour moi. En HTML, les modifications sont prises en compte. Pas avec l'éditeur d'image.

                      Commentaire


                      • #12
                        Re,
                        il y a quelqu'un ces jours-ci qui parlait de téléscopage entre des div nommées du template et les div qu'utilise le javascript de l'éditeur. En changeant de template, ça change quelque chose ?
                        Schtroumpfe toi le Schtroumpf t'aidera.
                        Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

                        Commentaire


                        • #13
                          Pas chez moi, Gd S. !

                          Commentaire


                          • #14
                            Insertion image

                            En fait, il faut revenir au problème initial (j'ai le même !!!). Dans l'éditeur d'article, lorsqu'on utilise le bouton de bas d'éditeur pour inserrer une image, l'image n'est pas inserrée à l'endroit du focus, mais systématiquement au début du texte (c'est TRES énervant).

                            J'ai un autre plugin qui me permet d'inserrer des videos et du son (AllVideo). Le phénomène est le même.

                            J'ai donc l'impression que ce n'est pas dû aux outils, mais bien à un bug Joomla. Je n'ai pas d'éléments de réponse pour le moment. Je cherche. Si je trouve, je reviens pour vous en causer ...

                            A+

                            Commentaire


                            • #15
                              Bonjour Breizhooo,

                              Enervant, c'est le mot !
                              Ma solution provisoire : insérer l'image dans le texte, puis la positionner en html (j'ai trouvé comment coder).
                              A suivre...

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X