1 question : affichage articles en blog

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • 1 question : affichage articles en blog

    Bonjour,

    Quelqu'un pourrait-il m'éclairer ?

    Pourquoi quand par un menu je demande l'affichage d'un seul article, celui-ci n'est pas coupé et sa dimension est "relative" par défaut (il est affiché en entier sans être masqué par la position right ou sans déborder sur la position right)

    Et par contre quand je sélectionne l'affichage de plusieurs articles en blog, ce même article est coupé sur la droite par la position right ?

    Par avance merci
    Dernière édition par idnov à 17/09/2009, 09h13

  • #2
    Bonjour,

    N'y aurait-il pas un module associé à l'élément de menu dans un cas et pas dans l'autre ?

    Commentaire


    • #3
      Non car dans les 2 cas, j'ai modifié le même élément de menu

      Ne serait-ce pas qq chose par défaut dans l'affichage "blog" qui expliquerait cette situation ?

      Commentaire


      • #4
        Bonjour,
        tu utilises quel template ?
        Schtroumpfe toi le Schtroumpf t'aidera.
        Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

        Commentaire


        • #5
          Bonjour Grand Schtroumpf,

          J'utilise versality 4, mais le souci est le même avec ja purity

          Commentaire


          • #6
            Bonjour, ja Purity fonctionne raisonnablement donc c'est plutôt ton article... Image trop grande, codes HTML suspects hérités de copier/coller malheureux...
            Schtroumpfe toi le Schtroumpf t'aidera.
            Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

            Commentaire


            • #7
              Merci pour la piste mais ce n'est pas lié à l'article car j'ai essayé avec d'autres articles - dont un très simple sans image. Encore une fois, avec l'un ou l'autre template c'est la même chose (NB : je n'ai jamais touché au code de Ja Purity)

              Mais j'ai fait un test intéressant :
              - je crée un article qui ne contient qu'une suite ininterrompue de caractères (càd sans ponctuation)
              - cet article, qu'il soit affiché seul ou en blog avec d'autres articles, est masqué par le module placé en position right
              - mais s'il contient de la ponctuation (un point par exemple), cet article est correctement affiché lorsqu'il est seul mais pas en mode blog !

              Est ce que l'affichage blog ignorerait certaines caractéristiques de l'article comme la ponctuation ?

              Commentaire


              • #8
                J'ai trouvé une demie-solution, donc j'ai toujours un demi-problème - j'ai fait varier dans template_css :

                table.blog
                (...)
                .contentpane, .contentpaneopen {width: 85%;} au lieu de 100%

                Cela s'applique à l'affichage blog, c'est normal - mais également à l'affichage d'un seul article. N'y aurait-il pas un moyen de spécifier une valeur spécifique l'affichage d'un seul article ?
                J'ai fait plusieurs essais mais rien ne marche. Quelqu'un pourrait-il m'aider ?

                Commentaire


                • #9
                  Bonjour,
                  je me permets d'insister lourdement...
                  JA Purity est un bon template, qui fonctionne correctement sans masquer des trucs avec son module right. Donc si ça se produit aussi avec JA purity, inutile de chercher à modifier à tout prix ton template, le problème est ailleurs :
                  > mauvaise installation de Joomla -> insister en FTP
                  > codes HTML suspects hérités de copier/coller malheureux dans les articles (tu n'a pas répondu à ça),
                  > plugin délirant...
                  Schtroumpfe toi le Schtroumpf t'aidera.
                  Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

                  Commentaire


                  • #10
                    Bonjour,

                    Pour répondre à tes questions :
                    - je travaille en local,
                    - concernant des codes "html douteux hérités de copier/coller malheureux", j'ai fait attention, aucun copier/coller et j'ai refait le test avec des articles différents
                    - concernant un éventuel plug in délirant, à quoi penses tu ?

                    Commentaire


                    • #11
                      Bonjour,
                      concernant un éventuel plug in délirant, à quoi penses tu ?
                      à aucun en particulier, mais un plugin pourrait ajouter dans la page du html mal ficelé qui mettrait le bazar...
                      Ça pourrait aussi venir du module publié en right pour les mêmes raisons...

                      Peut-être en repartant d'une installation vierge. Données exemple + JA_purity, ajouter un module à droite sur toutes les pages (une copie de menu...) on vérifie que ça marche.
                      Puis remplacer les articles par les tiens, le module à droite par le tien, installer progressivement toutes tes extensions... jusqu'à ce que ça plante !

                      Tu peux aussi en utilisant Firefox+firebug analyser la page et tester des modifs pour essayer d'identifier le code et/ou le css qui est à l'origine de ça, retsera à trouver d'où il sort !
                      Schtroumpfe toi le Schtroumpf t'aidera.
                      Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

                      Commentaire


                      • #12
                        Merci Grand Schtroumpf pour ces conseils. Il semble que ce soit la structure de mes articles (tableau avec images) qui pose problème pour les templates Ja purity et versality 4 car j'ai essayé de changer de template et plus de problème (Afterburner de Rocket theme)

                        Merci encore

                        Commentaire


                        • #13
                          Bonjour,
                          pense à passer le sujet en [réglé].
                          http://forum.joomla.fr/announcement.php?f=128
                          Schtroumpfe toi le Schtroumpf t'aidera.
                          Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

                          Commentaire

                          Annonce

                          Réduire
                          1 sur 2 < >

                          C'est [Réglé] et on n'en parle plus ?

                          A quoi ça sert ?
                          La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                          Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                          Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                          Comment ajouter la mention [Réglé] à votre discussion ?
                          1 - Aller sur votre discussion et éditer votre premier message :


                          2 - Cliquer sur la liste déroulante Préfixe.

                          3 - Choisir le préfixe [Réglé].


                          4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                          2 sur 2 < >

                          Assistance au forum - Outil de publication d'infos de votre site

                          Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                          Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                          Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                          UTILISER À VOS PROPRES RISQUES :
                          L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                          Problèmes connus :
                          FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                          Installation :

                          1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                          Archive zip : https://github.com/AFUJ/FPA/zipball/master

                          2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                          3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                          4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                          5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                          6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                          et remplacer www. votresite .com par votre nom de domaine


                          Exemples:
                          Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                          Télécharger le script fpa-fr.php dans: /public_html/
                          Pour executer le script: http://www..com/fpa-fr.php

                          Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                          Télécharger le script fpa-fr.php dans: /public_html/cms/
                          Pour executer le script: http://www..com/cms/fpa-fr.php

                          En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                          Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                          Voir plus
                          Voir moins
                          Travaille ...
                          X