Icone d'impression remplacé par "Array Imprimer Array"

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Icone d'impression remplacé par "Array Imprimer Array"

    Bonjour,

    Les recherches ne m'ayant pas permis d'avoir la solution, je rouvre un sujet.

    Sur un site en 1.5.14, les paramètres généraux des articles sont à "montrer" pour les icônes, et afficher PDF, imprimer et mail.

    Sur certains articles, les trois icônes PDF, impression et e-mail sont bien affichés. Mais sur d'autres, je ne retrouve que le texte "Array Imprimer Array" sans les mentions PDF et mail, alors que les paramètres sont à "défaut".
    Si je les force à "Montrer" dans les paramètres de l'article, les textes "PDF" et "Mail" apparaissent à la place des icônes !
    Ces articles se comportent donc totalement différemment des autres, alors qu'ils n'ont apparemment rien de spécial !

    Exemple sans icônes : http://www.chamant.fr/La-cantine/menus.html
    et un autre article où ils apparaissent : http://www.chamant.fr/Calendriers/vie-pratique.html

    Quelqu'un aurait-il une idée de la cause d'un tel phénomène ?

    Merci d'avance,
    Robert
    Dernière édition par RobertG à 08/10/2009, 17h13
    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

  • #2
    Bonjour,
    ça ne t'aidera pas beaucoup si ça marche, mais essaye de désactiver l'url rewriting le temps d'un test, pour voir...
    Schtroumpfe toi le Schtroumpf t'aidera.
    Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

    Commentaire


    • #3
      J'y avais pensé, je viens de le faire, mais ça ne change rien, même après avoir vidé tous les caches et changé de navigateur !

      Edit : j'ai créé un nouvel article où j'ai copié le contenu de l'autre, et oh miracle, les icônes sont réapparus ! Allez savoir pourquoi !!!
      Dernière édition par RobertG à 08/10/2009, 17h12
      "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

      Commentaire


      • #4
        Re,
        j'ai retrouvé des posts sur le sujet qui parlent de ICON_SEP=| dans le fr-FR.ini où le pipe serait à remplacer par un - ou n'importe quoi d'autre...
        Schtroumpfe toi le Schtroumpf t'aidera.
        Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

        Commentaire


        • #5
          J'avais vu ces discussions, mais alors que tout est paramétré pour que ce soient les trois icônes qui s'affichent, on retrouve du texte dans ces articles, avec "Array" à la place de "|". Et aucun texte ne remplace les icônes "PDF" et "mail", ce qui est encore une anomalie...
          J'en ai déduit qu'il y avait peut-être un problème avec les articles eux-mêmes, et en en créant un nouveau, où j'ai collé le texte d'un précédent, copié depuis l'affichage sur le site, tout est rentré dans l'ordre !
          La question est maintenant de savoir ce qui, dans le code de l'article, peut perturber la gestion des icônes en question. Je ne m'y suis pas plongé.
          Dernière édition par RobertG à 08/02/2010, 20h40
          "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

          Commentaire


          • #6
            problème urgent

            Bonjour, après avoir lu le post je ne vois aucune solution au problème cité.
            J'ai le meme problème et j'aimerais bien le résoudre.
            Y'a t'il une bonne ame qui pourrait me donner une soluce ?
            Merci
            chris
            joomla 1.5.10
            virtuemart 1.1.6

            Commentaire


            • #7
              Bonjour,
              Y'a t'il une bonne ame qui pourrait me donner une soluce ?
              Ben c'est à peu près ecrit au dessus non ? Tu as le pb avec tous les articles ?
              > oui : va dans le languages/fr-FR/fr-FR.ini et remplace ICON_SEP=| par ICON_SEP=:
              > non juste un ou deux : crée des nouveaux articles, copie dedans le contenu des articles à problème et supprime les anciens.
              Schtroumpfe toi le Schtroumpf t'aidera.
              Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

              Commentaire


              • #8
                J'ai quand meme pas mal d'artcile ça fait beaucoupe de boulot. Y'aurais pas une autre solution ?
                Merci
                chris
                joomla 1.5.10
                virtuemart 1.1.6

                Commentaire

                Annonce

                Réduire
                1 sur 2 < >

                C'est [Réglé] et on n'en parle plus ?

                A quoi ça sert ?
                La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                Comment ajouter la mention [Réglé] à votre discussion ?
                1 - Aller sur votre discussion et éditer votre premier message :


                2 - Cliquer sur la liste déroulante Préfixe.

                3 - Choisir le préfixe [Réglé].


                4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                2 sur 2 < >

                Assistance au forum - Outil de publication d'infos de votre site

                Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                UTILISER À VOS PROPRES RISQUES :
                L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                Problèmes connus :
                FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                Installation :

                1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                Archive zip : https://github.com/AFUJ/FPA/zipball/master

                2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                et remplacer www. votresite .com par votre nom de domaine


                Exemples:
                Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                Télécharger le script fpa-fr.php dans: /public_html/
                Pour executer le script: http://www..com/fpa-fr.php

                Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                Télécharger le script fpa-fr.php dans: /public_html/cms/
                Pour executer le script: http://www..com/cms/fpa-fr.php

                En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                Voir plus
                Voir moins
                Travaille ...
                X