Joomladay francophone 2018 à Paris 18 et 19 mai

Bouton "Lire la Suite" ferme l'article en cours d'édition

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] Bouton "Lire la Suite" ferme l'article en cours d'édition

    Bonjour,

    Depuis que j'ai mis à jour certains site de la 1.5.9 vers la 1.5.14 puis 1.5.15, le bouton "lire la suite" de l'éditeur ferme l'article en cours d'édition sans ajouter le "lire la suite". J'utilise donc depuis le nouveau bouton "basculer l'éditeur"( - génial, merci à eux! ;-)), et je rajoute manuellement la balise hr. Mais je dois livrer un site à des clients qui voudraient éditer leurs articles, et je suis un peu géné de leur expliquer cette manip qui fait un peu "bricolage".
    Il me semble que ce n'est pas dépendant du navigateur.
    Je suis un peu surpris de ne pas avoir lu de posts sur ce sujet : suis-je le seul à avoir ce problème?
    Quelqu'un aurait il une idée?
    Site : http://www.cyber-diego.com
    Blog perso : http://cyber-diego.blogspot.com

  • #2
    1.5.15 incompatible avec le bouton "lire la suite"

    Bonjour à tous
    Je rencontre le même problème avec le bouton "Lire la Suite" qui me ferme l'article en cours d'édition. Je suis en version 1.5.15 avec un template de rockettheme. Devant ce problème j'ai testé la version stable 1.5.15 de joomla. j'ai installé JCE 156 et j'ai rencontré le même problème. Donc nouvelle installation avec JCE 157 et c'est toujours pareil. J'ai lu quelque part sur le forum qu'avec la version 1.5.15 le bug serait résolu.

    J'en suis arrivé à la conclusion que la version actuelle de JCE est incompatible avec joomla 1.5.15. Bien evidemment comme je l'ai lu quelque part j'ai désactivé le plugin "read more" et utilise le bouton de JCE "article readmore".

    Si quelqu'un à une autre info.....
    Merci

    Commentaire


    • #3
      même soucis

      impossible de faire un "suite", l'article disparaît, du coup je ne peux plus paginer mes articles qui sont très long...
      help !!!!

      Commentaire


      • #4
        Bouton Lire la suite

        Salut
        Et en utilisant le bouton de JCE "article readmore" cela devrait le faire ???

        Commentaire


        • #5
          JComment aussi...

          Bonjour,

          Je rencontre le même problème (Joomla 1.5.15 et JCE 1.5.7 et plug in 1.5.4). Je ne trouvais pas cela embêtant car JCE possède lui aussi un bouton READ MORE qui fonctionne lui parfaitement bien.

          Le problème est que j'extension JComment (avec ses boutons au même endroit que LIRE LA SUITE) réagit aussi de la sorte en quittant l'article brusquement.

          Les recherches sont en cours...

          Commentaire


          • #6
            La réponse est donnée plus haut... sous JCE il existe une îcone pour cela... le lien en bas "lire la suite" ne fonctionne pas.

            Commentaire


            • #7
              La réponse est donnée plus haut... sous JCE il existe une îcone pour cela... le lien en bas "lire la suite" ne fonctionne pas.

              Commentaire


              • #8
                Bonjour bénéluz,

                Ce que tu dis est tout à fait exact et appuie mes propos par l'image ce qui est encore mieux.

                Le soucis est :
                - pourquoi ce bug est rencontré avec JCE (on aurait très bien pu mettre un message du type "désactivé" au lieu de faire planter l'article)
                - si l'éditeur JCE présente un bouton pour résoudre cela, l'éditeur de Jcomment n'en présente pas

                La seule solution est donc actuellement de copier/coller la balise ReadMore dans le code HTML. Peu élégant pour des clients.

                Excellente journée.

                Commentaire


                • #9
                  C'est vrai qu'on peut toujours insérer la balise à la main... moins pratique effectivement pour les novices.
                  Je ne sais pas pourquoi avec certains éditeurs ça marche... où pas.
                  Joomla est plein de surprise.... ;-)

                  Commentaire


                  • #10
                    Bonjour,
                    je viens d'avoir le problème sur un site en dev : le bouton lire la suite (en bas de l'éditeur) fermait la fenêtre, les autres boutons du bas (page suivante, Phoca gallery) yoyotaient avec des vriantes. JCE ou tinyMCE même combat.
                    Après enquête j'avais déjà le problème sur la pré-install en local.

                    J'ai réinstallé un site à partir d'un paquet Joomla tout neuf, ça marchait. J'ai installé dessus un JCE com157/plg156 tout neuf de chez sarki, ça marchait toujours. J'ai copié sur mon site en panne le dossier /plugins/editors, tout est rentré dans l'ordre.
                    En suivant le début du transfert FTP, j'ai vu que quelques fichiers n'avaient pas la bonne taille. Mystère...
                    Schtroumpfe toi le Schtroumpf t'aidera.
                    Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

                    Commentaire

                    Annonce

                    Réduire
                    1 sur 2 < >

                    C'est [Réglé] et on n'en parle plus ?

                    A quoi ça sert ?
                    La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                    Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                    Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                    Comment ajouter la mention [Réglé] à votre discussion ?
                    1 - Aller sur votre discussion et éditer votre premier message :


                    2 - Cliquer sur la liste déroulante Préfixe.

                    3 - Choisir le préfixe [Réglé].


                    4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                    2 sur 2 < >

                    Assistance au forum - Outil de publication d'infos de votre site

                    Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                    Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                    Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                    UTILISER À VOS PROPRES RISQUES :
                    L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                    Problèmes connus :
                    FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                    Installation :

                    1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                    Archive zip : https://github.com/AFUJ/FPA/zipball/master

                    2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                    3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                    4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                    5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                    6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                    et remplacer www. votresite .com par votre nom de domaine


                    Exemples:
                    Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                    Télécharger le script fpa-fr.php dans: /public_html/
                    Pour executer le script: http://www..com/fpa-fr.php

                    Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                    Télécharger le script fpa-fr.php dans: /public_html/cms/
                    Pour executer le script: http://www..com/cms/fpa-fr.php

                    En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                    Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                    Voir plus
                    Voir moins
                    Travaille ...
                    X