stockage des parametres de confiugration des articles

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • stockage des parametres de confiugration des articles

    Bonjour,

    Je n'arrive pas à modifier de manière globale le paramétrage générale des articles (affichage de l'auteur, dates, ...).
    Dans le backoffice, en cliquant sur l'icone paramètres (en haut à droite liste de tous les articles), cela n'a aucun effet.
    J'ai réinstallé les patch 1.5.20 sans changements.

    Je souhaite du coup, le changer manuellement dans un fichier ou la base si je n'arrive pas à trouver la raison !!

    a+
    Dernière édition par herve à 27/09/2010, 12h08
    Guide pour débutants des principaux outils, ressources et logiciels libres + alternatives à Google : http://www.clibre.eu/

  • #2
    Même problème pour moi...HELP PLEASE !!!!

    Commentaire


    • #3
      Bonjour,
      Je n'arrive pas à modifier de manière globale le paramétrage générale des articles (affichage de l'auteur, dates, ...).
      Tous ces paramètres sont redéfinis dans les éléments de ment, et pour une bonne part dans les articles. Pour que le paramétrage du niveau "au-dessus" s'applique, il faut que les paramètres soient réglés sur "Paramètres globaux" ce qui est la cas par défaut en cas de création, mais pas si tu as recyclé des données exemple.
      Schtroumpfe toi le Schtroumpf t'aidera.
      Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

      Commentaire


      • #4
        Bonjour,

        Pour moi c'est réglé, j'ai trouvé la solution hier soir...

        En fait, il y a 3 choses :

        1°) Modifier comme tu veux les paramètres globaux (Article manager -> Parameters)
        2°) Bien configurer tes articles avec dans la partie "Parameters (Advanced)" -> "Use global" partout
        3°) Bien configurer tes menus avec dans la partie "Parameters (Advanced)" -> "Use global" partout

        Voila pour moi ca fontionne niquel

        Commentaire


        • #5
          Bonjour,
          Pour moi c'est une nouvelle installation J! 1.5.20.
          Je n'ai donc pas modifié les paramètres généraux mais il est vrai que si je règle les paramètres au niveau de l'article, cela fonctionne.
          Il y a peut-être eu un problème de transfert de fichier php ou autre. C'est pour cela que je souhaite savoir ou sont stockés ces paramètres.

          Dans joomla 1.0, c'était dans le configuration.php.

          Sur une autre installation, en modifiant dans les paramètres généraux de tous les articles, je n'ai pas vu de fichier php modifié mais je n'arrive pas non plus à trouver une table qui pourrait les contenir
          a+
          Guide pour débutants des principaux outils, ressources et logiciels libres + alternatives à Google : http://www.clibre.eu/

          Commentaire


          • #6
            Pour info je suis aussi en J 1.5.20

            Commentaire


            • #7
              Bonjour,
              Je n'ai donc pas modifié les paramètres généraux
              Et ben dans ces conditions c'est normal qu'il ne se passe rien ! Tu dis pourtant : Dans le backoffice, en cliquant sur l'icone paramètres (en haut à droite liste de tous les articles), cela n'a aucun effet. ça veut dire que tu ne peux pas modifier ou que tu modifies et que ça n'a pas d'impact ?

              C'est pour cela que je souhaite savoir ou sont stockés ces paramètres.
              Table jos_components, enregistrement "Articles", colonne params.
              Schtroumpfe toi le Schtroumpf t'aidera.
              Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

              Commentaire


              • #8
                Envoyé par Grand Schtroumpf Voir le message
                Bonjour,
                Et ben dans ces conditions c'est normal qu'il ne se passe rien !
                Effectivement je dis n'importe quoi. pas bien réveillé moi

                Je confirme seul les modifications au niveau de l'article sont pris en compte et pas au niveau du blog ou au niveau global.

                Je suis parti dans une réinstallation complète de Joomla 1.5.20 dans un nouveau répertoire et j'y ai collé (par ftp) tous les nouveaux fichiers ou répertoires crées.
                J'ai beau modifié les paramètres globaux (Article manager -> Parameters)


                J'ai essayé aussi en modifiant la table dans la base. Je vois bien la répercussion dans le back office.
                Réciproquement en modifiant dans les paramètres généraux du back office, je vois la modification dans la table de la base

                Mais à l'affichage, rien n'y fait

                A priori la base fonctionne, j'ai appliqué le patch 1.5.20 puis réalisé la réinstallation complète (via FTP). Je suis chez OVH en php 5 donc à priori aussi avec de bon paramètre. J'ai aussi essayé de désactiver certains composants pour voir s'il y a avait interférence ...

                Il me reste pus qu'à modifier des dizaines d'articles à la main
                a moins que vous ayez d'autres suggestions ?

                a+
                Dernière édition par herve à 28/09/2010, 12h20 Raison: ajout de test
                Guide pour débutants des principaux outils, ressources et logiciels libres + alternatives à Google : http://www.clibre.eu/

                Commentaire


                • #9
                  Confiramtion du problème

                  Bonjour,

                  Mon premier post parmi vous.
                  Effectivement sur ma version standard joomla 1.5.20 (avec easyPHP5.2.10), alors que les paramètres sur les articles sont sur global et qu'au niveau paramètres global article j'ai précisé que je ne voulais pas voir le nom de l'auteur et les dates, cela ne fonctionne pas, je suis obligé de changer les paramètres pour chacun des articles.
                  Si vous avez une solution je suis preneur ! (en même temps si je ne rencontre que ce problème dans le projet sur lequel je me suis lançé, j'y survivrais..)

                  Commentaire


                  • #10
                    Re,
                    c'est l'auberge espagnol ce fil !
                    Je confirme seul les modifications au niveau de l'article sont pris en compte et pas au niveau du blog ou au niveau global.
                    Je pense que tu te goures, refais le test calmement... Si l'article est sur global, Joomla regarde au niveau au dessus, si l'élément de menu est sur global, Joomla monte jusqu'au niveau global.

                    alors que les paramètres sur les articles sont sur global et qu'au niveau paramètres global article j'ai précisé que je ne voulais pas voir le nom de l'auteur et les dates, cela ne fonctionne pas, je suis obligé de changer les paramètres pour chacun des articles.
                    Là tu ne prouves rien puisque tu ignores complétement le niveau "élément de menu" : s'il n'est pas su global, le niveau paramètres global article n'est pas "visible" !
                    Schtroumpfe toi le Schtroumpf t'aidera.
                    Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

                    Commentaire

                    Annonce

                    Réduire
                    1 sur 2 < >

                    C'est [Réglé] et on n'en parle plus ?

                    A quoi ça sert ?
                    La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                    Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                    Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                    Comment ajouter la mention [Réglé] à votre discussion ?
                    1 - Aller sur votre discussion et éditer votre premier message :


                    2 - Cliquer sur la liste déroulante Préfixe.

                    3 - Choisir le préfixe [Réglé].


                    4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                    2 sur 2 < >

                    Assistance au forum - Outil de publication d'infos de votre site

                    Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                    Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                    Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                    UTILISER À VOS PROPRES RISQUES :
                    L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                    Problèmes connus :
                    FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                    Installation :

                    1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                    Archive zip : https://github.com/AFUJ/FPA/zipball/master

                    2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                    3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                    4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                    5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                    6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                    et remplacer www. votresite .com par votre nom de domaine


                    Exemples:
                    Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                    Télécharger le script fpa-fr.php dans: /public_html/
                    Pour executer le script: http://www..com/fpa-fr.php

                    Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                    Télécharger le script fpa-fr.php dans: /public_html/cms/
                    Pour executer le script: http://www..com/cms/fpa-fr.php

                    En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                    Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                    Voir plus
                    Voir moins
                    Travaille ...
                    X