Les liens mailto ne marchent pas même en désactivant content-Email cloaking !

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] Les liens mailto ne marchent pas même en désactivant content-Email cloaking !

    Bonjour à tous,

    Je me résigne à poser la question sur le forum car après avoir trouvé pas mal de réponses sur le sujet, je reste "coincé" sur mon problème.
    Version 1.5.22

    Pour créer un lien vers une adresse mail, je sélectionne un mot dans le texte, choisis l'îcone lien et je mets dans l'URL l'adresse du genre : "mailto : adresse@site.fr" et normalement, ça devrait le faire... et ben non !

    Voilà l'adresse que je vois dans l'URL : http://mce_host/mailto : adresse@site.fr

    Donc Joomla a rajouté un préfixe http://mce_host/ que je ne demandais pas !

    J'ai cherché sur le forum et lu qu'il suffisait de désactivé le plug-in Content-Email cloaking. Je me suis empressé de le faire, tout heureux de voir que je tenais la solution... et ben non !! J'ai toujours la même chose même si je supprime le lien et que je le recrée après désactivation du plug-in....

    J'ai même essayé en désactivant le plug-in SEF (parce que j'ai vu ça sur le forum aussi)...

    Je suis désemparé, d'autant plus que sur un autre site que j'ai fait il y a un an (avec la même version) : je n'ai eu aucun souci et sans désactiver quoi que ce soit !!!

    J'ai aussi essayé en allant directement dans le html et en insérant :
    <a href="mailto: nom@domaine.com <lien> /a> mais meme ce morceau de html se trouve modifié quand je retourne le vérifier.....

    J'ai aussi tenté le <p>{emailcloak=off} </p> juste avant le lien mais rien n'y fait et le {emailcloak=off} est visible sur la page publique....

    Si quelqu'un peut m'aider, j'apprécierais....

    Etienne.

  • #2
    Re : Les liens mailto ne marchent pas même en désactivant content-Email cloaking !

    Bonjour,
    as tu essayé en désactivant ton éditeur ?
    Version 1.5.22
    La version stable de Joomla 1.5 est 1.5.26 :
    http://aide.joomla.fr/telechargement...r-joomla-1-5-x
    JoomlaDay FR 2018 - 18/19 Mai 2018 ! J'y serai ... et vous ?

    Envie de lire sur Joomla!, mais pas que ? Cinnk magazine http://cinnk.com/magazine

    Pour apprendre à construire votre site web avec Joomla 3 : Joomla3! Le Livre Pour Tous : http://cinnk.com/joomla/3/le-livre-pour-tous
    Créez votre boutique en ligne avec Joomla! & HikaShop http://cinnk.com/boutique/livres/cre...la-et-hikashop

    Commentaire


    • #3
      Re : Les liens mailto ne marchent pas même en désactivant content-Email cloaking !

      Bonjour SimonG et merci de m'avoir répondu.

      Je viens d'essayer en paramétrant sur "Editor-No editor". Ensuite j'ai modifié le lien directement dans le html de l'article. Ce lien ne semble pas subir de modification ensuite puisque quand j'y retourne j'ai bien l'expression :
      <a href="mailto : webmaster@monsite.fr">webmaster</a>
      mais en revanche le lien ne fonctionne toujours pas puisque, quand on survole le lien de la page publique avec la souris on voit qu'il y a encore un préfixe (différent) qui a été ajouté : ça ressemble à htt://monsite/index.php juste avant le mailto....

      Quand à faire évoluer la version en 1.5.26 : peut-être (mais je ne maîtrise pas bien la mise à jour !) mais je ne suis pas plus convaincu que cela de cette nécessité car, un autre site, fait l'an dernier avec cette même version en 1.5.22 fonctionne !! Mais je m'en vais voir comment je peux faire la mise à jour...

      A cet instant : j'ai donc toujours mon problème et je continue de chercher.... tout en espérant qu'un aimable forumer ait une solution.

      Merci d'avance.

      Etienne.

      Bien

      Commentaire


      • #4
        Re : Les liens mailto ne marchent pas même en désactivant content-Email cloaking !

        Bonjour,

        au cours de tes recherches, as tu vu ce post :
        http://forum.joomla.fr/showthread.ph...ghlight=mailto

        Quand à faire évoluer la version en 1.5.26 : peut-être (mais je ne maîtrise pas bien la mise à jour !) mais je ne suis pas plus convaincu que cela de cette nécessité car, un autre site, fait l'an dernier avec cette même version en 1.5.22 fonctionne !! Mais je m'en vais voir comment je peux faire la mise à jour...
        Pour faire cette mise à jour, tout est expliqué dans le lien que je t'ai donné. C'est important à faire car ces mises à jour contiennent des corrections de bugs et de failles de sécurité.
        JoomlaDay FR 2018 - 18/19 Mai 2018 ! J'y serai ... et vous ?

        Envie de lire sur Joomla!, mais pas que ? Cinnk magazine http://cinnk.com/magazine

        Pour apprendre à construire votre site web avec Joomla 3 : Joomla3! Le Livre Pour Tous : http://cinnk.com/joomla/3/le-livre-pour-tous
        Créez votre boutique en ligne avec Joomla! & HikaShop http://cinnk.com/boutique/livres/cre...la-et-hikashop

        Commentaire


        • #5
          Re : Les liens mailto ne marchent pas même en désactivant content-Email cloaking !

          Oui, j'ai vu.... Mais mon pb est que même en désactivant le mailcloaking : ça ne marche toujours pas !!!

          OK, je vais faire la mise à jour (ça me paraît simple), mais sans doute que demain.... faut que je parte...

          Merci et on se tient au courant ! Bonne journée.

          Etienne.

          Commentaire

          Annonce

          Réduire
          1 sur 2 < >

          C'est [Réglé] et on n'en parle plus ?

          A quoi ça sert ?
          La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

          Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

          Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
          Comment ajouter la mention [Réglé] à votre discussion ?
          1 - Aller sur votre discussion et éditer votre premier message :


          2 - Cliquer sur la liste déroulante Préfixe.

          3 - Choisir le préfixe [Réglé].


          4 - Et voilà… votre discussion est désormais identifiée comme réglée.

          2 sur 2 < >

          Assistance au forum - Outil de publication d'infos de votre site

          Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

          Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

          Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

          UTILISER À VOS PROPRES RISQUES :
          L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

          Problèmes connus :
          FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

          Installation :

          1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

          Archive zip : https://github.com/AFUJ/FPA/zipball/master

          2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

          3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

          4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

          5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

          6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
          et remplacer www. votresite .com par votre nom de domaine


          Exemples:
          Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
          Télécharger le script fpa-fr.php dans: /public_html/
          Pour executer le script: http://www..com/fpa-fr.php

          Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
          Télécharger le script fpa-fr.php dans: /public_html/cms/
          Pour executer le script: http://www..com/cms/fpa-fr.php

          En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

          Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
          Voir plus
          Voir moins
          Travaille ...
          X