Bouton "lire la suite"

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Bouton "lire la suite"

    Bonjour, Je rencontre un problème avec le bouton "lire la suite". Lorsque que je clique dessus une barre grise se met en place dans mon éditeur Par contre en page d'accueil le bouton n'apparaît pas "barre grise"? Je dispose de joomla version 1.5.3. et j'ai fais la mise à jour de l'éditeur TinyMCE. Quelqu'un peut-il m'aider please !!!
    Dernière édition par franckophone à 24/06/2008, 11h17

  • #2
    La "barre grise" permet de séparer visuellement le texte d'intro du texte principal dans l'éditeur seulement.
    S'il y a un texte principal ET que le paramètre ad hoc est choisi pour votre menu composant page d'acceuil, un lien "Lire la suite" apparaitra à la fin de l'intro de l'article.
    Jean-Marie Simonet / infograf768
    Joomla co-fondateur. Joomla Production Working Group.
    Sauf demande explicite de ma part, merci de ne pas utiliser de Message Privé pour poser des questions. Le forum est là pour ça.

    Commentaire


    • #3
      Ok pour la barre de séparation dans l'éditeur <hr id="system-readmore"> par contre dans la page d'accueil mon article s'affiche dans ça totalité. La séparation entre le texte principal et le secondaire est inexistante aucun lien "lire la suite" mais une barre grise. Dans le "main menu" "accueil" paramètre du composant j'ai activé dans l'onglet "Afficher le texte d'introduction" "monter" et "Lire la suite... Lien" "montrer" ? J'ai entendu dire qu'il y avait un problème de fermeture de balise <hr id="system-readmore"> <hr id="system-readmore" /> ?

      Commentaire


      • #4
        dans la 1.5.3 c'est:
        <hr id="system-readmore" />
        et cela marche OK avec la version de TinyMCE par défaut (ainsi que JCE et FCK)
        Jean-Marie Simonet / infograf768
        Joomla co-fondateur. Joomla Production Working Group.
        Sauf demande explicite de ma part, merci de ne pas utiliser de Message Privé pour poser des questions. Le forum est là pour ça.

        Commentaire


        • #5
          Envoyé par infograf768 Voir le message
          dans la 1.5.3 c'est:
          <hr id="system-readmore" />
          et cela marche OK avec la version de TinyMCE par défaut (ainsi que JCE et FCK)
          lorsque je ferme la balise /> dans le code source cela ne marche pas. il ne prends pas en compte la fermeture de balise "/" J'ai du oublier un paramètre ?

          Paramètre du plugin TinyMCE 2.0
          Nettoyage du code lors de la sauvegarde : jamais
          Ne pas nettoyer le code HTML : oui

          Commentaire


          • #6
            Le code source est dans
            plugins/editors-xtd/readmore.php

            i.e.
            Code:
            function onDisplay($name)
            	{
            		global $mainframe;
            
            		$doc 		=& JFactory::getDocument();
            		$template 	= $mainframe->getTemplate();
            
            		// button is not active in specific content components
            
            		$getContent = $this->_subject->getContent($name);
            		$present = JText::_('ALREADY EXISTS', true) ;
            		$js = "
            			function insertReadmore(editor) {
            				var content = $getContent
            				if (content.match(/<hr id=\"system-readmore\" \/>/)) {
            					alert('$present');
            					return false;
            				} else {
            					jInsertEditorText('<hr id=\"system-readmore\" />', editor);
            				}
            			}
            			";
            
            		$doc->addScriptDeclaration($js);
            
            		$button = new JObject();
            		$button->set('modal', false);
            		$button->set('onclick', 'insertReadmore(\''.$name.'\');return false;');
            		$button->set('text', JText::_('Readmore'));
            		$button->set('name', 'readmore');
            		// TODO: The button writer needs to take into account the javascript directive
            		//$button->set('link', 'javascript:void(0)');
            		$button->set('link', '#');
            
            		return $button;
            	}
            }
            Jean-Marie Simonet / infograf768
            Joomla co-fondateur. Joomla Production Working Group.
            Sauf demande explicite de ma part, merci de ne pas utiliser de Message Privé pour poser des questions. Le forum est là pour ça.

            Commentaire


            • #7
              J'ai le même code source dans plugins/editors-xtd/readmore.php pas de problème à ce niveau là par contre le souci viens du code source de l'éditeur lorsque je fais "afficher le code source" la balise n'ait pas fermé <hr id="system-readmore"> donc je ferme <hr id="system-readmore"/> je fais appliquer et voilà il ne prend pas en compte ma demande, le bouton "lire la suite" ne s'affiche pas !! je retourne dans le code source et j'ai ça <hr id="system-readmore"> une balise non fermé. Pourquoi la fermeture de la balise n'ait pas sauvegardé ?

              Commentaire


              • #8
                j'ai fais la mise à jour de l'éditeur TinyMCE
                explique sans doute cela
                Jean-Marie Simonet / infograf768
                Joomla co-fondateur. Joomla Production Working Group.
                Sauf demande explicite de ma part, merci de ne pas utiliser de Message Privé pour poser des questions. Le forum est là pour ça.

                Commentaire


                • #9
                  Envoyé par infograf768 Voir le message
                  explique sans doute cela
                  Le problème existant avant mise à jour C'est pour cela que j'ai fais une mise à jour en espérant corriger le problème sans aucun effet

                  Commentaire


                  • #10
                    Dans ce cas, si vous n'avez pas d'override du template, il doit y avoir un fichier corrompu.

                    je vous suggère d'écraser les fichiers core existants par un paquet propre. FTP mais mieux par CPanel ou File Manager en décompressant le paquet dans l'hôte
                    Jean-Marie Simonet / infograf768
                    Joomla co-fondateur. Joomla Production Working Group.
                    Sauf demande explicite de ma part, merci de ne pas utiliser de Message Privé pour poser des questions. Le forum est là pour ça.

                    Commentaire


                    • #11
                      Après installation du Pack JCE FR/EN : Composant 1.5RC4 - Plugin 1.5RC1 le lien "lire la suite" fonctionne.

                      Commentaire


                      • #12
                        Salut,
                        il y a eu un bug tracker à ce sujet :
                        http://joomlacode.org/gf/project/joo..._item_id=11892
                        et un sujet dans le forum dev :
                        http://forum.joomla.org/viewtopic.php?f=199&p=1361623

                        Quoiqu'il en soit, le pb provient la plupart du temps de TinyMCE, qui bouffe le " / "de la fin à l'enregistrement (NB :en 1.5.6, Tiny Mce foire sur la plupart de mes serveurs).

                        Procédure :
                        - se paramétrer en NoEditor
                        - tester ces differentes possibilités jusqu'a ce que ca marche:
                        Code:
                        <hr id="system-readmore" /> (l'officiel)
                        
                        <hr id='system-readmore'> 
                        <HR id="system-readmore"> 
                        <hr id='system-readmore"> (bullet-proof/ béton :p)"
                        la derniere soluce fonctionne tres bien sur un serveur strict.

                        Puis, un plugin, "Alternative Readmore link" :
                        http://extensions.joomla.org/compone...279/Itemid,35/

                        Je ne suis pas fan, mais ca peut rendre service.

                        Enfin, un "trick" pour ajouter le titre de l'article au readmore,
                        en utilisant "template override":
                        http://docs.joomla.org/Add_article_t...read_more_link

                        pour résumer, dans les fichiers :
                        * (votretemplate)/html/com_content/category/blog_item.php
                        * (votretemplate)/html/com_content/frontpage/default_item.php
                        * (votretemplate)/html/com_content/section/blog_item.php
                        chercher vers la ligne 131
                        Code:
                        echo JText::sprintf('Read more...');
                        remplacer par :
                        Code:
                        echo JText::sprintf('Read more', $this->item->title);
                        Voila
                        a+
                        Dernière édition par ghazal à 22/08/2008, 19h32
                        “Un message d’erreur sur votre site Joomla ... ayez le reflexe de consulter le nouveau service (en Beta) de la base de connaissance https://kb.joomla.fr

                        Commentaire

                        Annonce

                        Réduire
                        1 sur 2 < >

                        C'est [Réglé] et on n'en parle plus ?

                        A quoi ça sert ?
                        La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                        Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                        Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                        Comment ajouter la mention [Réglé] à votre discussion ?
                        1 - Aller sur votre discussion et éditer votre premier message :


                        2 - Cliquer sur la liste déroulante Préfixe.

                        3 - Choisir le préfixe [Réglé].


                        4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                        2 sur 2 < >

                        Assistance au forum - Outil de publication d'infos de votre site

                        Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                        Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                        Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                        UTILISER À VOS PROPRES RISQUES :
                        L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                        Problèmes connus :
                        FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                        Installation :

                        1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                        Archive zip : https://github.com/AFUJ/FPA/zipball/master

                        2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                        3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                        4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                        5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                        6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                        et remplacer www. votresite .com par votre nom de domaine


                        Exemples:
                        Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                        Télécharger le script fpa-fr.php dans: /public_html/
                        Pour executer le script: http://www..com/fpa-fr.php

                        Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                        Télécharger le script fpa-fr.php dans: /public_html/cms/
                        Pour executer le script: http://www..com/cms/fpa-fr.php

                        En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                        Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                        Voir plus
                        Voir moins
                        Travaille ...
                        X