des lignes de code dans mes articles

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • des lignes de code dans mes articles

    Bonjour,

    J'ai un problème: au début de chaque article les lignes suivantes s'affichent :

    e = "content"' . ' LEFT JOIN #__users AS u ON u.id = a.created_by' . ' LEFT JOIN #__groups AS g ON a.access = g.id'. $voting['join']. $where; $this->_db->setQuery($query); $this->_article = $this->_db->loadObject(); if ( ! $this->_article ) { return false; } if($this->_article->publish_down == $this->_db->getNullDate()) { $this->_article->publish_down = JText::_('Never'); } // These attributes need to be defined in order for the voting plugin to work if ( count($voting) && ! isset($this->_article->rating_count) ) { $this->_article->rating_count = 0; $this->_article->rating = 0; } return true; } return true; } /** * Method to load content article parameters * * @access private * @return void * @since 1.5 */ function _loadArticleParams() { global $mainframe; // Get the page/component configuration $params = clone($mainframe->getParams('com_content')); // Merge article parameters into the page configuration $aparams = new JParameter($this->_article->attribs); $params->merge($aparams); // Set the popup configuration option based on the request $pop = JRequest::getVar('pop', 0, '', 'int'); $params->set('popup', $pop); // Are we showing introtext with the article if (!$params->get('show_intro') && !empty($this->_article->fulltext)) { $this->_article->text = $this->_article->fulltext; } else { $this->_article->text = $this->_article->introtext . chr(13).chr(13) . $this->_article->fulltext; } // Set the article object's parameters $this->_article->parameters = & $params; } /** * Method to build the WHERE clause of the query to select a content article * * @access private * @return string WHERE clause * @since 1.5 */ function _buildContentWhere() { global $mainframe; $user =& JFactory::getUser(); $aid = (int) $user->get('aid', 0); $jnow =& JFactory::getDate(); $now = $jnow->toMySQL(); $nullDate = $this->_db->getNullDate(); /* * First thing we need to do is assert that the content article is the one * we are looking for and we have access to it. */ $where = ' WHERE a.id = '. (int) $this->_id; // $where .= ' AND a.access <= '. (int) $aid; if (!$user->authorize('com_content', 'edit', 'content', 'all')) { $where .= ' AND ( '; $where .= ' ( a.created_by = ' . (int) $user->id . ' ) '; $where .= ' OR '; $where .= ' ( a.state = 1' . ' AND ( a.publish_up = '.$this->_db->Quote($nullDate).' OR a.publish_up <= '.$this->_db->Quote($now).' )' . ' AND ( a.publish_down = '.$this->_db->Quote($nullDate).' OR a.publish_down >= '.$this->_db->Quote($now).' )'; $where .= ' ) '; $where .= ' OR '; $where .= ' ( a.state = -1 ) '; $where .= ' ) '; } return $where; } }

    J'ai trouvé que ce code provenait de plusieurs fichiers dans com_content/views/category . Mais pas moyen de trouver pourquoi ça s'affiche.
    Quelqu'un a t'il une idée?

    Pour ce qui est de la vertion php sur mon serveur il me semble que c'est php5, je suis chez ovh avec une offre start1g.

    J'ai aussi dans Information/fichier de configuration (dans l'admin jommla) la fameuse erreur qui proviendrait d'ovh :
    Warning: eregi() [function.eregi]: Unmatched \{ in ..../administrator/components/com_admin/tmpl/sysinfo_config.php on line 57
    J'ai essayé la solus de ce post http://forum.joomla.fr/showthread.ph...ighlight=eregi mais dans tous les cas le premier problème ne disparait pas!
    __________________________________________________ __________
    correction: ma Version PHP est la 4.4.9
    Dernière édition par suidacra à 26/01/2009, 20h32

  • #2
    J'ai passé mon serveur en PHP Version 5.2.6, mais le problème persiste, et rien n'a changé.

    Commentaire


    • #3
      Hello,

      J'ai jamais entendu parlé de ce probleme dans les articles, mais je l'ai deja eut sur des composants dont la balise "<?php" du début du code était mal écrite !

      Dans tous les cas, c'est une bonne chose d'etre passé en php 5.2.6 !

      As-tu tenter de backuper ta base MySQL et ton arboresence Joomla et de faire une reinstall ?
      (on dirait que des fichiers ont été mal installé ?)

      Ca te le fait sur tous les articles ou seulement sur certains ?
      Garstud Workshop - Concepteur, Développeur et Formateur Joomla - http://www.garstud.com
      « Ce n’est pas parce que les choses sont difficiles que nous n’osons pas,
      c’est parce que nous n’osons pas qu’elles sont difficiles. »
      - Sénèque

      Commentaire


      • #4
        Merci pour ta réponse!
        Disons que mon installation joomla est plutôt jeune et j'ai ce problème depuis le début... enfin il me semble.
        Le code s'affiche que sur les articles créés par joomla, c'est à dire que les articles créés par les composant (artforms, galerie etc) ne génèrent pas le problème.

        Sinon je vais tenter le backup, il me semble qu'il y a des composants pour le faire, non?

        Commentaire


        • #5
          Attention, je ne parles pas d'un backup a restaurer, mais bien d'une reinstallation d'un joomla "propre" !

          C'est a dire de bien re-télécharger un joomla 1.5.8 (ne pas reutiliser le tien qui est peut-etre vérolé !?!)

          Du coup :
          - si le probleme n'apparait plus, alors tu pourras tenter de restaurer UNIQUEMENT ta base de données (tu peux la sauvegarder avec LazyBackup par exemple)
          - si le probleme est toujours la, c'est qu'il y a un probleme du coté de ton hébergement

          Dans les 2 cas on avancera sur ton probleme
          Garstud Workshop - Concepteur, Développeur et Formateur Joomla - http://www.garstud.com
          « Ce n’est pas parce que les choses sont difficiles que nous n’osons pas,
          c’est parce que nous n’osons pas qu’elles sont difficiles. »
          - Sénèque

          Commentaire


          • #6
            réinstallation

            Merci pour ta réponse,
            une dernière précision, pour faire la réinstallation je n'ai besoin de sauvegarder que ma base de donnée? les articles et la structure du site seront conservés?
            bon je me doute bien qu'il faille sauvegarder les medias (photo et autre) et mon template. Mais n'y a t'il pas d'autres fichiers à récupérer avant?

            Commentaire


            • #7
              résolue

              Merci pour l'aide, j'ai réussi à résoudre le problème en mettant à jour mon joomla!
              j'avais la 1.5.7 et avec la 1.5.9 il n'y a plus de problème!
              Merci

              Commentaire

              Annonce

              Réduire
              1 sur 2 < >

              C'est [Réglé] et on n'en parle plus ?

              A quoi ça sert ?
              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
              Comment ajouter la mention [Réglé] à votre discussion ?
              1 - Aller sur votre discussion et éditer votre premier message :


              2 - Cliquer sur la liste déroulante Préfixe.

              3 - Choisir le préfixe [Réglé].


              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

              2 sur 2 < >

              Assistance au forum - Outil de publication d'infos de votre site

              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

              UTILISER À VOS PROPRES RISQUES :
              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

              Problèmes connus :
              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

              Installation :

              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

              Archive zip : https://github.com/AFUJ/FPA/zipball/master

              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
              et remplacer www. votresite .com par votre nom de domaine


              Exemples:
              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
              Télécharger le script fpa-fr.php dans: /public_html/
              Pour executer le script: http://www..com/fpa-fr.php

              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
              Télécharger le script fpa-fr.php dans: /public_html/cms/
              Pour executer le script: http://www..com/cms/fpa-fr.php

              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
              Voir plus
              Voir moins
              Travaille ...
              X