Joomladay francophone 2018 à Paris 18 et 19 mai

Les slides sous IE ne se déplient pas complètement

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] Les slides sous IE ne se déplient pas complètement

    Bonsoir,

    J'utilise le plugin "tabs and slides in content items" dans mes articles.
    Sous FireFox, il n'y a aucun problème.
    Sous IE (7, je n'ai pas le 6 pour tester), le slide ne se déploie pas complètement : l'animation semble s'arrêter quand la taille de l'article atteint la taille laissée disponible par l'alignement avec les modules placés en position "right".

    Quand l'article dépasse cette longueur, il s'affiche complètement.

    Est-ce que quelqu'un a une idée sur comment permettre l'affichage correct lorsqu'on déploie le slide ?

    (je soupçonne un problème javascipt ou CSS...)

    Merci.
    Administrateur de sites Web sous Joomla et depuis peu développeur de plugins
    Sites sous Joomla 3.4.8 (à la date d'écriture de la signature). Maintien permanent à la dernière version

  • #2
    J'ai trouvé un début de réponse dans le forum joomlaworks.

    Il faut "encadrer" les inserts {slide} et {/slide} par des balises <p></p> ; ainsi que le contenu.

    Ce qui donnerait :
    Code:
    <p>{slide=premier}</p>
    <p>
    contenu
    </p>
    <p>{/slide}</p>
    <p>{slide=deuxième}</p>
    <p>
    contenu
    </p>
    <p>{/slide}</p>
    Mais le contenu ne doit pas contenir de balise <p> !!! Utiliser des balises <br /> à la place.

    Ceci ne règle pas mon problème car mon contenu est un ensemble de tableaux...

    Avec cette méthode, on dirait qu'il ne déplie que pour 1 tableau. Pour le contourner, pour le moment, j'ai uniquement trouvé le moyen de mettre un slide par tableau...

    J'ai peut-être une idée (mettre une balise <p> suivi d'une 50aine de lignes vides suivies d'une balise </p> suivie de mes tableaux) car on dirait que le code javascript pose quelques problèmes à IE7 de calcul de la hauteur à déplier...
    Administrateur de sites Web sous Joomla et depuis peu développeur de plugins
    Sites sous Joomla 3.4.8 (à la date d'écriture de la signature). Maintien permanent à la dernière version

    Commentaire


    • #3
      Bonjour à toi,

      j'avais le même problème que toi depuis que j'ai installé ce plugin (que je trouve bien sympathique).
      Sur IE7 en effet il ne s'ouvre pas complètement. J'ai testé sous internet explorer 6 et cela s'ouvre bien ! (si tu veux tester tes pages dans plusieurs IE différents tu peux chercher un logiciel qui s'appelle "MultipleIEs" ;-) )
      J'ai pour corriger cela enlevé toutes les balises "<p>" présentent entre {slide=} et {/slide} et remplacé donc par des <br/>.
      L'auteur le dit lui même dans la description du plugin : "Make sure that when you press "enter" in your content, the editor does not output a <p> tag, but a simple, plain, good ol' <br /> (break tag). In the editor's parameters, there is always such an option."

      Maintenant les slides s'ouvrent bien.
      Par contre pour les tableaux je ne vois pas comment faire...

      voilà à bientôt!

      Commentaire


      • #4
        JWTS Tab FIX

        Bonjour tous,

        J'ai penser que tous mondes a les problems avec le Tabs & Slides in content Plugin.

        Il sont cool de mettre ce plugin gratuit mais aussi con du faire es bug dans les css pour que tu leur paie. Alors voici le FIx Gratuit les gars. Mes excuse aussi pour ma francais .. Suis American.

        Ouvrir le CSS file: tabs_slides.css et

        chercher ce ligne:

        .jwts_tabberlive .jwts_tabbertab {margin:0px;padding:6px;border:1px solid #000;border-top:2px solid #000;/*height:300px;overflow:auto;*/}

        et Voila

        maintenant il n'y a plus c'est petite espace a gauche de premier tab.

        Le reste c'est pur CSS aussi et assez facile. Si vous avez les problems n'hesitez pas de me contactez. J'ai meme fais plein template pour set extension.

        A plus

        Commentaire


        • #5
          J'ai le meme problème

          Bonjour,
          J'ai le problème de non deploiement des slides sous IE 7.
          Amerloc, j'ai changé le CSS mais rien y fait le problème persiste.

          Je donne plus de precision. moi j'essaye d'encapsuler le module connexion de joomla dans un slide. Et j'ai le problème de deploiement malgre le changement de CSS.
          Merci d'avance
          Dernière édition par pandagwada à 28/04/2010, 19h11

          Commentaire

          Annonce

          Réduire
          1 sur 2 < >

          C'est [Réglé] et on n'en parle plus ?

          A quoi ça sert ?
          La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

          Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

          Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
          Comment ajouter la mention [Réglé] à votre discussion ?
          1 - Aller sur votre discussion et éditer votre premier message :


          2 - Cliquer sur la liste déroulante Préfixe.

          3 - Choisir le préfixe [Réglé].


          4 - Et voilà… votre discussion est désormais identifiée comme réglée.

          2 sur 2 < >

          Assistance au forum - Outil de publication d'infos de votre site

          Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

          Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

          Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

          UTILISER À VOS PROPRES RISQUES :
          L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

          Problèmes connus :
          FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

          Installation :

          1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

          Archive zip : https://github.com/AFUJ/FPA/zipball/master

          2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

          3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

          4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

          5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

          6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
          et remplacer www. votresite .com par votre nom de domaine


          Exemples:
          Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
          Télécharger le script fpa-fr.php dans: /public_html/
          Pour executer le script: http://www..com/fpa-fr.php

          Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
          Télécharger le script fpa-fr.php dans: /public_html/cms/
          Pour executer le script: http://www..com/cms/fpa-fr.php

          En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

          Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
          Voir plus
          Voir moins
          Travaille ...
          X