Installé un code Iframe dans un article

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] Installé un code Iframe dans un article

    Bonjour, je posséde un forum que j'aimerais importais dans mon site l'on m'a donc donner un code Iframe mais je en sais pas ou l'intégré. Un article ?! Oui mais je vais dans quoi pour mettre ce code ?

  • #2
    Salut,

    On oublie le code Iframe...dans un article... il y a tout ce qu'il faut dans Joomla (c'est possible mais il y a beaucoup mieux sous joomla).
    Il y a la possibilité d'utiliser le "Wrapper" de joomla (système d'Iframe).
    Pour cela dans, il suffit d'ajouter un lien de menu en choisissant : "Encapsuleur"

    Ensuite ne reste plus qu'à donner un titre à ce lien ("forum" dans ton cas par exemple), et de mettre l'url de forum dans le champs "lien".

    Ne pas oublier ensuite de regler les paramètres du wrapper à droite, pour régler et ajuster l'affichage du wrapper dans le contenu du site.
    Comme par exemple, regler la largeur du wrapper à 100% si on souhaite que le forum s'affiche sur toute la largeur de la page (si le template le permet)...

    Commentaire


    • #3
      pas tout compris le coup du Wrapper mais je vais farfouiné dans l'administration de joomla pour savoir ce que c'est exactement. Mercii pour la piste Jreviendrais dire si c'est bon

      Commentaire


      • #4
        Ah ok, oui pardon je n'ai put-être pas été clair.

        En fait, il suffit d'aller dans l'adminstration de Joomla.
        De cliquer sur "menus" et de sélectionner le menu où se trouvera le lien pour aller sur le forum.

        • Une fois arrivé sur ce menu, il suffit de cliquer sur "nouveau".

        • On arrive au panneau "Sélection du type d'élément de menu".
        • Il faut cliquer sur "Encapsuleur (Wrapper)"...Après le premier clic, il apparait encore "encapsuleur (Wrapper)" il faut cliquer dessus aussi.
        • De là, on arrive sur la page permettant de paramétrer le lien.
        • Titre : on met "Forum" (dans ton exemple),
        • Lien : on laisse tel quel (je me suis trompé tout à l'heure),
        • on choisi l'élément parent (s'il doit en avoir un), publié, niveau d'accès, on laisse "fenêtre parente avec navigation".
        • On jette un œil à droite de la page, et c'est là, dans le champs "URL" qu'on met l'adresse ou se situe la page qu'on veut inclure. Dans ton exemple ce sera du style http://www.adresseduforum.com (je ne sais plus s'il faut mettre ou non le "http://" ...de toute façon si ça ne va pas, il est tjs possible de le modifier plus tard),
        • Ensuite on choisi la hauteur et la largeur que doit avoir le wrapper (c'est exactement le même principe que l'iframe). Donc si on veut qu'il soit parfaitement intégré, on laisse généralement 100% à la largeur...Et la hauteur... ben cela dépend de la "hauteur" de la page du forum... tu peux laisser au début, si tu vois une barre de scroll verticale (barre de défilement) lors de tes tests et que tu n'en veux pas, alors il faudra augmenter la hauteur du wrapper.
          Sinon dans les paramètre avancés on peut cliquer sur "Hauteur automatique" mais ça ne fonctionne pas à tous les coups. ...

        Bref, tu valides tout ça, tu test, et si tout est tout es ok... ben alors tant mieux
        Sinon il suffit de retourner sur cet élément de menu et d'ajuster la hauteur, les barre de défilements etc... pour arriver au résultat finale escompté.

        Commentaire


        • #5
          ok mercii mais alors la j'ai une autre question. Comment ca se fait que quand je fait un article j'ai les derniére lettre de la ligne qui se sont coupé/effacé derriére mon image ou mon module ( tout depens de ce qu'il y'a en fin de ligne ) ?!!

          J'vous donne juste un exemple d'article foiré a cause de ca :
          http://www.profil-lesb.com/index.php...=40&Itemid=172

          Commentaire


          • #6
            up svp c'est important :$

            Commentaire


            • #7
              je pensais le problème reglé, car je ne vois rien, pas de lignes coupées ni effacés quand je clique sur le lien.

              La seule chose que je vois, c'est le texte qui colle un peu trop les photos. Mais ce n'est pas très important. Si c'est ça le problème, il suffit de regler la marge entre la photo et le texte directement dans l'éditeur de texte, lorsqu'on va dans les "proprieté" de l'image/photo.

              Commentaire


              • #8
                euh ok je vais voir ce que je peut faire avec ca pck j'etait perdu, je trouve ca moche quand c'est trop collé, ca fait travail baclé Mercii

                Commentaire

                Annonce

                Réduire
                1 sur 2 < >

                C'est [Réglé] et on n'en parle plus ?

                A quoi ça sert ?
                La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                Comment ajouter la mention [Réglé] à votre discussion ?
                1 - Aller sur votre discussion et éditer votre premier message :


                2 - Cliquer sur la liste déroulante Préfixe.

                3 - Choisir le préfixe [Réglé].


                4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                2 sur 2 < >

                Assistance au forum - Outil de publication d'infos de votre site

                Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                UTILISER À VOS PROPRES RISQUES :
                L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                Problèmes connus :
                FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                Installation :

                1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                Archive zip : https://github.com/AFUJ/FPA/zipball/master

                2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                et remplacer www. votresite .com par votre nom de domaine


                Exemples:
                Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                Télécharger le script fpa-fr.php dans: /public_html/
                Pour executer le script: http://www..com/fpa-fr.php

                Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                Télécharger le script fpa-fr.php dans: /public_html/cms/
                Pour executer le script: http://www..com/cms/fpa-fr.php

                En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                Voir plus
                Voir moins
                Travaille ...
                X