Mon menu principal et menu du haut ne s'affichent pas correctement

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] Mon menu principal et menu du haut ne s'affichent pas correctement

    Bonjour

    J'ai créé le module Information et services :
    - type de module : mod_mainmenu
    - nom du menu : mainmenu
    - position : right

    J'ai créé le module Menu du haut:
    - type de module : mod_mainmenu
    - nom du menu : topmenu
    - position : header

    Ça semble correct, n'est-de pas? Pourtant, mon module « Information et services » ne s'affiche pas et les articles qu'il contient s'affichent à la place du menu du haut qui lui ne s'affiche pas!

    J'ai fouillé le forum mais ne trouve pas de solution à ce problème qui me fait tourner en rond depuis plusieurs jours.

    Quelqu'un peut éclairer ma lanterne?

    Merci de vos lumières.

  • #2
    Bonjour,
    tu peux mettre le lien de ton site pour voir ce que ca donne.
    Tu crées ton item de menu et tu y rattaches un article, une catégorie, etc..
    puis tu crées tes 2 modules, le nom du menu étant le menu que tu vas rattacher au module.
    Quel est ton template ?
    Dernière édition par SCARPIA à 04/01/2010, 22h39

    Commentaire


    • #3
      Salut,

      En créant l'ensemble des liens de ton menu, tu as du choisir comme type d'élément du menu :

      un lien interne > article > un article

      Vérifie chaque élément composant tes menus.

      Tu peux nous envoyer l'adresse du site stp!

      Commentaire


      • #4
        Envoyé par SCARPIA Voir le message
        Bonjour,
        tu peux mettre le lien de ton site pour voir ce que ca donne.
        salut Scarpia,

        Je ne peux te fournir le lien parce que le site est privé pour l'instant, son accès étant restreint au client.

        Je joins une capture d'écran des éléments du menu « Information et services » qui devraient pourtant se retrouver à droite.

        À+
        Fichiers joints

        Commentaire


        • #5
          Alors, c'est difficile de répondre dans le noir.
          Tu as crée tes items d emenus puis tu y as rattaché un article..
          ensuite tu crées tes 2 modules, le nom du menu étant le menu que tu vas rattacher au module.
          Quel est ton template ?
          header ne me semble pas une position adéquate pour un menu.

          Commentaire


          • #6
            Tout est correct au niveau des articles et liens aux menus. Voir la capture d'écran envoyée à Scarpia. Les éléments de ce menu devraient s'afficher à droite sous une rubrique « Information et services »...

            Je ne sais si cela peut vous aider à saisir le problème. Je l'espère

            OPCAI

            Envoyé par max_sim11 Voir le message
            Salut,

            En créant l'ensemble des liens de ton menu, tu as du choisir comme type d'élément du menu :

            un lien interne > article > un article

            Vérifie chaque élément composant tes menus.

            Tu peux nous envoyer l'adresse du site stp!

            Commentaire


            • #7
              Scarpia,

              J'utilise le gabarit themza_j15_33
              http://www.freejoomlatemplatez.com/p...emzaj1533.html

              Envoyé par SCARPIA Voir le message
              Alors, c'est difficile de répondre dans le noir.
              Tu as crée tes items d emenus puis tu y as rattaché un article..
              ensuite tu crées tes 2 modules, le nom du menu étant le menu que tu vas rattacher au module.
              Quel est ton template ?
              header ne me semble pas une position adéquate pour un menu.

              Commentaire

              Annonce

              Réduire
              1 sur 2 < >

              C'est [Réglé] et on n'en parle plus ?

              A quoi ça sert ?
              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
              Comment ajouter la mention [Réglé] à votre discussion ?
              1 - Aller sur votre discussion et éditer votre premier message :


              2 - Cliquer sur la liste déroulante Préfixe.

              3 - Choisir le préfixe [Réglé].


              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

              2 sur 2 < >

              Assistance au forum - Outil de publication d'infos de votre site

              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

              UTILISER À VOS PROPRES RISQUES :
              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

              Problèmes connus :
              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

              Installation :

              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

              Archive zip : https://github.com/AFUJ/FPA/zipball/master

              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
              et remplacer www. votresite .com par votre nom de domaine


              Exemples:
              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
              Télécharger le script fpa-fr.php dans: /public_html/
              Pour executer le script: http://www..com/fpa-fr.php

              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
              Télécharger le script fpa-fr.php dans: /public_html/cms/
              Pour executer le script: http://www..com/cms/fpa-fr.php

              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
              Voir plus
              Voir moins
              Travaille ...
              X