Un nouveau menu qui n'apparait pas

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Un nouveau menu qui n'apparait pas

    Bonsoir,

    J'ai créé un menu (Le site communautaire). Je lui ai affecté un élément sous la forme d'un lien externe. Ce lien externe a une image de menu. J'ai bien fait attention de suivre les indications des info-bulles. J'ai activé le module du menu et je l'ai positionné juste en dessous du menu principal après lui avoir affecté l'élément de menu créé plus tôt. Le menu et l'élément de menu sont publiés. Rien ne s'affiche sur mon site :

    http://www.savs-epilepsies.fr

    Mon but est d'avoir une image cliquable dans le menu qui mène à un site externe.

    Ma configuration :

    Joomla 1.5.25
    JA_Purity_II

    Merci

  • #2
    Re : Un nouveau menu qui n'apparait pas

    Bonjour,
    quand je regarde le code de ta page avec Firebug, il me semble bien qu'il y a un module vide sous l'abonnement newsletter. Si c'est bien ton menu, ça voudrait dire que ton lien de menu n'est pas publié, ou pas public, ou avec des dates de publication qui le bloquent...
    Schtroumpfe toi le Schtroumpf t'aidera.
    Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

    Commentaire


    • #3
      Re : Un nouveau menu qui n'apparait pas

      Envoyé par Grand Schtroumpf Voir le message
      Bonjour,
      quand je regarde le code de ta page avec Firebug, il me semble bien qu'il y a un module vide sous l'abonnement newsletter. Si c'est bien ton menu, ça voudrait dire que ton lien de menu n'est pas publié, ou pas public, ou avec des dates de publication qui le bloquent...
      Il est publié et public, à ce que je vois. Voici de captures d'écran de ce que j'ai fait :


      http://www.flickr.com/photos/4554415...7628346953927/

      En espérant que les captures soient assez visibles
      Dernière édition par LaurentR à 09/12/2011, 16h55

      Commentaire


      • #4
        Re : Un nouveau menu qui n'apparait pas

        Bonjour,

        En regardant les captures que tu as envoyées, ton menu ne sera affiché que sur la page "accès au site communautaire".
        JoomlaDay FR 2018 - 18/19 Mai 2018 ! J'y serai ... et vous ?

        Envie de lire sur Joomla!, mais pas que ? Cinnk magazine http://cinnk.com/magazine

        Pour apprendre à construire votre site web avec Joomla 3 : Joomla3! Le Livre Pour Tous : http://cinnk.com/joomla/3/le-livre-pour-tous
        Créez votre boutique en ligne avec Joomla! & HikaShop http://cinnk.com/boutique/livres/cre...la-et-hikashop

        Commentaire


        • #5
          Re : Un nouveau menu qui n'apparait pas

          Envoyé par SimonG Voir le message
          Bonjour,

          En regardant les captures que tu as envoyées, ton menu ne sera affiché que sur la page "accès au site communautaire".
          Quel capture ? Accès au site communautaire" n'est pas une page, mais un élément de menu du menu "Le site communautaire" qui est de type "site-elgg" et qui est affecté au module menu-elgg qui lui même est activé et positionné juste en dessous du menu principal. En fait je veux juste afficher une image cliquable pointant sur un site web externe. C'est pour que j'ai créé un élément de menu de type URL externe et que je lui ai affecté une image.

          Commentaire


          • #6
            Re : Un nouveau menu qui n'apparait pas

            Je sais que "Accès au site communautaire" n'est pas une page, et c'est justement pour cela que ton menu ne s'affiche pas.

            Quel capture ?
            Dans la capture d'écran ou tu montres les réglages de ton module, dans affectation de menu, tu n'as choisis que "Accès au site communautaire" alors que cette page n'existe pas. Il faut que tu choisisses "tous" .
            JoomlaDay FR 2018 - 18/19 Mai 2018 ! J'y serai ... et vous ?

            Envie de lire sur Joomla!, mais pas que ? Cinnk magazine http://cinnk.com/magazine

            Pour apprendre à construire votre site web avec Joomla 3 : Joomla3! Le Livre Pour Tous : http://cinnk.com/joomla/3/le-livre-pour-tous
            Créez votre boutique en ligne avec Joomla! & HikaShop http://cinnk.com/boutique/livres/cre...la-et-hikashop

            Commentaire


            • #7
              Re : Un nouveau menu qui n'apparait pas

              Envoyé par SimonG Voir le message
              Je sais que "Accès au site communautaire" n'est pas une page, et c'est justement pour cela que ton menu ne s'affiche pas.



              Dans la capture d'écran ou tu montres les réglages de ton module, dans affectation de menu, tu n'as choisis que "Accès au site communautaire" alors que cette page n'existe pas. Il faut que tu choisisses "tous" .
              Nickel, merci. Je n'avais pas bien compris ce fonctionnement. En même temps, je ne trouve pas que l'intitulé soit très clair. Quand je lis :

              Affectation de menu

              et en dessous :

              Sélectionner un menu:

              Je comprends qu'il s'agit d'affecter un menu à ce module et non pas une page. Je ne saurai pas dire quelle serait la meilleure tournure, mais je trouve celle-ci difficile à comprendre.

              Commentaire


              • #8
                Re : Un nouveau menu qui n'apparait pas

                Oui c'est vrai que c'est pas toujours évident avec tous ces termes.
                Mais ça vient avec la pratique

                Bonne soirée
                JoomlaDay FR 2018 - 18/19 Mai 2018 ! J'y serai ... et vous ?

                Envie de lire sur Joomla!, mais pas que ? Cinnk magazine http://cinnk.com/magazine

                Pour apprendre à construire votre site web avec Joomla 3 : Joomla3! Le Livre Pour Tous : http://cinnk.com/joomla/3/le-livre-pour-tous
                Créez votre boutique en ligne avec Joomla! & HikaShop http://cinnk.com/boutique/livres/cre...la-et-hikashop

                Commentaire

                Annonce

                Réduire
                1 sur 2 < >

                C'est [Réglé] et on n'en parle plus ?

                A quoi ça sert ?
                La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                Comment ajouter la mention [Réglé] à votre discussion ?
                1 - Aller sur votre discussion et éditer votre premier message :


                2 - Cliquer sur la liste déroulante Préfixe.

                3 - Choisir le préfixe [Réglé].


                4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                2 sur 2 < >

                Assistance au forum - Outil de publication d'infos de votre site

                Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                UTILISER À VOS PROPRES RISQUES :
                L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                Problèmes connus :
                FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                Installation :

                1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                Archive zip : https://github.com/AFUJ/FPA/zipball/master

                2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                et remplacer www. votresite .com par votre nom de domaine


                Exemples:
                Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                Télécharger le script fpa-fr.php dans: /public_html/
                Pour executer le script: http://www..com/fpa-fr.php

                Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                Télécharger le script fpa-fr.php dans: /public_html/cms/
                Pour executer le script: http://www..com/cms/fpa-fr.php

                En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                Voir plus
                Voir moins
                Travaille ...
                X