les éléments du menu dans le main menu ont disparu du back-office!

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] les éléments du menu dans le main menu ont disparu du back-office!

    Cliquez sur l'image pour l'afficher en taille normale

Nom : problème joomla.jpg 
Affichages : 1 
Taille : 62,2 Ko 
ID : 1815489Bonjour,

    J'ai besoin d'une solution urgente à un problème très étrange! Depuis quelques temps, quand on va dans le main menu, aucun élément n'apparait alors qu'ils n'ont pas disparu du site! Du coup, je ne peux ni modifier, ni supprimer aucun élément puisque je ne peux pas les sélectionner. Je peux par contre en créer de nouveaux puisque j'ai toujours accès au bouton "nouveau".
    Je tiens à préciser qu'aucune mise à jour n'a été faite ces derniers temps. Nous avons la version joomla 1.5.10 depuis la création du site et il n'y avait jamais eu ce genre de problème avant.
    Merci d'avance à ceux qui s'intéresseront à mon problème!!

  • #2
    Re : les éléments du menu dans le main menu ont disparu du back-office!

    Bonsoir,

    Quelle idée de supprimer tous ses liens dans le mainmenu ? ;-)

    As-tu un cache d'activé?

    Commentaire


    • #3
      Re : les éléments du menu dans le main menu ont disparu du back-office!

      Envoyé par georgios Voir le message
      Bonsoir,

      Quelle idée de supprimer tous ses liens dans le mainmenu ? ;-)

      As-tu un cache d'activé?
      Bonjour,

      Merci de ta réponse, j'aimerais que ce soit si simple! Où est-ce que j'aurai supprimé ses liens ces liens selon toi? Je précise que je ne suis pas une grande spécialiste de site Internet donc il se peut que la solution soit plus évidente que je ne le pense!
      A priori je n'ai pas de cache d'activé (j'ai joint l'imprim écran de la page de config). Cliquez sur l'image pour l'afficher en taille normale

Nom : pb joomla.jpg 
Affichages : 1 
Taille : 78,5 Ko 
ID : 1801164

      Merci de ton aide!

      Commentaire


      • #4
        Re : les éléments du menu dans le main menu ont disparu du back-office!

        Bonjour,

        Et bienvenue sur le forum.
        Envoyé par francecomplet Voir le message
        Je tiens à préciser qu'aucune mise à jour n'a été faite ces derniers temps. Nous avons la version joomla 1.5.10 depuis la création du site et il n'y avait jamais eu ce genre de problème avant.
        La mise à jour de Joomla! 1.5.10 vers 1.5.26 s'impose d'urgence: http://aide.joomla.fr/telechargement...r-joomla-1-5-x.
        Il est fort probable que l'hébergeur ait mis à jour sa version de PHP et que donc cette vénérable version de Joomla! datant du crétacé ait quelques problèmes. La mise à jour aurait 99% de chances de régler le problème.
        Pas de demande de support par MP.
        S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

        Commentaire


        • #5
          Re : les éléments du menu dans le main menu ont disparu du back-office!

          Envoyé par jisse03 Voir le message
          Bonjour,

          Et bienvenue sur le forum.

          La mise à jour de Joomla! 1.5.10 vers 1.5.26 s'impose d'urgence: http://aide.joomla.fr/telechargement...r-joomla-1-5-x.
          Il est fort probable que l'hébergeur ait mis à jour sa version de PHP et que donc cette vénérable version de Joomla! datant du crétacé ait quelques problèmes. La mise à jour aurait 99% de chances de régler le problème.
          Bonjour, j'ai exactement le même problème sauf que je suis en 1.5.7 avec php 5.3 j'imagine que le problème viens de la, j'ai donc télécharger le patch de mise à jour Patch de mise à jour de Joomla 1.5.x vers 1.5.26 et extrait le contenu dans mon serveur en remplacant bien tout mais dans l'admin il m'indique toujours que je suis en 1.5.7, y a t-il une procédure a suivre afin de faire la mise à jour ?

          Cordialement.

          Commentaire


          • #6
            Re : les éléments du menu dans le main menu ont disparu du back-office!

            Bonjour,
            Envoyé par Musyanon Voir le message
            je suis en 1.5.7 avec php 5.3 j'imagine que le problème viens de la, j'ai donc télécharger le patch de mise à jour Patch de mise à jour de Joomla 1.5.x vers 1.5.26 et extrait le contenu dans mon serveur en remplacant bien tout mais dans l'admin il m'indique toujours que je suis en 1.5.7, y a t-il une procédure a suivre afin de faire la mise à jour ?.
            Soit déconnexion/reconnexion au serveur indiquera la bonne version, soit des erreurs de transfert ont eu lieu, et dans ce cas refaire le transfert, en surveillant bien les éventuelles erreurs.
            Pas de demande de support par MP.
            S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

            Commentaire


            • #7
              Re : les éléments du menu dans le main menu ont disparu du back-office!

              Je viens de récupérer un site en 1.5.14 et le temps de faire quelques manip, j'ai eu exactement le même problème

              C'est stressant.

              Musyanon et francecomplet, est-ce que la mise à jour à résolu votre problème ?

              Merci d'avance !

              EDIT: un passage en 1.5.26 a effectivement résolu le problème. Merci pour l'info
              Dernière édition par LoneCat à 09/06/2012, 11h41

              Commentaire


              • #8
                Re : les éléments du menu dans le main menu ont disparu du back-office!

                bonjour,
                cela fait un bout de temps que je ne suis plus passé par ici et tout tournait vraiment super bien jusque la semaine passée,
                le site du club tourne en version 1.5.8 et j'en suis super content mais depuis une semaine je n'ai plus de menus également sous cette version et un message d'erreur est apparu deux jours avant de laisser place au vide
                voila le message :warning: parameter 1 to modMainMenuHelper::buildXML()expected to be a reference value given (acces au directory de l'hébergeur)....on line 99
                depuis ce jours ils sont disparu du front-end , je les vois en back end mais je n'ai plus la possibilité de les éditer ou d'en créer de nouveaux....
                et toutes les bases de données sont accessibles et complètes.

                pensez vous que je vais également devoir faire une mise à jour?
                c'ets vraiment pas le moment
                merci de votre savoir....
                Kab
                Dernière édition par kabongo à 02/08/2012, 20h47

                Commentaire


                • #9
                  Re : les éléments du menu dans le main menu ont disparu du back-office!

                  Bonjour,

                  je ne suis pas du tout un "pro" de Joomla mais compte tenu du fait que la migration vers 1.5.26 est ultra facile à faire, je ne vois pas pourquoi tu n'essaierais pas. De plus, il va prochainement falloir passer à la version suivante, puisque la version 1.5 ne sera plus supportée prochainement et si je me souviens bien il faut passer par la 1.5.26 avant de passer en 2.5 ...

                  PS: si la mise à jour a corrigé le problème, ce serait sympa de l'indiquer.

                  Commentaire


                  • #10
                    Re : les éléments du menu dans le main menu ont disparu du back-office!

                    Bonjour,
                    Envoyé par kabongo Voir le message
                    le site du club tourne en version 1.5.8 et j'en suis super content mais depuis une semaine je n'ai plus de menus également sous cette version et un message d'erreur est apparu deux jours avant de laisser place au vide
                    L'hébergeur a probablement réalisé une mise à jour de PHP, vers une version qu ela vénérable relique 1.5.8 ne supporte pas.
                    La mise à jour vers 1.5.26 s'impose, et de plus très simple à réaliser. http://aide.joomla.fr/telechargement...r-joomla-1-5-x
                    Pas de demande de support par MP.
                    S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

                    Commentaire


                    • #11
                      Re : les éléments du menu dans le main menu ont disparu du back-office!

                      Envoyé par jisse03 Voir le message
                      Bonjour,

                      L'hébergeur a probablement réalisé une mise à jour de PHP, vers une version qu ela vénérable relique 1.5.8 ne supporte pas.
                      La mise à jour vers 1.5.26 s'impose, et de plus très simple à réaliser. http://aide.joomla.fr/telechargement...r-joomla-1-5-x
                      Bonjour à tous, je reviens sur ce très vieux topic car je viens de rencontrer le même problème!
                      J'ai fait une mise à jour de mon joomla 1.5.17 en 1.5.26 ce midi. Tout avait l'air ok, j'ai seulement eu des problèmes avec mon .htaccess !!! bref, ceci est résolu. Par contre, je viens de voir que certains liens de modules ont totalement disparu du backend mais les entrées sont toujours dans la bdd donc existantes. Du coup en frontend on ne voit pas le problème (c'est déjà ça....) Mais voilà, j'ai besoin de voir mes menu pour les modifier et quand bien même, ce n'est pas du tout normal.
                      J'ai un menu ou 2 qui ont leurs liens, mais pas les autres. Sur la page de gestion des menus, ils indiquent pourtant chacun le nombre de liens existants mais quand je veux aller voir ces liens, il n'y sont pas...
                      Que dois-je faire ? restaurer ma sauvegarde d'avant la maj, et rester en 1.5.17 ? J'ai peur que ce ne soit pas lié à la version vu que d'autres ont eu le problème avec de plus anciennes versions.... Vous savez d'où ça peut venir ?

                      Je précise que j'ai récupéré ma sauvegarde d'avant la maj, je l'ai mise en local sans mettre à jour joomla, les menus sont tous ok. Je fais la maj vers la v1.5.26 et là même problème que sur le site en ligne !
                      Je n'ai pas pris le bon patch de maj ? j'ai téléchargé le patch de maj joomla 1.5.x vers 1.5.26 pourtant...

                      Merci à tous pour votre aide
                      Dernière édition par linceb à 30/11/2012, 16h30

                      Commentaire


                      • #12
                        Re : les éléments du menu dans le main menu ont disparu du back-office!

                        Bon finalement à force de chercher, je viens de trouver ce qui n'allait pas !
                        Dans la base de données je me suis aperçue que seuls les menus n'ayant pas d'espace dans leur appellation "menutype" affichait leurs items sur le backend. En revanche ceux avec un espaces dans le nom du menutype apparaissaient vides de tout lien.
                        J'ai donc modifié leur nom de menutype et l'ai également modifié dans les liens de menu pour les affecter correctement.
                        Maintenant tout est là ! bizarre que ce problème ne soit pas apparu plus tôt ....
                        Désolée pour le dérangement, je laisse la réponse ici au cas où quelqu'un d'autre rencontrerai ce problème...
                        Bon weekend à tous !

                        Commentaire

                        Annonce

                        Réduire
                        1 sur 2 < >

                        C'est [Réglé] et on n'en parle plus ?

                        A quoi ça sert ?
                        La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                        Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                        Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                        Comment ajouter la mention [Réglé] à votre discussion ?
                        1 - Aller sur votre discussion et éditer votre premier message :


                        2 - Cliquer sur la liste déroulante Préfixe.

                        3 - Choisir le préfixe [Réglé].


                        4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                        2 sur 2 < >

                        Assistance au forum - Outil de publication d'infos de votre site

                        Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                        Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                        Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                        UTILISER À VOS PROPRES RISQUES :
                        L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                        Problèmes connus :
                        FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                        Installation :

                        1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                        Archive zip : https://github.com/AFUJ/FPA/zipball/master

                        2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                        3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                        4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                        5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                        6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                        et remplacer www. votresite .com par votre nom de domaine


                        Exemples:
                        Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                        Télécharger le script fpa-fr.php dans: /public_html/
                        Pour executer le script: http://www..com/fpa-fr.php

                        Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                        Télécharger le script fpa-fr.php dans: /public_html/cms/
                        Pour executer le script: http://www..com/cms/fpa-fr.php

                        En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                        Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                        Voir plus
                        Voir moins
                        Travaille ...
                        X