Joomladay francophone 2018 à Paris 18 et 19 mai

Module de recherche fait disparaitre menu

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] Module de recherche fait disparaitre menu

    Bonjour

    J'ai un soucis avec le composant Com_search. J'utilise la fonction de base avec Joomla 1.5 et le template Purity. Quand on effectue une recherche avec le composant du template le menu de gauche reste affiché. Par contre si on utilise à nouveau le formulaire de recherche qui vient d'apparaitre avec les résultats, alors la avec le résultat le menu de gauche disparait...
    J'ai vu que dans components\com_search\controller.php il faisait une recherche de ItemId pour laisser un menu apparent. Dans mon cas je suppose qu'il laisse apparent mon menu horizontal, mais pas le menu de gauche. J'ai essayé de lui indiquer un Itemid=75 par défaut, mais ca ne marche pas.
    Quelqu'un a une idée ?
    PJ : photo explicative
    PS : le site est visible sur http://romduf.byethost8.com/
    Fichiers joints

  • #2
    Va jeter un coup d'oeil dans ton mod_mainmenu où tu as programmé ton menu (administrator -> gestion des modules).

    L'affichage du menu est sûrement de type variable càd que tu as demandé à ce qu'il soit affiché seulement sur certaines pages. Vérifie si tu ne dois pas en ajouter l'une ou l'autre.
    Christophe (cavo789)
    Développeur d'aeSecure; protection, optimisation et nettoyage (après hack) de sites web Apache https://www.aesecure.com/fr
    Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes

    Venez rencontrer la communauté francophone à l'occasion du JoomlaDay 2018 qui se tiendra les 18 et 19 mai 2018. Plus d'infos sur https://www.joomladay.fr

    Commentaire


    • #3
      Merci de ta réponse, mais non, mon menu est programmé pour apparaitre TOUJOURS... Mais il ne peut pas prendre en compte le cas du module de recherche seul... Autre idée ?

      Commentaire


      • #4
        Ben non et voilà que je constate le même comportement sur mon site . Si quelqu'un te répond; je profiterai de la réponse
        Christophe (cavo789)
        Développeur d'aeSecure; protection, optimisation et nettoyage (après hack) de sites web Apache https://www.aesecure.com/fr
        Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes

        Venez rencontrer la communauté francophone à l'occasion du JoomlaDay 2018 qui se tiendra les 18 et 19 mai 2018. Plus d'infos sur https://www.joomladay.fr

        Commentaire


        • #5
          Je viens de jeter un coup d'oeil sur les paramètres de mod_search.

          A droite, tu as un champs nommé Itemid.

          Prends connaissance du tooltip qui y est associé et fais comme indiqué.

          Chez moi, je n'ai pas vu de différence et chez toi ?
          Christophe (cavo789)
          Développeur d'aeSecure; protection, optimisation et nettoyage (après hack) de sites web Apache https://www.aesecure.com/fr
          Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes

          Venez rencontrer la communauté francophone à l'occasion du JoomlaDay 2018 qui se tiendra les 18 et 19 mai 2018. Plus d'infos sur https://www.joomladay.fr

          Commentaire


          • #6
            Merci de ta remarque, j'ai déja essayé, rien à faire...
            Au secours

            Commentaire


            • #7
              Bonjour,
              tout est là : http://forum.joomla.fr/showthread.php?t=101093
              Schtroumpfe toi le Schtroumpf t'aidera.
              Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

              Commentaire


              • #8
                Merci. Comme tu le mentionnes dans ce post-là, "mod_search" est mal ficelé. Il y a peu, j'ai demandé via un post si quelqu'un utilisait un autre module de recherche que mod_search. Je n'ai pas eu de réponse.

                J'eusse aimé en trouver un qui prenne en charge les plugins search additionnels; je n'en ai pas trouvé.
                Christophe (cavo789)
                Développeur d'aeSecure; protection, optimisation et nettoyage (après hack) de sites web Apache https://www.aesecure.com/fr
                Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes

                Venez rencontrer la communauté francophone à l'occasion du JoomlaDay 2018 qui se tiendra les 18 et 19 mai 2018. Plus d'infos sur https://www.joomladay.fr

                Commentaire


                • #9
                  Je vais essayer grand schtroumf !
                  Merci

                  Commentaire


                  • #10
                    Marche toujours pas

                    Grand schtroumf

                    Ca ne marche pas ! Regarde sur www.terredegraines.fr tu verras si tu fais une recherche avec le module en haut a droit(blé par exemple), il trouve les articles correspondant et laisse mon menu car il garde le &Itemid=56
                    Par contre des que l'on utilise le module de recherche qui apparait AVEC les résultats de la recherche, alors la plus de &Itemid=56 dans le résultat donc disparition du menu de gauche...
                    J'ai d'ailleurs le meme probleme avec le "plan du site" (tout en bas a gauche): j'ai fais un "menu bas" contenant le plan du site généré par Xmap, mais la encore impossible de lui dire de mettre le &Itemid=56 dans le résultat, il efface systématiquement le menu gauche...

                    Une solution ?
                    Merci Romain

                    Commentaire


                    • #11
                      Bonjour,
                      Ca ne marche pas !
                      un truc que moi j'ai écrit et qui ne marche pas ? !

                      Une solution ?
                      Faire tout ce qui est écrit là http://forum.joomla.fr/showthread.php?t=101093

                      1. création d'un élément de menu sur le com_search http://forum.joomla.fr/showpost.php?...13&postcount=3
                      2. modifier le mod_search http://forum.joomla.fr/showpost.php?...41&postcount=8
                      Schtroumpfe toi le Schtroumpf t'aidera.
                      Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

                      Commentaire


                      • #12
                        toujours pas

                        salut Grand schtroumf
                        Eh bien désolé, j'ai fais tout ce que tu dis, mais ca ne marche vraiment pas... Peut être le pb est il légèrement différent. J'ai créé un menu_bas qui contient les éléments dont je ne peux modifier le ItemId. Pour le mod_search, le bon ItemId n'apparait pas. Tu verras j'ai mis le changement sur www.terredegraines.fr rien à faire il prend pas en compte le changement. Je sais vraiment pas quoi faire d'autre ?

                        Commentaire


                        • #13
                          Au secours !

                          Rebonjour a tous. Bon ce message n'a pas l'air d'intéresser les foules. Pourtant c'est un probleme assez basique : quand on clique sur un menu ou le module de recherche standard, un menu qui devrait rester en place disparait... Vous pouvez vérifier sur www.terredegraines.fr
                          Merci de vos suggestions, je viens de passer une semaine a faire des essais en vain...
                          Romain

                          Commentaire


                          • #14
                            Grand schtroumf !! Au secours; j'ai tout essayé :
                            - fait les modif que tu as dites, notamment créé un menu appellé "fictif" avec une entrée de menu "recherche", j'ai pas bien compris a quoi ca sert, mais ce ne donne rien
                            - essayé de mettre un id dans "paramètre ItemId" du module de recherche
                            Quand je rajoute manuellement ItemId=56 au résultat de recherche, mon menu réapparait, mais quand je met son véritable ItemId qui est 1, alors la ca ne marche pas non plus. En fait il s'agit d'un module menu et non d'un véritable menu...
                            Bref, j'espère etre à peu près clair, tu verras sur www.terredegraines.fr pas moyen d'empecher le formulaire de recherche de faire disparaitre le menu...
                            Merci de ton aide !

                            Commentaire


                            • #15
                              Bon, n'ayant pas trouvé de réponse, j'ai décidé de placer une entre pour le module de recherche dans mon menu principal. La évidemment ca marche mais bon ce n'est pas une véritable solution.
                              J'ai eu le meme probleme avec un autre module de menu qui faisait disparaitre un autre module.... Il semble y avoir des problemes avec certains modules sous joomla ou je n'ai encore rien compris.
                              Romain

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X