Mailto

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Mailto

    Bonjour à tous,

    1/ Voila j'ai un petit problème avec le composant mailto, lorsque je clic sur la petite enveloppe pour Envoyer l'adresse url de la page à un ami, la police de la légende du formulaire est en blanc et comme le fond est blanc....

    Une petite idée pour modifier ça serait là bienvenue.

    2/ sinon serait-il possible d'utiliser cet icône (la petite enveloppe) pour faire pointer vers la messagerie de l'utilisateur.

    3/ j'utilise joomfish pour la traduction du site en anglais et il ne me traduit pas les options sur mon sondage quelqu'un connait-il une solution?

    je crois qu'avec ça je vais corriger les quelques bugs qui restent merci pour votre aide.

    version: 1.5.20
    url du site: objectifrock.free.fr
    Les faits sont têtus. Il est plus facile de s'arranger avec les statistiques.

    Mark Twain (1835-1910)

  • #2
    Bonjour,
    1/ Voila j'ai un petit problème avec le composant mailto, lorsque je clic sur la petite enveloppe pour Envoyer l'adresse url de la page à un ami, la police de la légende du formulaire est en blanc et comme le fond est blanc....
    Installe Firebug sous Firefox, fais un clic droit sur le champ et inspecter un élément. Tu verras la structure de la page,e t notamment les styles qui s'appliquent, tu devrais pouvoir en conclure où intervenir sur le CSS

    Une petite idée pour modifier ça serait là bienvenue.

    2/ sinon serait-il possible d'utiliser cet icône (la petite enveloppe) pour faire pointer vers la messagerie de l'utilisateur.
    En théorie oui, avec un plugin, mais il va falloir le développer, et le mailto avec sujet pré rempli c'est très moyen.

    3/ j'utilise joomfish pour la traduction du site en anglais et il ne me traduit pas les options sur mon sondage quelqu'un connait-il une solution?
    Question qui n'a rien à voir = nouveau sujet dans le bon forum !
    Schtroumpfe toi le Schtroumpf t'aidera.
    Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

    Commentaire


    • #3
      J'ai bien installé Firebug, mais lorsque je modifie la couleur de la police correspondante cela me change la couleur de police du site complet et pas que du composant mailto.

      Cela ne résout pas mon problème...
      Les faits sont têtus. Il est plus facile de s'arranger avec les statistiques.

      Mark Twain (1835-1910)

      Commentaire


      • #4
        Re,
        ok donc on va surcharger le composant pour pouvoir l'adresser spécifiquement :

        Copie /components/com_mailto/views/mailto/tmpl/default.php dans templates/tontemplate/html/com_mailto/mailto/ (il faudra sûrement créer les dossiers de la fin du chemin...)

        Et là, modifie la ligne form en

        Code:
        <form action="<?php echo JURI::base() ?>index.php" name="mailtoForm" method="post" id="mailto">
        À partir de là tu peux adresser spécifiquement le contenu du formulaire en css, par exemple :
        Code:
        #mailto .inputbox{
            color: #E00;
        }
        Schtroumpfe toi le Schtroumpf t'aidera.
        Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

        Commentaire


        • #5
          Suite

          Bon alors j'ai bien copier le fichier dans le fichier que tu m'as indiqué la pas de soucis, ensuite j'ai mis le code #mailto .inputbox{.... avec la couleur voulue soit le noir #000 dans le template.css mais là ca ne marche toujours pas.
          Les faits sont têtus. Il est plus facile de s'arranger avec les statistiques.

          Mark Twain (1835-1910)

          Commentaire


          • #6
            Re,
            j'ai bien copié le fichier dans le fichier que tu m'as indiqué la pas de soucis, ensuite j'ai mis le code #mailto
            Et tu as modifié la ligne <form ...> dans le fichier copié ?
            Et tu t'es installé Firebug ? Alors utilise-le pour voir ce qui se passe ...
            > tu vois le id="mailto" daans le code html de la page ? Sinon la surcharge n'a pas marché, tu as fait une erreur de frappe dans le chemin
            > tu vois le style dans les styles qui s'appliquent ? sinon erreur de frappe dans le css ? Oui mais il est supplaté par un style plus prioritaire ? Viens raconter ça qu'on voie comment le modifier...
            Schtroumpfe toi le Schtroumpf t'aidera.
            Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

            Commentaire


            • #7
              Suite

              Je pense qu'il est supplanté par un prioritaire car avec firebug il m'affiche toujours

              Hérité debody.contentpane
              body, td {
              color:#FFFFFF;
              font-family:Helvetica,Arial,sans-serif;
              font-size:12px;
              line-height:1.4em;

              J'ai bien vérifié les chemins ils sont corrects et la ligne est bien modifiée dans le fichier copié
              Les faits sont têtus. Il est plus facile de s'arranger avec les statistiques.

              Mark Twain (1835-1910)

              Commentaire


              • #8
                Re,
                tu n'as pas répondu à :
                > tu vois le id="mailto" dans le code html de la page ?
                > tu vois le style dans les styles qui s'appliquent ?
                Schtroumpfe toi le Schtroumpf t'aidera.
                Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

                Commentaire


                • #9
                  Re

                  oui je vois bien l'id="mailto"
                  et pour le style dans les styles qui s'appliquent ben c'est celui que j'ai indiqué juste avant
                  Les faits sont têtus. Il est plus facile de s'arranger avec les statistiques.

                  Mark Twain (1835-1910)

                  Commentaire


                  • #10
                    Re,
                    tu vois le #mailto .inputbox dans les styles et il est surpassé ou tu n le vois pas ?
                    tu l'as mis dans quel fichier CSS ? Tu peux en faire un copier/coller ici ?
                    Schtroumpfe toi le Schtroumpf t'aidera.
                    Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

                    Commentaire


                    • #11
                      Je ne le vois pas dans les styles et je l'ai mis dans le fichier template.css je te joints une copie iciCopie de template.txt
                      Les faits sont têtus. Il est plus facile de s'arranger avec les statistiques.

                      Mark Twain (1835-1910)

                      Commentaire


                      • #12
                        Re,
                        hum... peut-être un Ctrl F5 ou vidage du cache navigateur pour forcer le rechargement du CSS sur la page ?
                        Schtroumpfe toi le Schtroumpf t'aidera.
                        Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

                        Commentaire


                        • #13
                          Re

                          non car j'essaie sur 2 navigateurs différents que je choisi au hasard opéra,chrome,firefox(celui par defaut) et malheureusement IE 7 et cela ne change rien
                          Les faits sont têtus. Il est plus facile de s'arranger avec les statistiques.

                          Mark Twain (1835-1910)

                          Commentaire


                          • #14
                            Sinon autre idée mettre le fond en noir comme sur le template du site
                            Les faits sont têtus. Il est plus facile de s'arranger avec les statistiques.

                            Mark Twain (1835-1910)

                            Commentaire


                            • #15
                              Re,
                              excuses, j'avais mal lu, j'étais sur les zones de saisie...
                              Pour le titre et les labels, tu as juste besoin d'un
                              Code:
                              #mailto  {
                              color:#000000;
                              }
                              Schtroumpfe toi le Schtroumpf t'aidera.
                              Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X