Pas d'éditeur WYSIWYG dans mod_custom

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] Pas d'éditeur WYSIWYG dans mod_custom

    Bonjour,

    Je suis en Joomla 1.5.21 et le mod-custom ne présente pas d'éditeur WYSIWYG.
    Il présente un éditeur de texte basique, sans possibilité affichage html, et ce quel que soit l'éditeur par défaut du site : tiny mce, jce ou no editor ...

    Je subodore qu'il me manque quelque chose. Quelqu'un aurait-il une idée ?

    Merci d'avance
    Dernière édition par casdyn à 09/11/2010, 17h02

  • #2
    Je viens de faire la mise à jour 1.5.22 : toujours pas d'éditeur WYSIWYG dans le module mod_custom

    Ce problème ne se présente que sur l'un de mes sites : pourrait-il venir du template ?

    Commentaire


    • #3
      Bonjour,
      il n'y a pas un bouton afficher/masquer au dessus de la zone de texte ?
      Schtroumpfe toi le Schtroumpf t'aidera.
      Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

      Commentaire


      • #4
        Envoyé par Grand Schtroumpf Voir le message
        il n'y a pas un bouton afficher/masquer au dessus de la zone de texte ?
        Non, il n'y a pas de bouton afficher/masquer.

        De plus :
        - il n'y a aucune icône de type traitement de texte au dessus de la fenêtre,
        - la fenêtre se comporte comme un éditeur de texte brut,
        - en dessous à gauche de la fenêtre, il y a l'icône d'insertion d'image, mais cette icône ne fonctionne qu'à moitié, car elle permet bien de télécharger une image, mais pas de l'insérer dans le texte ...

        Commentaire


        • #5
          Envoyé par casdyn Voir le message
          pas d'éditeur WYSIWYG dans le module mod_custom
          Personne n'a une idée ?
          C'est d'autant plus surprenant que cela se produit pour un site et non sur les 5 autres sites qui sont dans la même version de Joomla et avec les mêmes éditeurs de texte.

          Commentaire


          • #6
            Bonjour,

            J'avance dans mes investigations pour résoudre ce problème, mais je n'ai pas encore trouvé le fin mot de l'histoire.

            Ce qui est sûr, c'est que le problème est lié à la présence de l'éditeur JCE (dernière version). En effet, lorsque je désinstalle JCE, les éditeurs du site (tiny mce ou no editor) fonctionnent tout à fait correctement.

            Par contre, lorsque je réinstalle l'éditeur JCE, le fonctionnement devient aberrant :
            - aucun éditeur n'apparait dans mod_custom quel que soit l'éditeur choisi par défaut dans la config générale,
            - l'éditeur JCE s'impose partout (sauf dans mod-custom) quel que soit l'éditeur choisi par défaut dans la config générale.

            Ce comportement inspire-t-il quelqu'un pour m'aiguiller vers la solution ?

            Commentaire


            • #7
              J'ai exactement le même problème, je viens de m'en apercevoir, as-tu trouvé une solution ?

              Joomla 1.5.22 cela semble me le faire sur tous mes sites. bizarre, je dirais que c'est lié aux dernières maj mais laquelle ???

              Commentaire


              • #8
                Envoyé par Gregleens Voir le message
                as-tu trouvé une solution ?
                je dirais que c'est lié aux dernières maj mais laquelle ???
                Non, je n'ai pas encore trouvé la solution.

                Mais lorsque j'installe une sauvegarde du site dans un sous répertoire, je n'ai plus de problème avec cette copie du site .... ????

                Par ailleurs, cela ne vient pas du noyau de Joomla, car je gère 6 sites tous avec la 1.5.22 et le problème n'apparait que sur un seul site et de plus il n'apparait pas sur la copie de ce site ....

                Commentaire


                • #9
                  Bon j'ai trouvé une "pseudo" solution, en forçant l'actualisation de la page (CTRL + F5) j'obtiens l'affichage de l'éditeur. Il doit se passer un bins dans le cache du navigateur.

                  A vérifier et à tester mais pas le temps ce soir :
                  - tester sous IE ou Chrome pour voir si le problème existe
                  - supprimer et vider le cache du navigateur

                  Commentaire


                  • #10
                    J'ai également le même problème mais uniquement sur un site ?!

                    Je vais essayer de remettre la mise à jour 1;5.22 et je vous tiens au courant
                    www.astucesvoyages.com
                    www.vend-appartement.com
                    Auteur du livre " Le guide malin du voyageur -1001 Astuces

                    Commentaire


                    • #11
                      Il me faisait la même chose dans les articles, je suis allé dans gestion des plugins, j'ai choisi l'éditeur (Editor - TinyMCE) et mis mode de l'editeur étendu, et j'ai de nouveau eu toutes mes options
                      a+
                      Thomas

                      Commentaire


                      • #12
                        Tous mes sites sont en 1.5.22 et pour moi aussi, le problème ne se présente que sur un site.

                        Commentaire


                        • #13
                          Re : Pas d'éditeur WYSIWYG dans mod_custom

                          Je rencontre le même problème : l'éditeur JCE ne s'affiche pas dans mod_custom. Mais sur une autre instance de joomla ça marche. j'ai veillé à entrer exactement les mêmes paramètres et rien n'y fait. Quelqu'un a-t-il avancé sur ce problème ?

                          Commentaire


                          • #14
                            Re : Pas d'éditeur WYSIWYG dans mod_custom

                            Envoyé par noemiero Voir le message
                            Quelqu'un a-t-il avancé sur ce problème ?
                            De mon coté, je n'ai pas encore trouvé la solution à ce problème qui ne se présente que sur un seul de mes sites.

                            Commentaire


                            • #15
                              Re : Pas d'éditeur WYSIWYG dans mod_custom

                              Chez moi c'est bien un problème de gestion du cache de Firefox. En faisant CTRL+F5 une fois sur la page mod_custom les barres d'outils reviennent.

                              Depuis quelques jours je n'ai plus le problème, c'est revenu tout seul. Certainement une mise à jour quelconque qui a résolu le truc.

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X