Pas d'images dans le gestionnaire de médias

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Pas d'images dans le gestionnaire de médias

    Bonjour à tous,

    Je voudrais mettre en ligne des images en random sur la page d'accueil.

    Lorsque j'ai effectué les tests en local, je n'ai eu aucun problème. Mais lorsque je charge les images sur le site en ligne, les vignettes apparaissent en blanc dans le gestionnaire de médias.

    Je les ai chargées dans un premier temps à partir du site administrateur, puis j'ai tenté de les charger en FTP, le résultat est le même.

    Le problème n'est apparemment pas lié au lien vers le répertoire puisqu'il affiche le nom de l'image.

    Auriez-vous une idée de la source du problème ? En vous remerciant par avance...
    Dernière édition par Elisa64 à 28/01/2008, 14h04

  • #2
    bonjour,

    une piste à vérifier: comment as-tu nommé tes images ?

    y'a t'il des accents ou des caractères spéciaux dans les noms ?

    transformer un nom du style "l'avant-dernier repas de l'été.jpg" en "av_dernier_repas_et.jpg" pourrait résoudre ce genre de souci

    Commentaire


    • #3
      Bonjour netajour,

      Lorsque je veux agrandir une image du côté administrateur, voici le message qu'il m'affiche.

      You don't have permission to access /images/ImagesRandom/baraque champs 1.JPG on this server.
      Apache/2.0.58 (Unix) mod_ssl/2.0.58 OpenSSL/0.9.7i Server at xx.org Port 80

      J'ai l'impression que c'est plus un problème de droits : pourtant je suis superadministrateur.

      Ceci dit, il faut que je renomme les images que l'on m'a données...

      Commentaire


      • #4
        dans ce cas, vérifie par FTP que les droits en lecture/écriture sur le dossier ImagesRandom sont bien ouverts.

        chmod 755 ou carrément 777 sur le dossier, 644 sur les images - si aucun des 2 ne passe, essaye 750 sur dossier

        tu es superadmin dans joomla, pas sur le serveur

        Commentaire


        • #5
          Bonjour netajour,

          C'est là que s'arrête mon savoir : mes connaissances du FTP se limitent au transfert des données sur un site distant...

          Peux-tu m'expliquer chmod 755, 777 et 644 ? Un petit tuto, un site explicatif ? Histoire que je meure moins idiote

          Par ailleurs, j'ai l'impression que le problème se situe sur l'ensemble des répertoires se trouvant sous le dossier images (gestionnaire de médias). En effet, le images à la racine du dossier images sont parfaitement visibles (elles fonctionnent aussi pour le random...). Si je dois fouiller, ne dois-je pas vérifier les droits dans un autre dossier ?

          Commentaire


          • #6
            bonjour elisa64,

            je ne donne pas de cours ici; je te renvoie sur wikipedia concernant les chmod et l'entretien de ta culture gé. Bien que ce forum contient déjà un tas de posts sur ce sujet.

            http://fr.wikipedia.org/wiki/Chmod

            Un clic droit sur un nom de fichier, une fois connecté en FTP, donne accès à un menu dans lequel on trouve le moyen de changer les droits. Attention certains serveurs, (comme oléane par ex) ne permettent pas n'importe quoi en chmod.

            Ton gestionnaire de média n'affiche pas les images, mais uniquement les noms des fichiers, c'est bien ça ? Et ton module de random image ne renvoie rien en page d'accueil, c'est bien ça aussi ?

            - tu n'as enregistré que des images transparentes (nan, je plaisante !)
            - contrôle les droits sur tous les dossiers qui se trouveraient dans les dossier image principal qui est à la racine de joomla.
            - vérifie aussi à l'intérieur du dossier contenant le random (est-ce images aléatoires de joomla ou un truc additionnel ? Si c'est externe, il faut généralement installer les images aléatoires dans ce dossier)
            - le random prend les images dans quel dossier ? Vérifie dans le module si tu n'as pas oublié de renseigner une option.
            - quand tu changeras tes noms de fichiers, met tout en minuscule, y compris l'extension. Evite les caractères spéciaux et les intervalles (mets un tiret bas pour séparer des mots).
            Explication:
            Certaines déclarations oublient parfois d'intégrer toutes les orthographes possibles pour les fichiers autorisés au téléchagement. Si le programmeur a écrit jpeg au lieu de JPEG, et bien JPEG ne s'affichera jamais, alors que c'est bien la bonne et la même extension. Est-ce clair ?
            Dernière édition par netajour à 28/01/2008, 11h55

            Commentaire


            • #7
              Bonjour netajour,

              Je savais bien que chmod me disait quelque chose... Il y a très longtemps, j'ai eu une initiation à unix... Merci pour le lien.

              Donc j'ai contrôlé les droits (clic droit) et sous FileZilla, les choses étant simplifiées, j'ai pu comparer aisément les droits ouverts à la racine du dossier "images" et ceux des sous-répertoires.

              Il y a une petite case à cocher pour répercuter les droits d'un dossier vers tous les répertoires. Ce que j'ai fait et... MAGIQUE !! Ca a fonctionné.

              Alors je n'ai plus qu'à dire et merci beaucoup

              Commentaire


              • #8
                CHMOD changé et toujours pas d'images...

                Bonjour,
                J'ai tout fait comme indiqué dans les messages précédents mais je n'ai toujours pas d'images qui s'affichent. Et quand je veux effacer une image il me met Permission denied in /home/foljuif/bdecenciere/www/administrator/components/com_media/admin.media.php on line 99
                Je ne peux pas non plus uploader de nouvelles photos...
                Quelqu'un aurait une idée de comment résoudre le problème? Merci beaucoup!

                Commentaire


                • #9
                  Problème résolu

                  Bonjour,
                  Après quelques heures passées sur divers forums joomla de différents pays j'ai trouvé la solution à mon problème (dans le forum suivant http://www.joomlaspanish.org/foros/s...m_media&page=2) donc je me précipite pour la mettre ici car j'ai vu pas mal de personnes qui avaient eu ce problème.
                  Donc moi mes chmod étaient les bons, le fichier config aussi, c'était un problème de configuration d'apache. Il y a un alias actif appelé images et
                  icons dans le dossier usr/share ou qq chose du genre.
                  Il faudrait mettre # devant
                  <Directory /usr/share/images>
                  Options MultiViews
                  AllowOverride None
                  Order allow,deny
                  Allow from all
                  </Directory>

                  Il faut donc en parler avec le responsable de votre serveur et il répare cela en trois temps deux mouvements!

                  Merci aux forums joomla et toutes les bonnes âmes qui se dévouent pour répondre aux utilisateurs non expérimentés!

                  A bientôt!

                  Commentaire

                  Annonce

                  Réduire
                  1 sur 2 < >

                  C'est [Réglé] et on n'en parle plus ?

                  A quoi ça sert ?
                  La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                  Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                  Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                  Comment ajouter la mention [Réglé] à votre discussion ?
                  1 - Aller sur votre discussion et éditer votre premier message :


                  2 - Cliquer sur la liste déroulante Préfixe.

                  3 - Choisir le préfixe [Réglé].


                  4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                  2 sur 2 < >

                  Assistance au forum - Outil de publication d'infos de votre site

                  Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                  Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                  Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                  UTILISER À VOS PROPRES RISQUES :
                  L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                  Problèmes connus :
                  FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                  Installation :

                  1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                  Archive zip : https://github.com/AFUJ/FPA/zipball/master

                  2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                  3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                  4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                  5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                  6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                  et remplacer www. votresite .com par votre nom de domaine


                  Exemples:
                  Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                  Télécharger le script fpa-fr.php dans: /public_html/
                  Pour executer le script: http://www..com/fpa-fr.php

                  Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                  Télécharger le script fpa-fr.php dans: /public_html/cms/
                  Pour executer le script: http://www..com/cms/fpa-fr.php

                  En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                  Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                  Voir plus
                  Voir moins
                  Travaille ...
                  X