Joomladay francophone 2018 à Paris 18 et 19 mai

Comment insérer module dans Article

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Comment insérer module dans Article

    Bonjour,

    Je désirerais savoir de quelle manière insérer un module (par exemple une galerie) dans un Article sous Joomla 1.5.

    Merci !

  • #2
    Bonjour,
    pour afficher un module dans un artiche tu peu faire comme ceci :

    affecte la position de ton module sur "userxx" ou autre non utilisé par ton template, ensuite dans ton article tu fais {loadposition userxx}

    et chez moi cela fonctionne trés bien
    @+

    Commentaire


    • #3
      Chez moi ça ne marche pas

      Bonjour,

      Je suis sur Joomla 1.5.4
      J'ai activé le module Content - Load Module
      J'ai placé un module ( mod-random_image) en user9
      Puis j'ai crée un article en insérant {loadmodule user9}

      Ce que j'obtiens c'est tout simplement {loadmodule user9} en texte.

      Qu'elle erreur ai-je commise ?
      Comment dois-je insérer {loadmodule user9} ?

      Merci
      Sébastien Inion
      Professeur Certifié d'économie gestion option Informatique

      Commentaire


      • #4
        Bonjour,
        et bien ma ligne de commande c'est : {loadposition userxx}
        et cela fonctionne bien !

        @+

        Commentaire


        • #5
          ça marche pas chez moi

          Bonjour,

          Je viens d'essayer en tapant {loadmodule user9}
          Et ça ne marche pas. Il m'affiche {loadmodule user9} sans interpréter le code !

          Je ne vois pas du tout pourquoi...
          C'est bien au milieu du texte dans ton article que tu tapes ça ?

          Merci
          Sébastien Inion
          Professeur Certifié d'économie gestion option Informatique

          Commentaire


          • #6
            Bonjour,
            Envoyé par Seb11000 Voir le message
            Bonjour,

            Je viens d'essayer en tapant {loadmodule user9}
            Et ça ne marche pas. Il m'affiche {loadmodule user9} sans interpréter le code !

            Je ne vois pas du tout pourquoi...
            C'est bien au milieu du texte dans ton article que tu tapes ça ?

            Merci
            il faut mettre : {loadposition user9}.
            Chez cela fonctionne très bien en version Joomla 1.5.4 !
            @+
            Dernière édition par Jpeuf007 à 22/07/2008, 10h44

            Commentaire


            • #7
              Merci [Réglé]

              Merci beaucoup !

              ça fonctionne effectivement très bien, je pensais pourtant avoir déjà essayé cette solution.
              Sébastien Inion
              Professeur Certifié d'économie gestion option Informatique

              Commentaire


              • #8
                Bonjour à tous,

                je débute également sous Joomla et il y a quelque chose que je ne comprends pas avec le loadposition...

                Lorsque je place un {loadposition right} sur un article, pas de soucis il me reprends bien le module de droite (qui est déjà sur ma page article)...
                Par contre, j'ai un module placé en user1 uniquement sur ma home page.
                Lorsque je place un {loadposition user1} sur mon article, il ne m'affiche rien...

                Est-il impossible de faire un loadposition sur un module qui n'est pas affiché dans une page ?

                Merci d'avance pour vos réponses.
                Longue vie à ce forum !!

                Flamby

                Commentaire


                • #9
                  Salut,
                  Essayes cela je pense que cela répondra à ta question.
                  @+
                  Création de site web | Site de référence sur les fibres végétales | Administrateur du site

                  Commentaire


                  • #10
                    module dans un article

                    Bonjour à tous
                    Pour le cas où cela poserait un problème avec {loadposition user9}
                    Pour positionner un module dans un article il faut insérer ce code :
                    {mosmodule module=countdown}

                    Pour mon cas, il me fallait mettre un décompte de jours dans un article.
                    Bonne continuation

                    Commentaire


                    • #11
                      Salut,

                      Chez moi la fonction {loadposition user1} fonctionne très bien mais seulement lorsqu'un menu pointe sur l'article dans lequel j'insère ce code.

                      Comment faire pour que ce code fonctionne sur n'importe quel article ?

                      Commentaire


                      • #12
                        Bonjour

                        Normalement tu peux mettre ton loadposition dans autant d'articles que tu veux.
                        Je ne comprends pas le blém.
                        Tu peux développer
                        Merci
                        SVP pas de MP pour de l'aide, le forum est l’outil idéal

                        Commentaire


                        • #13
                          si l'article n'est pas lié à un menu, celui-ci ne fait pas apparaitre le module avec le loadposition. Par exemple dans mon cas, mon menu pointe vers les articles d'une catégorie et dans ce cas pas d'affichage. Si par contre mon menu pointe directement sur l'article, plus de problème d'affichage...

                          Commentaire


                          • #14
                            ok je comprends

                            Pour ma part effectivement j'ai un loadposition sur plusieurs articles avec une édition par un menu.

                            Je suis désolé de ne pas pouvoir t'aider mais je pense que ta question est très pertinente et demande que les personnes plus alaise en joomla nous aides car je reste intéressé par ce probléme.

                            @+
                            SVP pas de MP pour de l'aide, le forum est l’outil idéal

                            Commentaire


                            • #15
                              j'ai trouvé une solution mais celle ci n'est pas très "propre" :
                              j'ai crée un menu dans lequel je fais des liens vers les articles en question mais je ne publie pas le menu. Résultat les loadposition apparaissent bien mais l'url dans le navigateur est en référence avec le menu et le fil d'ariane est "coupée"...

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X