Joomladay francophone 2018 à Paris 18 et 19 mai

Yoo effects - Spotlight

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Yoo effects - Spotlight

    Bonjour à tous,

    J'ai un soucis avec le plugin Yoo effects - Spotlight, j'ai beau suivre la procédure sur le site de yootheme http://tutorials.yootheme.com/index....d=116&Itemid=2 mais ça ne fonctionne pas chez moi.

    Je répete les mêmes étapes que le gars sur la vidéo, mais lorsque je clique sur "sauver" après avoir editer mon code dans l'article, le contenu du code rajouté pour le plugin s'efface.

    Voici la partie du code:

    <div class="spotlight" style="background: url(../images/stories/logo.png);" width="240" height="180"></div>


    Le plugin semble être bien installé. De plus, je suis complètement perdu entre div tag, span tag, div class, etc...

    ps: il s'agit de la version 1.5 (j'ai testé sur une version 1.0.15 et ça ne fonctionne pas non plus...)
    Auriez-vous une idée (j'en ai marre lol)?

    Merci
    Fichiers joints

  • #2
    Salut Anis,

    C'est vraisemblablement à cause de ton éditeur WYSIWYG qui supprime les balises pour lesquelles il n'a pas d'exceptions (exemple "background") :

    - Soit tu désactives l'éditeur pour insérer ton code
    - Soit tu crées une liste de balises supplémentaires dans la configuration de l'éditeur (et là, c'est en fonction de chaque éditeur, vois pour le tien).

    Pour Yoo-Spotlight, tu utilises "div" lorsqu'il s'agit d'une simple image (ton code donné en exemple est pour ce cas de figure). Le "span" s'utilise lorsque ton image comporte aussi un lien. Dans ce cas, il faut ajouter la contrainte supplémentaire "display=block;"
    Enfin, n'oublies pas de créer 2 images pour Spotlight :
    - logo.png
    - logo_spotlight.png
    Soit "nomdefichier.png" en image primaire ET "nomdefichier_spotlight.png" pour le survol de type spotlight.

    A la relecture de ton code, il y a peut être une petite erreur, alors essaies plutôt d'écrire :
    Code PHP:
    <div class="spotlight" style="background: url(../images/stories/logo.png); width:240px; height:180px;"></div
    @++
    Hyperion
    Pas de demande de support en MP ou par mail, le forum est là pour ça!
    http://network.wantoo.com : Wantoo Network - Infogérance Serveurs Dédiés - Sécurité Joomla!

    Commentaire


    • #3
      Bonjour Hyperion,

      Tout d'abord je te remercie pour ta réponse. J'ai essayé différente choses mais ça n'a pas malheureusement pas fonctionné.

      Dans un premier temps, j'ai tout repris à zero sur un autre pc. Nouvelle install joomla, template etc... Ensuite, j'ai rajouté une exception dans les parametres de mon editeur (le standard de joomla), mais comme je n'ai pas trouvé de documentation mentionnant exactement comment les balises doivent être déclarées dans les paramètres, je me suis peut-être trompé (voir attachment).

      J'ai désactivé l'editeur comme suggéré et utilisé ton code mais pas moyen, on dirait qu'il m'affiche uniquement l'emplacement vide. J'ai pourtant un fichier logo.png et un autre logo_spotlight.png...

      Essayé également avec le template de base, me suis dit que peut être celui de gavick merdait mais c'est pas ça.

      Je commence à perdre espoir et je me demande si quelqu'un a déjà réussit à le faire marcher ce plugin, dommage j'en ai pas trouvé un autre qui fasse la même chose (et je veux cet effet! lol)
      Fichiers joints

      Commentaire


      • #4
        Re

        As-tu pensé à inclure mootool à ton template, s'il ne le possède pas déjà ??

        Dans ton index.php de ton template (en général, sinon un "include" quelconque dans les fichiers du template), entre les balises "head", tu dois avoir le chargement d'une librairie javascript mootool nécessaire. Exemple :
        Code PHP:
        <script type="text/javascript" src="<?php echo $template_path?>/js/mootools-release-1.11.js"></script>
        Ceci dans le cas d'un template possédant mootool. Sinon tu dois l'ajouter toi-même, pour la 1.0.15 par exemple :
        Code PHP:
        <script type="text/javascript" src="<?php echo $mosConfig_live_site?>/mambot/system/yoo_effects/mootools/mootools-release-1.11.js"></script>
        Mais normalement le plugin te donne le choix de "charger" ou non mootool... dans ce cas, c'est lui qui insère ce qu'il faut dans les en-têtes.

        Ce plugin marche très bien ! Je l'utilise souvent. Mon dernier exemple se trouve sur le site http://www.adiv84.fr (les boutons gris un peu partout et dans la page "irrigation" sur les icones de type dossiers)

        Donnes moi plus d'infos sur tes en-têtes du template

        @++
        Hyperion
        Pas de demande de support en MP ou par mail, le forum est là pour ça!
        http://network.wantoo.com : Wantoo Network - Infogérance Serveurs Dédiés - Sécurité Joomla!

        Commentaire


        • #5
          J'avais effectivement bien vérifié si moo tools est lancé avec mon template et c'est bien le cas. J'ai d'ailleurs lu a plusieurs endroits que moo est maintenant automatiquement livré avec la version 1.5 ?

          Voici ce que j'ai mon index.php:

          Code:
          	// adding mootools
          	JHTML::_('behavior.mootools');
          	
          	// getting variables from administration panel
          	$mtype = $this->params->get("menutype", "moomenu");
          	$datatop = ($this->params->get("datatop", 1)  == 2) ? false : true;
          	$login_link = ($this->params->get("login", 1) == 0) ? false : true;
          	$register_link = ($this->params->get("register", 1) == 0) ? false : true;
          Voici ce que je vois lorsque je consulte le code source de ma page d'accueil:

          Code PHP:
            <link rel="stylesheet" href="http://localhost/test/plugins/system/yoo_effects/lightbox/shadowbox.css" type="text/css" />
            <
          script type="text/javascript" src="/test/media/system/js/mootools.js"></script>
            <
          script type="text/javascript" src="/test/media/system/js/caption.js"></script>
            <
          script type="text/javascript">var YOOeffects = { url'http://localhost/test/plugins/system/yoo_effects/lightbox/' };</script>
          <
          script type="text/javascript" src="http://localhost/test/plugins/system/yoo_effects/yoo_effects.js.php?lb=1&amp;re=1&amp;sl=1"></script
          Le template de chez Gavick est livré avec des menus suckerfish avec effet mootools et ça marche. De plus, j'ai essayé yoo reflection et ça marche ****l...

          J'ai également changé d'editeur, j'ai pris JCE mais le même soucis.

          Tu me redonnes un peu l'espoir lorsque je vois ton site, très beau en passant
          Dernière édition par Anis à 08/10/2008, 11h45

          Commentaire


          • #6
            Merci pour les compliments Je suis content que cela te redonne de l'espoir

            Ca devrait être bon pour toi, avec ce que je vois ! A moins que le mootool de Gavick soit amputé d'une partie de ses fonctions... il arrive que les développeurs fabriquent un mootool sur mesure, juste pour eux (et le template)

            Tu peux essayer de charger le mootool de Yoo à la place de celui de Gavick, ou de le charger en PLUS, déjà, pour essayer : tu coches toutes les cases dans les réglages du plugin yoo_effects.
            Ca va créer 2 instances de mootool, c'est pas très propre, mais c'est pour le test. Après, tu verras si le poblème vient du mootool.js de Gavick ou non...


            Sinon, je te donne un exemple de code pour un bouton du site de l'ADIV cité plus haut :
            Code PHP:
            <a href="http://www.adiv84.fr/association/conseil-d-administration/view-category.html"><span class="spotlight" style="background: url('http://www.adiv84.fr/images/boutons/bt_adiv_ressources.png'); display: block; width: 160px; height: 50px"></span></a
            J'espère que ça va t'aider un peu
            Pas de demande de support en MP ou par mail, le forum est là pour ça!
            http://network.wantoo.com : Wantoo Network - Infogérance Serveurs Dédiés - Sécurité Joomla!

            Commentaire


            • #7
              Re,

              Bon j'ai essayé tout ce que tu m'as dit, même installé pour test une version 1.0.15 de joomla avec le plugin pour la même version et ça ne fonctionne pas... Je dois vraiment être maudit c'est pas possible.

              Ca fait 2 jours que je suis non-stop dessus et j'abandonne. Dommage car je veux cet effet pour mon site lol

              Celui qui trouve la solution à mon problème je lui offre ce qu'il veut

              Encore merci

              Commentaire


              • #8
                Envoyé par Anis Voir le message
                Ca fait 2 jours que je suis non-stop dessus et j'abandonne. Dommage car je veux cet effet pour mon site lol
                Salut Anis,

                C'est dommage en effet ! N'abandonne pas... fais autre chose, trois tours du quartier en courant, une bonne sortie entre potes, je sais pas, mais ne lâche pas l'affaire. Il y a d'autres façons d'obtenir le même résultat (avec JQuery par exemple) mais c'est plus complexe à mettre en place. Le bidule Yoo fonctionne normalement "right off the box". C'est un mystère.
                Et comme tu développes en local, on ne peut pas trop t'aider à distance

                Tiens-nous informé de ton futur succès d'implémentation du Yoo récalcitrant (ce dont je ne doute pas 1 seconde )

                @++
                Hyperion
                Pas de demande de support en MP ou par mail, le forum est là pour ça!
                http://network.wantoo.com : Wantoo Network - Infogérance Serveurs Dédiés - Sécurité Joomla!

                Commentaire


                • #9
                  Envoyé par hyperion Voir le message
                  Salut Anis,

                  C'est dommage en effet ! N'abandonne pas... fais autre chose, trois tours du quartier en courant, une bonne sortie entre potes, je sais pas, mais ne lâche pas l'affaire. Il y a d'autres façons d'obtenir le même résultat (avec JQuery par exemple) mais c'est plus complexe à mettre en place. Le bidule Yoo fonctionne normalement "right off the box". C'est un mystère.
                  Et comme tu développes en local, on ne peut pas trop t'aider à distance

                  Tiens-nous informé de ton futur succès d'implémentation du Yoo récalcitrant (ce dont je ne doute pas 1 seconde )

                  @++
                  Hyperion
                  Salut Hyperion,

                  Merci pour l'encouragement je vais continuer le develloppement du site, j'y reviendrai peut-être à la fin après une bonne cure désintox yoomla... Jquery je ne connais pas, je vais peut-être essayé pour voir ce que ça donne. Reflection marche impec, spotlight veut pas, me reste donc plus qu'à tester le lightbox de yoo et j'aurai fait la totale

                  Sinon j'ai vu que joomla proposait lorsqu'on rajoute une image via l'editeur d'activer une option permettant de mettre une image alternative lorsque le curseur passe sur cette 1ere image, ça na pas l'effet de fondu de yoo mais ça marche bien

                  @++

                  Commentaire

                  Annonce

                  Réduire
                  1 sur 2 < >

                  C'est [Réglé] et on n'en parle plus ?

                  A quoi ça sert ?
                  La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                  Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                  Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                  Comment ajouter la mention [Réglé] à votre discussion ?
                  1 - Aller sur votre discussion et éditer votre premier message :


                  2 - Cliquer sur la liste déroulante Préfixe.

                  3 - Choisir le préfixe [Réglé].


                  4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                  2 sur 2 < >

                  Assistance au forum - Outil de publication d'infos de votre site

                  Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                  Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                  Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                  UTILISER À VOS PROPRES RISQUES :
                  L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                  Problèmes connus :
                  FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                  Installation :

                  1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                  Archive zip : https://github.com/AFUJ/FPA/zipball/master

                  2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                  3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                  4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                  5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                  6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                  et remplacer www. votresite .com par votre nom de domaine


                  Exemples:
                  Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                  Télécharger le script fpa-fr.php dans: /public_html/
                  Pour executer le script: http://www..com/fpa-fr.php

                  Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                  Télécharger le script fpa-fr.php dans: /public_html/cms/
                  Pour executer le script: http://www..com/cms/fpa-fr.php

                  En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                  Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                  Voir plus
                  Voir moins
                  Travaille ...
                  X