installation sur serveur précaire

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • installation sur serveur précaire

    Bonjour,

    j'ai eu ici un problème assez particulier pour lequel j'aimerais votre avis.

    J'ai créé un site en local, une fois celui-ci fini je veux l'uploader sur mon serveur.
    Problème d'invalid task, un classique. Le patch de joel ne marche pas (alors que d'habitude bien...), tant pis, je demande à joomlapack de placer l'installeur 3 (au lieu de 4) dans la sauvegarde. Plus de problème...

    J'upload donc le dossier de sauvegarde sur mon serveur en utilisant filezilla.
    J'ai eu ici une tonne de messages d'erreurs disants: too many connection to the serveur (quelque chose dans le genre, de mémoire). Première fois que j'ai ce problème. Malgré ça, le transfert se finit. Ai-je perdu des données dans la bataille, je ne suis pas assez pro pour le savoir...

    J'installe donc la sauvegarde sur mon serveur (avec l'installeur 3 donc). Aucun soucis, sauf qu'une fois cette étape finie, le site disjoncte complétement. Je vois du code au lieu de ma page d'accueil.
    Les autres pages fonctionnent correctement...

    La page d'accueil comprenant les seules images (utilisants mvThumbnails, je précise toujours) que j'aie actuellement sur le site, je décide de supprimer l'article les contenant (intuition sans doute).
    Là, tout refcontionne....
    Sauf que mon menu d'administration est passé à moitié en anglais... Un lien sur deux plus ou moins.
    C'est un détail, de manière générale tout marche très bien, mais je trouve cette installation un peu précaire pour travailler.
    (recommencer serait inutile, j'ai à chaque fois le même résultat)

    Une idée, une suggestion ?

    Merci d'avance
    Dernière édition par Zenike à 15/11/2009, 19h34

  • #2
    Fillezilla envoie 3 fichiers simultanement. désactive cette fonction. Semblerai que ton serveur refuse cette option.
    edition -> Préférence, puis dans transfère. Et refait le transfère
    Règlement du forum : http://forum.joomla.fr/faq.php
    Comment mettre le post en [Réglé]: http://forum.joomla.fr/announcement.php?f=58
    Joomla! 3 Le Livre Pour Tous , n'hésitez pas à le lire pour vous aider
    http://www.iwannaclick.org

    Commentaire


    • #3
      Ah, voilà qui serait plausible, je vais essayer ça de suite.
      (dans mon cas c'était configuré à deux fichiers simultanément, mais ça revient au même j'imagine).

      Merci bien, je teste ça de ce pas et je vous dis quoi.
      Dernière édition par Zenike à 15/11/2009, 18h06

      Commentaire


      • #4
        Ça a l'air de bien se dérouler grâce à cette astuce.
        Juste une question:

        Il me met fréquemment (en vert, pas un message d'erreur): Switching to ASCII mode. J'ai vu dans les options qu'il passait en ASCII pour les fichiers dont l'extension était inconnue.
        Tout ça est normal ou ça peut témoigner d'un problème ? (j'imagine que c'est ok mais ça ne coute rien de se renseigner)

        Commentaire


        • #5
          nomale: ascii mode = fichier TXT
          Règlement du forum : http://forum.joomla.fr/faq.php
          Comment mettre le post en [Réglé]: http://forum.joomla.fr/announcement.php?f=58
          Joomla! 3 Le Livre Pour Tous , n'hésitez pas à le lire pour vous aider
          http://www.iwannaclick.org

          Commentaire


          • #6
            Ok merci pour l'info.
            Bon, le tranfert s'est passé sans le moindre soucis et ça a réglé une partie des problèmes. Mon interface d'administration ne bug plus (plus de franglais).

            Par contre, ma page d'accueil contenant des images a toujours autant de mal.

            EDIT: Après quelques tests et recherches, il semblerait que le problème vienne de mavikthumbnails.
            Chaque image modifiée à l'aide de ce plug-in fait flancher la page qui l'affiche.
            Ce topic ci dessous, resté sans réponse, témoigne du même problème que moi, exactement.

            http://forum.joomla.fr/showthread.php?t=87643

            Le problème concernant la restauration de ma sauvegarde n'en est pas moins résolu grâce à l'aide de Sharky. Merci beaucoup.
            Je vais poser mes interrogations concernant ce plug-in dans la section adaptée, c'est à dire dans le topic que je viens de citer. Si vous avez une idée, répondez à cet endroit
            Dernière édition par Zenike à 15/11/2009, 19h36

            Commentaire


            • #7
              Contrôles les droits sur les répertoires
              dans le backend: menu : aides -> infos système, puis "permission des dossiers"
              Tous doit être en vert

              Je pense que ton mavikthumbnails doit avoir les droits d'écriture dans un dossier précis.
              Règlement du forum : http://forum.joomla.fr/faq.php
              Comment mettre le post en [Réglé]: http://forum.joomla.fr/announcement.php?f=58
              Joomla! 3 Le Livre Pour Tous , n'hésitez pas à le lire pour vous aider
              http://www.iwannaclick.org

              Commentaire

              Annonce

              Réduire
              1 sur 2 < >

              C'est [Réglé] et on n'en parle plus ?

              A quoi ça sert ?
              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
              Comment ajouter la mention [Réglé] à votre discussion ?
              1 - Aller sur votre discussion et éditer votre premier message :


              2 - Cliquer sur la liste déroulante Préfixe.

              3 - Choisir le préfixe [Réglé].


              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

              2 sur 2 < >

              Assistance au forum - Outil de publication d'infos de votre site

              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

              UTILISER À VOS PROPRES RISQUES :
              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

              Problèmes connus :
              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

              Installation :

              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

              Archive zip : https://github.com/AFUJ/FPA/zipball/master

              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
              et remplacer www. votresite .com par votre nom de domaine


              Exemples:
              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
              Télécharger le script fpa-fr.php dans: /public_html/
              Pour executer le script: http://www..com/fpa-fr.php

              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
              Télécharger le script fpa-fr.php dans: /public_html/cms/
              Pour executer le script: http://www..com/cms/fpa-fr.php

              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
              Voir plus
              Voir moins
              Travaille ...
              X