Mon site n'as pas de contenu

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Mon site n'as pas de contenu

    Bonjour,
    J'ai importé ma base de donnée, mais malgré cela le site n'as pas son contenu... Je ne comprends pas pourquoi... D'avance merci pour votre aide

  • #2
    bonjour;
    tu as importer vers un site distant ?
    ta version en local a tel encore de contenue ?
    si c'est le cas tu as surement du faire une erreur lors de l'exportation, peut être que tu na pas sélectionner toutes les table, ou peut être que tu as exporter ta base sur un site diffèrent sur le quel tu as travailler ?
    salutations
    salutations
    Un JoomlaDay au Maghreb ? Suivez le fil
    Suivez Joomla!Day Algérie Joomla!® Algérie
    Agence de communication xmedia http://www.xmedia-communication.com

    Commentaire


    • #3
      Avec si peut d'élément , moi non plus!!! Il manque pas mal d'info pour pouvoir t'aider, mais contrôle déjà:
      - ton joomla pointe sur la même BDD dont tu viens de faire l'import
      - l'import contient bien le content ?
      - est-ce de même version de Joomla 1.5 à 1.5 ?
      - est-ce que l'import c'est fait sans accroche?
      - Tu dis qu'il n'y a pas de contenu, qu'as-tu exactement importer ? Toute une base, une uniquement une table ??
      ...
      Règlement du forum : http://forum.joomla.fr/faq.php
      Comment mettre le post en [Réglé]: http://forum.joomla.fr/announcement.php?f=58
      Joomla! 3 Le Livre Pour Tous , n'hésitez pas à le lire pour vous aider
      http://www.iwannaclick.org

      Commentaire


      • #4
        Ma boule de cristal me dit que la base a été importée avant de faire une installation sans les exemples.
        Se trompe-t-elle ?
        "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

        Commentaire


        • #5
          Envoyé par RobertG Voir le message
          Ma boule de cristal me dit que la base a été importée avant de faire une installation sans les exemples.
          Se trompe-t-elle ?
          Règlement du forum : http://forum.joomla.fr/faq.php
          Comment mettre le post en [Réglé]: http://forum.joomla.fr/announcement.php?f=58
          Joomla! 3 Le Livre Pour Tous , n'hésitez pas à le lire pour vous aider
          http://www.iwannaclick.org

          Commentaire


          • #6
            Oui, alors sorry, je vais m'expliquer plus en détail. (ça va être long...). Voici ce que j'ai fait : en local j'ai une base de donnée nommée par exemple, basededonne_V2. Lors de l'installation sur le serveur de l'héberger il se trouve que la bd que je crée doit avoir une racine obligatoire comme xyz_Nomdelabase. La bd en local et celle du site distant on un nom différent, effectivement. à partir de là, ce que j'ai fait. J'ai crée un fichier text de ma bd en local et je l'ai placé sur le serveur. Dans la partie phpMyAdmin, toutes les tables sont là. Il y en a 90. C'est mon premier site sous joomla/virtuemart, et là je cafouille... MeaCulpa, comment dois-je procéder pour résoudre tous ça a votre avis ? Et encore merci pour votre aide, la communauté m'a toujours beaucoup aidé à résoudre mes soucis, j'suis dans la dernière ligne droite.

            Commentaire


            • #7
              Sur le serveur de l'hébergeur, la base de données a un nom éventuellement ixé par l'hébergeur, mais certainement pas le préfixe des tables : à toi de faire en sorte que ton site chez l'hébergeur utilise les mêmes préfixes de tables que ton site local.
              "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

              Commentaire


              • #8
                Donc tu es sur une migration local -> hebergeur. Suis bien les procédures
                http://www.iwannaclick.org/informati...-dun-site.html
                Règlement du forum : http://forum.joomla.fr/faq.php
                Comment mettre le post en [Réglé]: http://forum.joomla.fr/announcement.php?f=58
                Joomla! 3 Le Livre Pour Tous , n'hésitez pas à le lire pour vous aider
                http://www.iwannaclick.org

                Commentaire


                • #9
                  bonjour
                  peut etre que je me trompe, mais je crois que c'est un problème avec l'adresse de ta boutique, dans configuration de virtuemart sur ton serveur distant, tu devrais trouver un lien en local au lieu d'un lien distant.

                  tu clique sur virtuemart/configuration/sécurité et tu verife le lien URL si c'est un url comme http://www.tonsite.com c bon, ou si c'est un truc comme localhost: c'est pas bon

                  tu trouvera ici tous ce que tu cherche normalement
                  salutations
                  Dernière édition par xmedia à 01/11/2010, 14h41
                  Un JoomlaDay au Maghreb ? Suivez le fil
                  Suivez Joomla!Day Algérie Joomla!® Algérie
                  Agence de communication xmedia http://www.xmedia-communication.com

                  Commentaire


                  • #10
                    Merci pour votre aide, pour répondre à RobertG, mes tables chez l'hebergeur ont le bon préfixe.
                    J'ai suivie plusieurs pistes toutes super mais ça coince toujours. Super le lien de sharky, je le garde sous le coude. J'ai installé, désinstaller un milliard de fois, en utilisant divers possibilités qui m'ont été proposées.
                    - J'ai renommer ma base de donnée en locale du même nom que celle de mon héberger pour ne plus avoir de soucis.
                    - J'ai utilisé le fichier " moovlaJ15.php", pour la configuration. vérifié le contenu du fichier "configuration php", tout à l'air correcte et pourtant je n'arrive pas à avoir accès à la base de donné. Parce que je le répète je procède de nouveau à l'installation...

                    Commentaire


                    • #11
                      Je viens de procéder à l'installation (de nouveau). J'avais remarqué quelque chose d'étrange dans l'interface de l'héberger, là ou l'on crée un utilisateur (je ne peux pas créer d'utilisateur depuis phpMyAdmin, chez hosteur). Il n'était pas effectif donc quand je procédait à mes réinstallations, ça ne marchait pas bien sûr.
                      Cette fois-ci j'ai utiliser "JoomlaPackInstaller" 2.4 et plus. ça permet de faire une copie complète + base de donnée et de procéder à l'installation sur le serveur. Très pratique.
                      J'ai été au bout de l'installation, retiré le fichier 'installation', mais quand je suis sur le site j'ai ce message d'erreur : JError Unable to load Database Driver:
                      j'ajoute que j'ai bien modifié l'url du site en local par l'url du site distant dans le fichier "administrator/components/com_virtuemart/virtuemart.cfg.php"; alors késako ? je pédale dans la semoule !

                      Commentaire


                      • #12
                        Attention, Joomla Pack est devenu Akeeba ...
                        Donc c'est bien une migration que tu veux faire ?
                        Ton site en local fonctionne mais chez l'hébergeur !
                        Les pré-requis Joomla sont-ils OK ? Au début de l'installation, tout est en vert ?

                        Envoyé par amethyste Voir le message
                        là ou l'on crée un utilisateur (je ne peux pas créer d'utilisateur depuis phpMyAdmin, chez hosteur).
                        Là je ne sais pas si c'est l'utilisateur de la base ou de Joomla !

                        Envoyé par amethyste Voir le message
                        J'ai été au bout de l'installation, retiré le fichier 'installation', mais quand je suis sur le site j'ai ce message d'erreur : JError Unable to load Database Driver:
                        Problème temporaire de l'hébergeur ou mauvaise config ???
                        Règlement du forum : http://forum.joomla.fr/faq.php
                        Comment mettre le post en [Réglé]: http://forum.joomla.fr/announcement.php?f=58
                        Joomla! 3 Le Livre Pour Tous , n'hésitez pas à le lire pour vous aider
                        http://www.iwannaclick.org

                        Commentaire


                        • #13
                          Pour avancer dans mon projet j'ai procédé à une installation normale, puisque la base de donnée est correctement installée sur le site distant à présent (avec joomla Pack toute l'installation et la configue c'est bien déroulé ainsi que la migration de ma base de donnée). J'ai toujours le même problème. J'ai ma structure, mes templates, mes feuilles de styles css; mais toujours pas de contenu. ça devrait marcher pourtant, la bd est ok j'vois pas d'explications. Je suis en train de me retaper tout mon contenu (j'en ai pour plusieurs jours...). Joomla Pack est devenu Akeeba ? je l'ai essayé (super info, merci); pour tester. Quand je sauvegarde j'ai un massage d'erreur "Invalid AJAX data", dans la configuration j'ai coché "Utiliser des IFrames, au lieu d'AJAX" (conseillé en cas d'erreurs ajax) mais rien y fait...Cliquez sur l'image pour l'afficher en taille normale

Nom : Image 3.jpg 
Affichages : 1 
Taille : 29,8 Ko 
ID : 1796755

                          Commentaire


                          • #14
                            sharky, je parlais plu haut de l'utilisateur de la base chez l'héberger.

                            Commentaire

                            Annonce

                            Réduire
                            1 sur 2 < >

                            C'est [Réglé] et on n'en parle plus ?

                            A quoi ça sert ?
                            La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                            Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                            Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                            Comment ajouter la mention [Réglé] à votre discussion ?
                            1 - Aller sur votre discussion et éditer votre premier message :


                            2 - Cliquer sur la liste déroulante Préfixe.

                            3 - Choisir le préfixe [Réglé].


                            4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                            2 sur 2 < >

                            Assistance au forum - Outil de publication d'infos de votre site

                            Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                            Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                            Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                            UTILISER À VOS PROPRES RISQUES :
                            L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                            Problèmes connus :
                            FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                            Installation :

                            1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                            Archive zip : https://github.com/AFUJ/FPA/zipball/master

                            2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                            3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                            4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                            5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                            6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                            et remplacer www. votresite .com par votre nom de domaine


                            Exemples:
                            Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/
                            Pour executer le script: http://www..com/fpa-fr.php

                            Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/cms/
                            Pour executer le script: http://www..com/cms/fpa-fr.php

                            En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                            Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                            Voir plus
                            Voir moins
                            Travaille ...
                            X