Akkeba Backup ok mais impossible d'accéder au site et admin

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Akkeba Backup ok mais impossible d'accéder au site et admin

    Bonjour,
    j'ai fait la sauvegarde d'un site avec akeeba Backup 3.1b3 et kickstart 3.1.3 pour la récup - mon site au départ à un nom de domaine on va dire toto.com.

    j'ai fait la sauvegarde complète chez l'hébergeur Nuxit.
    Je souhaitais transférer ce site en secours chez 1and1 (mais donc sans y accéder par le nom de domaine toto.com, puisqu'il fonctionne toujours...je ne veux pas le transférer), Je pensais donc y accéder pour l'instant par le nom de domaine de mon hébergement 1and1, qui est en fait un nom de domaine générique attribué d'office et du style s04xxxxxx.onlinehome.fr
    j'ai donc créé un répertoire site1 chez 1and1 pour y faire l'installation via kickstart

    J'ai suivi pas à pas la procédure excellente du tuto vidéo de joomlabc. tout c'est très bien passé. les connexions FTp ok, sql ok...etc..à la fin de l'install j'ai bien supprimé le rep install comme indiqué.
    à la fin, on arrive sur une page de Kickstart avec un lien admin et un lien accédez au site.
    j'ai donc cliqué sur accéder au site et là miracle , le site s'affiche comme le "vrai" super...
    machinalement je clique sur un menu et là, cata..bien sûr, comme je suis en url rewriting sur le site original, le chemin affiché dans la barre d'adresse commence bien par le nom du nouveau site, par contre elle continue avec des noms significatifs du style : www.s04xxxxxx.onlinehome.fr/site1/les voyages.html
    donc là, bien sûr plus d'affichage. et donc bien sûr message d'erreur 404

    ALors maintenant quand je retape l'adresse du site chez 1and1 : www.s04xxxxxx.onlinehome.fr/[COLOR="#B22222"]site1[/
    il me télécharge direct le fichier index.php sur mon ordi...! sans rien afficher...page blanche

    j'ai modifié, puis viré le htaccess, rien n'y fait. Le fichier configuration.php à l'air correct (c'est à dire qu'à l'intérieur il fait bien référence la nouvelle adreese , la bonne base sql et...

    quelqu'un sait-il d'où peut provenir ce problème ? Chose importante ...quand j'essaye de me logguer en admin c'est à dire www.s04xxxxxx.onlinehome.fr/[COLOR="#B22222"]site1[/administrator/index.php ça fait pariel , c'est à dire qu'il me télécharge le fichier index sur mon disque...et page blanche

    merci, merci !!
    Gérard

  • #2
    Re : Akkeba Backup ok mais impossible d'accéder au site et admin

    salut,

    si c'est une migration que tu veux faire, ça me parait bien compliqué.

    Solution simple et robuste :
    1. Export complet de ta BdDvia phpmyadmin ou Akeeba (DB only)
    2. Transfert FTP joomla même version sur new hébergeur.
    3. Install avec même préfixe de table, même mdp admin que ta BdD de ton site.
    4. récupération du configuration.php, tu le redescends sur ton PC.
    5. import SQL de ta BdD sur nouvelle hébergeur.
    6. modif paramètre user/pwd et base si différent
    7. Transfert de ton site. tu remplace le joomla installé par ton site entier (sans configuration.php)
    8. upload à la racine de ton joomla de configuration.php
    ​Terminé, ton site est en ligne sur nouvel hébergeur.

    Si tu sais récupérer les variables
    $tmp_path, $host, $user, $db, $dbprefix tu peux directement transférer ton site sans nouvel install...
    Developper of JBreeding Manager: http://www.jbreeding.fr/
    J-cook Referral : Service Générateur d'Extensions pour Joomla

    Commentaire


    • #3
      Re : Akkeba Backup ok mais impossible d'accéder au site et admin

      Ok, j'ai tenté sur un site "normal" ça fonctionne à merveille,( le fait de garder le configuration.php de l'install neuve pour le remettre une fois les fichiers de sauvegardes réinstallés.)

      Je vais maintenant le faire avec le vrai site. mais ça va être un peut différent peut-^tre car sur le vrai site j'ai l'url rewriting qui fonctionne.(et le site 2 n'aura pas le même nom de domaine que le site 1 (celui que je veux transférer...)

      je présume qu'il faut que je remette aussi l'ancien htaccess ?

      merci
      Dernière édition par gaeil28 à 07/03/2012, 15h11

      Commentaire


      • #4
        Re : Akkeba Backup ok mais impossible d'accéder au site et admin

        Les noms de domaines ne perburbent pas la fonctionnalité de Joomla! Par contre les config PHP par défault des hébergeurs, OUI. Aussi il faut que tu vérifies cela avant de migrer un site.

        Et oui, tu peux peux remettre le .htaccess associé. (et vérifier si tu ne dois pas forcer l'environnement de run )
        SetEnv PHP_VER 5_3, par exemple chez OVH.
        Developper of JBreeding Manager: http://www.jbreeding.fr/
        J-cook Referral : Service Générateur d'Extensions pour Joomla

        Commentaire


        • #5
          Re : Akkeba Backup ok mais impossible d'accéder au site et admin

          Alors là !
          c'est toujours pareil, les trucs les plus simples, ont n'y pense jamais (sauf toi
          ça fait presque 1 semaine que je galère (pour être poli) à essayer une restauration avec Akeeba et (avec ou sans ) kicstart....
          et là nickel. vraiment merci pour cette idée lumineuse !

          Pour résumer, car ça peut servir à d'autres !

          J'ai 1 site toto.com chez l'hébergeur X - url rewriting fonctionne - sous joomla 1.5.18 + divers composants (jcomments etc..)

          j'ai un nom de domaine titi.com, chez l'hébergeur Y, qui pointe vers un répertoire (vide)

          Je fais une sauvegarde au format zip avec Akeeba Backup du sitetoto.com (zip, car pour moi la récup en fichier jpa fonctionnait, mais pas la restauration avec Kickstart.)

          Chez l'hébergeur Y, je fais une install classique d'un joomla 1.5.xxx - install terminée - je ne clique sur aucun lien - je supprime le répertoire install et je teste http//:www.titi.com, j'essaye aussi le lien Admin, (ou taper l'adresse direct : www.titi.com/administrator ). ça fonctionne - ce sont les données de démo...
          Comme le futur doit fonctionner avec l'url rewriting, Je vais dans l'admin, dans la zone SEO, je coche les 3 cases URLs explicites (SEF),utiliser le mode apache..réécriture des URL, ajouter un suffixe aux URL , et je ne valide pas !
          Avec FileZilla, ou un autre client FTP, je vais dans la racine du site titi.com,
          je renomme le htaccess.txt en .htaccess et je valide maintenant, et je vérifie que l'url rewriting fonctionne.
          Maintenant, je sauvegarde les 2 fichiers .htaccess et configuration.php.

          Avec le client FTP, je supprime tout le contenu du répertoire où j'avais fait cette superbe installation (snif...)
          ensuite, j'y transfère tous les fichiers de l'archive du site toto.com.
          j'entre l'adresse : www.titi.com/installation. - je renseigne les différents écrans avec les données (id base de données etc..)
          à la fin de l'installation, je supprime comme demandé le répertoire install - avec le client FTP je remplace les deux fichiers sauvegardés .htaccess et configuration.php
          et voilà...la je tape www.titi.com et je retrouve tout ce que j'avais sur toto.com
          Gérard
          PS : j'ai gardé les mêmes noms de tables sur les deux sites _jos (donc d'origine) mais je pense que ça aurait fonctionné quand même si j'avais pris un autre nom de base pour le deuxième site.
          Dernière édition par gaeil28 à 07/03/2012, 18h38

          Commentaire


          • #6
            Re : Akkeba Backup ok mais impossible d'accéder au site et admin

            Envoyé par gaeil28 Voir le message
            PS : j'ai gardé les mêmes noms de tables sur les deux sites _jos (donc d'origine) mais je pense que ça aurait fonctionné quand même si j'avais pris un autre nom de base pour le deuxième site.
            Attention, ça marche, car tu est passé par une install, et donc le "nouveau" configuration.php a été généré pour toi à l'install. Comme je te disais, si tu as une parfaite connaisssance des nouvelles "variables d'Environnements", tu modifies l'ancien configuration.php avec ses nouvelles valeurs, et ça roule !
            En 3 étapes, c'est migré, pour résumer:

            1 - Download du site (filesystem) + export Mysql.
            2 - Upload du site (filesystem) + import Mysql.
            3 - Upload du Configuration.php (mis à jour avec les nouvelles valeurs)

            Nickel ! tu vois, migrer un site joomla!, c'est pas sorcier, y'a juste quelques petites choses à maitriser
            Developper of JBreeding Manager: http://www.jbreeding.fr/
            J-cook Referral : Service Générateur d'Extensions pour Joomla

            Commentaire


            • #7
              Re : Akkeba Backup ok mais impossible d'accéder au site et admin

              J'ai lu ta procédure, mais tu ne parles pas des export / import de base de données. Tu ne peux pas retrouver le contenu de toto.com dans titi.com, si tu ne gère pas cette migration des données !?!
              Developper of JBreeding Manager: http://www.jbreeding.fr/
              J-cook Referral : Service Générateur d'Extensions pour Joomla

              Commentaire


              • #8
                Re : Akkeba Backup ok mais impossible d'accéder au site et admin

                ben si.. dans la sauvegarde faite par Akeeba Backup j'ai demandé la sauvegarde complète du site ; données et base de données.

                dans cette archive (zip) créée par Akeeba, il y a un script d'installation (un rep installation) comme pour une installation classique de joomla. Ainsi quand on lance ce script (www.titi.com/installation), on a différents écrans dans lesquels on doit entrer le nom de la nouvelle base, l'hôte Sql, l'id et mot de passe d'accès à la base. Il demande s'il doit écraser les tables existantes qui seraient trouvées (ou en faire une copie..), il demande d'entrer le nouveau préfixe des tables (moi j'ai gardé _jos), le nom de domaine du nouveau site s'il existe etc..ainsi, c'est ce script qui s'occupe de tout....d'ailleurs ce script ressemble beaucoup à celui utilisé pour l'installation de joomla.
                le problème de cette procédure (installation via le zip ), c'était que pour une raison inconnue, (un problème avec le configuration.php ?) en fin d'instal, le site ne tournait pas..il y avait un problème de chemin...ou je ne sais quoi..(il se plantait quand on cliquait sur les menus, l'admin restait figé...) - en remettant manuellement les 2 fichiers htacces et configuration.php sauvegardés lors de l'installation provisoire du joomla basique sur titi.com, le tout fonctionne...

                Commentaire


                • #9
                  Re : Akkeba Backup ok mais impossible d'accéder au site et admin

                  Ha OK !
                  Akeeba, je l'utilise que pour les sauvegardes des bases. Leur procédure de resto est vraiment trop lourde, que ce soit en .zip ou en .jpa
                  Impec alors !
                  Developper of JBreeding Manager: http://www.jbreeding.fr/
                  J-cook Referral : Service Générateur d'Extensions pour Joomla

                  Commentaire

                  Annonce

                  Réduire
                  1 sur 2 < >

                  C'est [Réglé] et on n'en parle plus ?

                  A quoi ça sert ?
                  La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                  Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                  Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                  Comment ajouter la mention [Réglé] à votre discussion ?
                  1 - Aller sur votre discussion et éditer votre premier message :


                  2 - Cliquer sur la liste déroulante Préfixe.

                  3 - Choisir le préfixe [Réglé].


                  4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                  2 sur 2 < >

                  Assistance au forum - Outil de publication d'infos de votre site

                  Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                  Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                  Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                  UTILISER À VOS PROPRES RISQUES :
                  L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                  Problèmes connus :
                  FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                  Installation :

                  1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                  Archive zip : https://github.com/AFUJ/FPA/zipball/master

                  2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                  3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                  4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                  5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                  6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                  et remplacer www. votresite .com par votre nom de domaine


                  Exemples:
                  Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                  Télécharger le script fpa-fr.php dans: /public_html/
                  Pour executer le script: http://www..com/fpa-fr.php

                  Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                  Télécharger le script fpa-fr.php dans: /public_html/cms/
                  Pour executer le script: http://www..com/cms/fpa-fr.php

                  En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                  Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                  Voir plus
                  Voir moins
                  Travaille ...
                  X