Joomladay francophone 2018 à Paris 18 et 19 mai

Les images des produits ne s'affichent pas dans les catégories

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] Les images des produits ne s'affichent pas dans les catégories

    Bonjour,

    Mon problème est le suivant : j'utilise Joomla 1.5.12 avec Virtuemart 1.1.3 sur un serveur en ligne. Lorsque je fais des tests en local avec Wamp, les images des produits s'affichent dans les catégories alors que sur le site en ligne, les images n'apparaissent pas ! Ceci est d'autant plus curieux que lorsque l'on clique sur le produit, la fiche détaillée du produit s'affiche avec son image tant en off-line qu'on-line (mais ça c'est normal et tant mieux).

    Quelqu'un a déjà rencontré le problème ? Avez-vous une piste ou (mieux) une solution à proposer ?

    D'avance, merci
    Joomla! 1.5.23 / Virtumart 1.1.9 / AllEvents beta 1.1

  • #2
    le lien vers le post des astuces
    http://forum.joomla.fr/showthread.php?t=89922

    consulte les sommaires, la reponse s'y trouve.

    cherche mes images secondaires ne s'affichent pas...
    sommaire thématique des astuces du forum e-commerce ici http://www.webtimarket.com/fr/telechargements
    http://virtuemart.fr

    Commentaire


    • #3
      Merci pour votre réponse, néanmoins, je ne trouve pas la solution ou alors elle est passé inaperçue malgré mon attention.

      Pour illustrer le propos, en annexe deux impressions d'écran prises sous Firefox 3.5.1 et Opéra 9.54.
      J'ai aussi testé sous d'autres navigateurs sans succès.

      On remarque bien que sous Opera, il y a un espace réservé aux images mais elles ne s'affichent pas.

      En local ça fonctionne pour un autre site en test.
      Fichiers joints
      Joomla! 1.5.23 / Virtumart 1.1.9 / AllEvents beta 1.1

      Commentaire


      • #4
        il y avait des pistes sur ce post
        http://forum.joomla.fr/showthread.ph...light=plongeur

        et ici
        http://forum.joomla.fr/showthread.ph...ges+miniatures

        vois si ca peut fonctionner pour toi
        sommaire thématique des astuces du forum e-commerce ici http://www.webtimarket.com/fr/telechargements
        http://virtuemart.fr

        Commentaire


        • #5
          J'ai été attiré par le problème GD mais c'est installé sur mon serveur [vérifié avec phpinfo()]. Je ne vois vraiment pas d'où viendrait ce problème. Je n'ai pas de module particulier activé (hormis Virtuemart mais sa désactivation entraine fatalement la suppression de l'affichage des produits... ). Il n'y a pas non plus de SEF activé et GZIP activé ou désactivé ne change rien.
          Je patauge...
          Joomla! 1.5.23 / Virtumart 1.1.9 / AllEvents beta 1.1

          Commentaire


          • #6
            quelle extension ont tes images ? jpg, png, ... ?
            sommaire thématique des astuces du forum e-commerce ici http://www.webtimarket.com/fr/telechargements
            http://virtuemart.fr

            Commentaire


            • #7
              du classique, rien que du classique : jpg
              Joomla! 1.5.23 / Virtumart 1.1.9 / AllEvents beta 1.1

              Commentaire


              • #8
                verifie aussi administrator/components/com_virtuemart/virtuemart.cfg.php

                que tes adresses sont les bonnes partout
                sommaire thématique des astuces du forum e-commerce ici http://www.webtimarket.com/fr/telechargements
                http://virtuemart.fr

                Commentaire


                • #9
                  Tout me semble normal mais je vais néanmoins comparer avec un autre fichier ce week-end. Une autre piste ?
                  Joomla! 1.5.23 / Virtumart 1.1.9 / AllEvents beta 1.1

                  Commentaire


                  • #10
                    QUestion bête , as-tu tes images d afficher dans l'admin des produits? dans virtuemart.
                    MOi, par exemple je me suis déja trompé en envoyant par CSVI (virgule a la place du point)
                    donc commence par le debut

                    Sinon change voir de flypage.tpl.php,

                    pour l'affichage des vignettes dans le flypage, c'est <?php echo $product_image ?>

                    donc si tu as pas ce code dans le flypage, c'est pas bon.

                    TU peux verifier ton code qui t'envoie les image c'est le fameux shop.browse.php(dans l'admin/component/comvrituemart/html/)

                    Voila, VOila .
                    Sans le code je peut pas faire beaucoup plus, désolé.
                    http://www.st42.fr : Astuce et téléchargement d’extension Joomla! et virtuemart
                    http://shop.st42.fr Catalogue extentions gratuit et Pro pour Virtuemart et Joomla

                    Commentaire


                    • #11
                      Malheureusement, ces indications en m'aident pas énormément dans la mesure où je ne suis pas assez affuté pour trouver une éventuelle erreur de codage dans le php.

                      Si quelqu'un a Skype, ce serait chouette de pouvoir discuter en live pour explorer quelques pistes. Parce que là je tourne en rond et c désagréable.

                      j'ai vérifié la version de PHP pour GB et tout est ok, flypage.tpl.php est d'origine donc je ne vois pas pourquoi ça n'irait pas. J'ai même remplacé par flypage.tpl.php d'une autre installation offline qui est opérationnelle.
                      shop.browse.php ne semble pas affecté non plus mais encore une fois, pas de point de comparaison valable pour ça.
                      Dans le détail du produit, pour rappel, les images s'affichent ! mais pas quand les produits sont listés dans les catégories (voir images postées plus haut).

                      Rdv sur Skype donc si intéressé.
                      Joomla! 1.5.23 / Virtumart 1.1.9 / AllEvents beta 1.1

                      Commentaire


                      • #12
                        l'affichage dans le flypage n'est pas géré par shop.browse.php mais par shop.productdetails.php
                        Donc le fait que tu as tes images dans le flypage veut dire qu'il sont au bon endroit
                        envoie en Zip ou copie colle ton shop.browser.php ici
                        et ton browse1.php
                        Je regarderais ce qui cloche si possible prochainement
                        http://www.st42.fr : Astuce et téléchargement d’extension Joomla! et virtuemart
                        http://shop.st42.fr Catalogue extentions gratuit et Pro pour Virtuemart et Joomla

                        Commentaire


                        • #13
                          Le problème ne se résout toujours pas à mon plus grand désarroi.
                          Voici en pièce jointe le fichier shop.product_details.php pour examen.
                          Si vous avez d'autres suggestions, je suis toujours preneur.

                          Pour rappel, j'ai déjà désinstallé et réinstallé VM1.1.3 une fois sans que cela ne corrige le problème. J'ai déjà pas mal de produits enregistrés et modules de paiement / expédition configurés... j'espère qu'on ne me proposera pas une nouvelle désinstallation / install.
                          Fichiers joints
                          Joomla! 1.5.23 / Virtumart 1.1.9 / AllEvents beta 1.1

                          Commentaire


                          • #14
                            Si tu as un site en ligne ou il y a le problème, ce sera plus facile.
                            La y a pas d'erreur visible sur ce fichier
                            Mais bon y a des fonctions qui génèrent le fichier et/ou le lien.
                            De faite il me faudrait ton
                            shop.browser.php ici
                            et ton browse1.php

                            (si tu utilise bien celui la)
                            http://www.st42.fr : Astuce et téléchargement d’extension Joomla! et virtuemart
                            http://shop.st42.fr Catalogue extentions gratuit et Pro pour Virtuemart et Joomla

                            Commentaire


                            • #15
                              regarde dans
                              virtuemart.cfg.php
                              // these path and url definitions here are based on the Joomla! Configuration
                              define( 'URL', 'http://localhost/electrocity/' );
                              define( 'SECUREURL', 'http://localhost/electrocity/' );
                              si tu as bien http://lenomdetonsite.be/shop/
                              http://www.st42.fr : Astuce et téléchargement d’extension Joomla! et virtuemart
                              http://shop.st42.fr Catalogue extentions gratuit et Pro pour Virtuemart et Joomla

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X