Retour intempestif à la page d'accueil

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Retour intempestif à la page d'accueil

    Salut à tous,

    J'ai des problèmes de retour à la page d'accueil du site quand,

    Je suis dans l'étape de choix d'adresse et que je passe à l'étape suivante (si je n'active pas cette étape de choix d'adresse, pas de problème)
    Je met à jour le panier sur un nombre d'article
    Je met à la poubelle un article
    Je met à jour le profil de compte

    Bref n'y aurait-il pas un problème ajax ou quelque chose du même type ...

    Merci pour votre aide
    Dernière édition par gbygby à 05/08/2009, 08h31
    Faites du bruit, JOOMLA is the best ...
    Quel pieds ce truc, j'en découvre tous les jours ...

  • #2
    Bonsoir tu veux dire que selon ce que tu actives dans le panier tu retournes dans une page kelkonke c ça?

    @+
    SVP pas de MP pour de l'aide, le forum est l’outil idéal

    Commentaire


    • #3
      Non c'est pas ça

      Si je passe une commande, j'ai mon panier quelque soit ce que j'ai dedans, je passe à l'étape suivante en cliquant sur Commander.

      c'est à dire l'étape de confirmation des adresses facturation et livraison et là quand je clique sur Suivant je passe à la page d'accueil

      Si je désactive cette étape ou si je l'associe à l'étape de choix du mode de livraison (ce qui est possible dans le param) je n'ai pas cette erreur.

      J'ai la même erreur sur toutes les MAJ du panier : recalcule du nombre de produits ou mise à la poubelle d'un produit

      Ou il y a un param qui ne lui plait pas dans les adresses ?

      Bref je sèche depuis 2 heures, sans succès

      Autre essai si je passe l'étape de choix expédition avant le choix adresse, ça plante comme si passage de l'étape 1 posait problème quelque soit l'étape ???
      Dernière édition par gbygby à 26/07/2009, 17h43
      Faites du bruit, JOOMLA is the best ...
      Quel pieds ce truc, j'en découvre tous les jours ...

      Commentaire


      • #4
        c'est à dire l'étape de confirmation des adresses facturation et livraison et là quand je clique sur Suivant je passe à la page d'accueil
        Alors là l'ami je t'arrête de suite

        Car moi aussi j'avais ce type de problème sur mon site.
        Ont ma dit il y a 3 mois sur un post "il faut mettre le composant de réécriture pour corriger cela" (hein PAT )

        Et moi la grosse feignasse je me suis dis mais kes kil me dit le PATSXM…encore un composant a mettre et à paramétrer

        Et oui il avait raison, le seul moyen de pourvoir avoir un site en 2 parties du style :

        1er partie en index pour l’accueil de votre site avec des infos des trucs hors virtuemart etc…
        2ème partie une boutique de vente en ligne avec le composant virtuemart
        (exemple de structure pour me faire comprendre)

        Et de faire de la réécriture sur le site car certains éléments de virtuemart aiment et mangent de l’index.php dans leur fonctionnement (donc retournent à chaque fois sur la partie hors boutique)

        Petite astuce car je viens de finaliser mes réglages il y a une heure sur ce sujet.

        Pour réécrire les url’s du panier en autre mais aussi sur les autres fonctions appelant virtuemart, il te faut un site en local (back-up par exemple) identique au site que tu souhaites réécrire.

        Pourquoi ? Parce que tu arriveras plus facilement à personnaliser la réécriture en prenant comme exemple les bons id’s et appellation virtuemart sur l’adresse sans réécriture.
        En passant par l’option redirections personnalisés tu arriveras facilement à donner aux URL non SEF le bon pointage.

        Bon c vrai c’est brumeux ce que je dis ci dessus mais tu verras en commençant la réécriture tu comprendras ce que je veux te dire.

        @+
        SVP pas de MP pour de l'aide, le forum est l’outil idéal

        Commentaire


        • #5
          J'active sh404SEF on va bien voir, merci pour ta réponse.

          Ce que je n'aime pas comme toi quand je prépare un site en test ...
          Faites du bruit, JOOMLA is the best ...
          Quel pieds ce truc, j'en découvre tous les jours ...

          Commentaire


          • #6
            OK plus de problème de passage mais ...

            J'ai sur les 2 étapes choix adresses et taux d'expédition
            Code:
            Notice:  Undefined property:  vmLanguage::$_PHPSHOP_CHECKOUT_TITLE in /home/ochdev/www/components/com_sh404sef/meta_ext/com_virtuemart.php on line 119
            
            Notice:  Undefined property:  vmLanguage::$_PHPSHOP_CHECKOUT_TITLE in /home/ochdev/www/components/com_sh404sef/meta_ext/com_virtuemart.php on line 121
            Et une perte de style CSS sur ces mêmes étapes
            Faites du bruit, JOOMLA is the best ...
            Quel pieds ce truc, j'en découvre tous les jours ...

            Commentaire


            • #7
              Laisses le SH404 travailler un temps car faut k'il boss les réécritures et cela peut prendre du temps.

              Astuce pour voir le SH404 bosser sur votre site, activez "qui est en ligne" et vous verrez que vous aurez 10 visiteurs d'un coup.

              @+
              SVP pas de MP pour de l'aide, le forum est l’outil idéal

              Commentaire


              • #8
                Après effectivement c du cas par cas ce type de problème il te faudra aller dans la liste des url's pour voir ce qui cloche.
                Tu auras aussi et personnaliser certaines d'entrent-elles.

                @+ et bonne chance car le SH404 est avec toi et moi il me tenu la jambe pendant 1 semaine donc maintenant je souffle.

                A petite précision il te faudra sûrement faire des essais avec les 3 types de réécritures car le SH404 et un super outil mais il te faut trouver le bon paramétrage pour ton site et selon le serveur.
                Avec ou sans htaccess par exemple.
                SVP pas de MP pour de l'aide, le forum est l’outil idéal

                Commentaire


                • #9
                  Merci pour ton aide et tes conseils
                  Faites du bruit, JOOMLA is the best ...
                  Quel pieds ce truc, j'en découvre tous les jours ...

                  Commentaire


                  • #10
                    Tu a remarqué les petits lutins de SH404 qui bossent sur le site?

                    Astuce pour voir le SH404 bosser sur votre site, activez "qui est en ligne" et vous verrez que vous aurez 10 visiteurs d'un coup.
                    @+
                    SVP pas de MP pour de l'aide, le forum est l’outil idéal

                    Commentaire


                    • #11
                      J'ai pas vu les lutins, mais je regarderai ...

                      Pour fixer le bug précédent

                      http://forum.virtuemart.net/index.ph...6905#msg136905

                      Ca marche nickel
                      Dernière édition par gbygby à 26/07/2009, 21h33
                      Faites du bruit, JOOMLA is the best ...
                      Quel pieds ce truc, j'en découvre tous les jours ...

                      Commentaire

                      Annonce

                      Réduire
                      1 sur 2 < >

                      C'est [Réglé] et on n'en parle plus ?

                      A quoi ça sert ?
                      La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                      Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                      Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                      Comment ajouter la mention [Réglé] à votre discussion ?
                      1 - Aller sur votre discussion et éditer votre premier message :


                      2 - Cliquer sur la liste déroulante Préfixe.

                      3 - Choisir le préfixe [Réglé].


                      4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                      2 sur 2 < >

                      Assistance au forum - Outil de publication d'infos de votre site

                      Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                      Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                      Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                      UTILISER À VOS PROPRES RISQUES :
                      L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                      Problèmes connus :
                      FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                      Installation :

                      1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                      Archive zip : https://github.com/AFUJ/FPA/zipball/master

                      2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                      3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                      4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                      5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                      6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                      et remplacer www. votresite .com par votre nom de domaine


                      Exemples:
                      Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                      Télécharger le script fpa-fr.php dans: /public_html/
                      Pour executer le script: http://www..com/fpa-fr.php

                      Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                      Télécharger le script fpa-fr.php dans: /public_html/cms/
                      Pour executer le script: http://www..com/cms/fpa-fr.php

                      En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                      Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                      Voir plus
                      Voir moins
                      Travaille ...
                      X