Joomla, VirtueMart et IE - Décalage du site

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Joomla, VirtueMart et IE - Décalage du site

    Bonjour à tous !

    Bon, j'ai déjà essayé de regarder au travers le forum, je n'ai rien trouvé pour m'aider !
    Mon soucis est relativement simple :
    Sur Firefox, le template pour VirtueMArt est parfait.
    Sur IE, le template, et QUE pour la section boutique, est décalé vers le bas.

    Voici un exemple en images de ce décalage. On aperçoit une petite marge blanche supplémentaire sous les onglets.




    Le site n'est pas encore en ligne, mais avez vous une idée du pourquoi ?
    Une petite piste ???

    Merci !
    Antoine
    Dernière édition par grobigou à 28/07/2009, 10h37

  • #2
    Si le pb est avec IE8, il faut installé le plugin de compatibilité IE8, y a un post sur le forum; mais je sais plus où exactement
    La critique est facile mais l'art est difficile
    Quand on cherche on trouve
    http://www.gcsites.fr

    Commentaire


    • #3
      il faut installé le plugin de compatibilité IE8
      il existe suis pas au courant
      Mais si oui "il existe" alors il me le faut c sur! kel mer*** ce IE

      C pas plutot ceci post 9
      http://forum.joomla.fr/showthread.php?t=89922&page=17
      Faut voir si cela corrige le problème

      @+
      SVP pas de MP pour de l'aide, le forum est l’outil idéal

      Commentaire


      • #4
        Le plugin IE8 est ici
        La critique est facile mais l'art est difficile
        Quand on cherche on trouve
        http://www.gcsites.fr

        Commentaire


        • #5
          Envoyé par grobigou Voir le message
          Bonjour à tous !

          Bon, j'ai déjà essayé de regarder au travers le forum, je n'ai rien trouvé pour m'aider !
          Mon soucis est relativement simple :
          Sur Firefox, le template pour VirtueMArt est parfait.
          Sur IE, le template, et QUE pour la section boutique, est décalé vers le bas.

          Voici un exemple en images de ce décalage. On aperçoit une petite marge blanche supplémentaire sous les onglets.

          Le site n'est pas encore en ligne, mais avez vous une idée du pourquoi ?
          Une petite piste ???

          Merci !
          Antoine
          http://forum.joomla.fr/showthread.php?t=89922 post #5) - 3) Fiche Bricolage 1
          sommaire thématique des astuces du forum e-commerce ici http://www.webtimarket.com/fr/telechargements
          http://virtuemart.fr

          Commentaire


          • #6
            Merci gentil_manager

            je ne le savais pas.

            Pat nous la mis dans le topic astuce?

            @+
            SVP pas de MP pour de l'aide, le forum est l’outil idéal

            Commentaire


            • #7
              Re !

              Et merci à tous pour les réponses !

              Alors : En ajoutant le plugin pour IE8, le problème est bien corrigé en IE8
              C'est déjà ça !!!

              Mais en IE7 par exemple, le problème est toujours là.
              Alors j'ai regardé les autres idées, comme le <br class="clr" /> ou le BR qui suit dans le browse header category.php. Pas de résultats, cette marge blanche est toujours là.

              Je continue de regarder...

              Antoine

              Commentaire


              • #8
                Il y a un plugin aussi pour IE7

                Dans le lien que je te donne ci dessus

                @+
                SVP pas de MP pour de l'aide, le forum est l’outil idéal

                Commentaire


                • #9
                  as-tu la recriture d'url activee ?
                  sommaire thématique des astuces du forum e-commerce ici http://www.webtimarket.com/fr/telechargements
                  http://virtuemart.fr

                  Commentaire


                  • #10
                    Je crois qu'il faut que tu modifie le css en mettant une condition pour ie.

                    Quand un objet est positionné par rapport au "top" ca crée un décallage avec ce f**king navigateur

                    Je sais plus trop mais c'est un truc connu si tu cherches sur google tu vas trouver

                    Commentaire


                    • #11
                      peut etre avec ce topic
                      http://forum.joomla.fr/showthread.php?t=89922&page=23 post #204
                      sommaire thématique des astuces du forum e-commerce ici http://www.webtimarket.com/fr/telechargements
                      http://virtuemart.fr

                      Commentaire


                      • #12
                        Bonjour tout le monde !

                        Bon merci encore pour ces pistes !
                        Concernant la redirection d'URL, non je n'ai pas ça.
                        Et concernant les CSS, oui c'est une bonne piste, je vais tacher de trouver le bon css !!!

                        Je continue mes recherches !

                        Bon mardi
                        Antoine

                        Commentaire


                        • #13
                          Quand un objet est positionné par rapport au "top" ca crée un décallage avec ce f**king navigateur
                          Je sais plus trop mais c'est un truc connu si tu cherches sur google tu vas trouver
                          Bonjour

                          Idem décalage dans les left du site j'ai déactivé le plugin car je n'ai pas problème majeur avec IE8 sauf kelke images qui apparaissent comme introuvable selon la page mais après navigation elles se mettent en place.

                          Pour kel f**king ce navigateur je te soutien dans ce sens.
                          La plus grosse boite avec le plus gros CA au monde nous sort vraiment un truc pas sympa pour nous les joomleur et franchement cela me désespère!

                          @+
                          SVP pas de MP pour de l'aide, le forum est l’outil idéal

                          Commentaire


                          • #14
                            Bonjour !!! (encore)

                            J'ai trouvé grace à vous !
                            J'ai donc utilisé le IE Developper Tools
                            J'ai pu correctement voir d'où venait cette barre blanche !
                            Elle venait d'un <div class="clr"></div>
                            Présent dans \templates\siteground-j15-58/index.php

                            Je l'ai mis en commentaire du coup, sauvegardé, et regardé le résulat.
                            C'est OK ! Pour IE ou Firefox, je pensais à des effets de bords, mais apparemment non.

                            Merci à vous tous !
                            Antoine

                            PS : On peut passer ce topic en réglé pour moi

                            Commentaire


                            • #15
                              On peut passer ce topic en réglé pour moi
                              Ben alors va y!

                              @+ et bonne continuation
                              SVP pas de MP pour de l'aide, le forum est l’outil idéal

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X